Vai al contenuto

Anet A8 non si collega al PC


 Condividi

Messaggi raccomandati

Salve

ecco il primo problema, (Anet A8, pc windows 10, cura 4.3.0)

Appena finito di montare la A8 ho effettuato la prima stampa di prova da scheda SD, la seconda stampa è stata un oggetto disegnato con freecad e preparato con Cura 4.3.0, inviato correttamente alla stampante via USB con risultati decenti, dopo due giorni ho ripreso con un progettino ma il pc non si collega più alla stampante, Cura afferma che non ci sono stampanti collegate anche se la gestione di windows mi segnala un dispositivo usb collegato correttamente USB serial CH340). Ho provato tutto quello che mi è venuto in mente, accendi e spegni, reset, insulti e blandizie, aglio appeso alla stampante e al pc ma niente da fare le due entità continuano ad ignorarsi.

Qualcuno ha idea di cosa è capitato e di come risolvere il problema?

Grazie in anticipo a tutti

Link al commento
Condividi su altri siti

  • Risposte 7
  • Creato
  • Ultima Risposta

Miglior contributo in questa discussione

Miglior contributo in questa discussione

1 ora fa, Graybear dice:

provato tutto quello che mi è venuto in mente, accendi e spegni, reset, insulti e blandizie, aglio appeso alla stampante e al pc ma niente da fare le due entità continuano ad ignorarsi.

hai dimenticato insulti e abbondante acqua santa per togliere il demonio cinese dalla stampante!

 

parlando seriamente, se non hai modificato nulla nel pc mi viene quasi da pensare ad un danno hardware anche se improbabile....

puoi riscaricare il driver qui: https://cfpmanfredini.wordpress.com/2016/02/28/installare-i-driver-corretti-per-arduino-con-chip-ch340-ch340g-e-ch341/

e tentare di nuovo.

ricordati di inserire il cavo usb sempre nella stessa porta, non è detto che il pc riconosca lo stesso dispositivo quando collegato ad una porta\usb diversa da quella dove era stato installato

Link al commento
Condividi su altri siti

I driver sono aggiornati all'ultima versione e il comportamento non cambia qualunque porta USB io usi, lo strano è che se faccio partire una stampa da SD con la stampante collegata e Cura attivo va tutto bene ma se esco da Cura la stampante termina il lavoro e va in idle.

Sembra che la cinesina recepisca qualche comando dal PC ma solo quelli che vuole lei, preso da insana follia e amore per il rischio ho provato ad aggiornare il firmware della stampante ma l'IDE di Arduino non riesce a caricarlo perché la stampante non risponde, cosa mai capitata con tutte le altre schede Arduino usate fino ad ora.

Sto incominciando a pensare che l'unica soluzione sia quella di resettare l'A8 ricaricando il bootloader (cosa che non ho mai fatto) e caricando poi il firmware aggiornato... il rischio è quello di trovarmi con un ammasso di plastica, metallo e semiconduttori completamente inutilizzabile.

Idee meno perniciose?

Link al commento
Condividi su altri siti

2 ore fa, Graybear dice:

Idee meno perniciose?

ogni cosa è meno pericolosa di quello che vuoi fare ... scambiare i firmware non è mai una buona idea,,,,,

non ho capito questa cosa: faccio partire una stampa da SD con la stampante collegata e Cura attivo va tutto bene ma se esco da Cura la stampante termina il lavoro e va in idle.

Link al commento
Condividi su altri siti

Provo a spiegarmi meglio, io avvio Cura, affetto il modello e carico il gcode sulla SD che tolgo dal PC e inserisco sull'A8, da pc avvio i preriscaldamenti e quando sono in temperatura dal pannello dell'A8 avvio la stampa da SD e fin qui tutto bene il che mi fa pensare che pc e stampante abbiano un certo feeling anche se non sufficiente a consentire la stampa "online", se però a qualunque punto della stampa io chiudo cura la stampa si ferma come se avesse finito il lavoro.

A questo punto penso di tenere le cose come stanno, riesco a stampare e se chiudo Cura prima di iniziare la stampa non ho problemi. l'unica cosa che mi spiace è il dover mettere e togliere l'SD sperando che le operazioni ripetute (all'inizio fra prove ed errori lo sto facendo spesso) non creino problemi all'alloggiamento della SD sull'A8 e l'avere un oggetto che non funziona al 100% come dovrebbe.

Grazie per la collaborazione e se ti viene qualche idea per risolvere il problemino fammi sapere.

Link al commento
Condividi su altri siti

Dunque.... Premesso che a mio parere stampare cura via usb è pessimo perché hai pochissimi controlli... Io faccio così :

A) Disabilitato plugin usb in cura così cura non impegna la seriale / usb e non resetta la stampante.

B) stampo via SD (non impegna il PC)

B bis) in alternativa per piccole cose o test, salvo il gcode sul PC e lo stampo via usb aprendolo da repetier host che ha molti più controlli della stp

Anycubic kossel linear plus,
Inviato utilizzando Tapatalk

Link al commento
Condividi su altri siti

Provo a spiegarmi meglio, io avvio Cura, affetto il modello e carico il gcode sulla SD che tolgo dal PC e inserisco sull'A8, da pc avvio i preriscaldamenti e quando sono in temperatura dal pannello dell'A8 avvio la stampa da SD e fin qui tutto bene il che mi fa pensare che pc e stampante abbiano un certo feeling anche se non sufficiente a consentire la stampa "online", se però a qualunque punto della stampa io chiudo cura la stampa si ferma come se avesse finito il lavoro.
A questo punto penso di tenere le cose come stanno, riesco a stampare e se chiudo Cura prima di iniziare la stampa non ho problemi. l'unica cosa che mi spiace è il dover mettere e togliere l'SD sperando che le operazioni ripetute (all'inizio fra prove ed errori lo sto facendo spesso) non creino problemi all'alloggiamento della SD sull'A8 e l'avere un oggetto che non funziona al 100% come dovrebbe.
Grazie per la collaborazione e se ti viene qualche idea per risolvere il problemino fammi sapere.
Ma da un programma come repetitier host riesci a collegarti? Prova ad abbassare i Baud rate. Rimuovi i driver e ricaricati installandoli quando hai collegato la stampante. Hai modo infine di provare su altro pc?

Inviato dal mio SM-G965F utilizzando Tapatalk

Link al commento
Condividi su altri siti

Problema risolto, dopo aver rimediato ad una piccola distrazione con l'IDE Arduino ho aggiornato il firmware con il software Marlin e dopo aver modificato un paio di parametri per evitare l'iniziale thermal runaway quando si attivava il ventilatore dell'estrusore adesso va alla grande e i pezzi piccoli li stampo via USB.

Adesso posso cimentarmi con i problemi di stampa (qualità, aspetto eccetera) ma penso di riuscire a risolverne la maggior parte dopo la lettura di qualche manuale ed eventualmente chiedendo qui.

Grazie per l'assistenza e la disponibilità.

Link al commento
Condividi su altri siti

Partecipa alla conversazione

Puoi pubblicare ora e registrarti più tardi. Se hai un account, accedi ora per pubblicarlo con il tuo account.

Ospite
Rispondi a questa discussione...

×   Hai incollato il contenuto con la formattazione.   Rimuovere la formattazione

  Sono consentiti solo 75 emoticon max.

×   Il tuo collegamento è stato incorporato automaticamente.   Mostra come un collegamento

×   Il tuo contenuto precedente è stato ripristinato.   Pulisci editor

×   Non puoi incollare le immagini direttamente. Carica o inserisci immagini dall'URL.

 Condividi


×
×
  • Crea Nuovo...