Vai al contenuto
  • Benvenuto!

     

CR20 pro: Calibrazione PID del piatto -> PID Autotune failed! Bad extruder number


Messaggi raccomandati

Ciao
come da soggetto, sto calibrando il PID per il piatto riscaldato della mia stampante. Mentre la calibrazione del PID dell'hotend e' andata via liscia, quando inserisco il comando

M303 E-1 S60 C8

da console, ottengo il seguente errore

PID Autotune failed! Bad extruder number

Guardando i G Codes, il parametro E-1 del comando M303 fa proprio riferimento all'heated bed 😞

 

Avete qualche idea su cosa non va?

Grazie

Link di questo messaggio
Condividi su altri siti
  • Risposte 6
  • Creato
  • Ultima Risposta

Miglior contributo in questa discussione

Miglior contributo in questa discussione

Messaggi Popolari

M303 E-1 S60 C8 è gusto, devi decommentare #define PIDTEMPBED in Marlin2 e vedrai che lo accetta logicamente dopo che avrai decommentato #define PIDTEMPBED dovrai ricaricare il firmware

secondo me non ci va -  m303 E1 S60 C5 (piu' cicli per il piano  non li vedo utili) comunque spesso questa funzione (pid bed) è disabilitata anche se in questo l'errore dovrebbe essere diver

secondo me ha ragione @FoNzY nel tuo firmware il PID del bed non è abilitato

3 ore fa, dnasini ha scritto:

Avete qualche idea su cosa non va?

secondo me non ci va - 

m303 E1 S60 C5 (piu' cicli per il piano  non li vedo utili)

comunque spesso questa funzione (pid bed) è disabilitata anche se in questo l'errore dovrebbe essere diverso

  • Like 1
Link di questo messaggio
Condividi su altri siti
20 hours ago, FoNzY said:

secondo me non ci va - 

m303 E1 S60 C5 (piu' cicli per il piano  non li vedo utili)

comunque spesso questa funzione (pid bed) è disabilitata anche se in questo l'errore dovrebbe essere diverso

Ciao

provaato in questo momento ma senza "-" con il medesimo errore. In effetti anche il comando M303 ca sito marlin recita

[E<index>]

Hotend index (-1 for heated bed). Default 0.

Link di questo messaggio
Condividi su altri siti

In effetti ho trovato qualche articolo in giro che associava questo errore alla non abilitazione nel firmware del PID del bed. Sinceramente non ci perdo il sonno se nn riesco a calibrarlo. Ad ogni modo, se volessi farlo, cosa dovrei fare per abilitarlo?

Link di questo messaggio
Condividi su altri siti
  • 1 mese dopo...

Partecipa alla conversazione

Puoi pubblicare ora e registrarti più tardi. Se hai un account, accedi ora per pubblicarlo con il tuo account.

Ospite
Rispondi a questa discussione...

×   Hai incollato il contenuto con la formattazione.   Rimuovere la formattazione

  Sono consentiti solo 75 emoticon max.

×   Il tuo collegamento è stato incorporato automaticamente.   Mostra come un collegamento

×   Il tuo contenuto precedente è stato ripristinato.   Pulisci editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Crea Nuovo...