Vai al contenuto

windom46

Membri
  • Numero contenuti

    14
  • Iscritto

  • Ultima visita

Reputazione Forum

6 Neutral

Su windom46

  • Grado
    Matricola

Visite recenti

Il blocco dei visitatori recenti è disabilitato e non viene mostrato ad altri utenti.

  1. windom46

    Tronxy X5S

    A proposito di vincolo delle viti trapezie dell'asse Z, io ho risolto così: 2 pulegge da 16 denti scaricate dal sito della Poggi e una cinghia da 1100mm, passo metrico, 5mm sempre della Poggi. Tensione perfetta, senza tendicinghia Mai più disallinamenti !!! allego anche i file delle pulegge X5SA.rar
  2. M303 E-1 S60 C8 è gusto, devi decommentare #define PIDTEMPBED in Marlin2 e vedrai che lo accetta logicamente dopo che avrai decommentato #define PIDTEMPBED dovrai ricaricare il firmware
  3. windom46

    Problemi Tronxy X5Sa-2E

    Anch'io mi trovo bene con il firmware originale che è calibrato molto bene. Capita però che a parte l'asse Z che è gestito da viti trapezie con passo di 8mm e che con driver 4988 va impostato a 400 step/mm, per gli altri 2 assi, X e Y movimentati da cinghie dentate, gli step/mm vanno verificati e a volte corretti per vari motivi, tipo usura o tensione delle cinghie stesse. Io, per esempio, sulla Prusa I3proW per avere le misure corrette ho dovuto impostare X a 80,34 e Y a 80,42. Questo, dopo avere stampato una croce di mm 180x180 e corretto gli step/mm con la classica equazione. Sulla X5SA a d
  4. windom46

    Problemi Tronxy X5Sa-2E

    Ciao a tutti, ho acquistato anch'io da circa una settimana questa stampante ed ho subito fatto la modifica già fatta sulla Geeetech I3proW per vincolare le due viti dell’asse Z che non capisco perchè non venga già fatta in produzione. I due assi Z infatti vanno sempre controllati e allineati prima di ogni stampa in quanto si spostano solo sfiorandoli., Vincolandoli questo non è più necessario. Basta veramente poco, 2 pulegge da 16 denti che si possono scaricare dal sito della Poggi per molti programma di CAD (Autocad, Fusion360, ecc) ed una cinghia da 1100 mm. passo metrico 5mm. Non serve
  5. Funziona anche da PC, ero io che provavo con Repetier Host facendo la stampa a vuoto ma appena ho stampato davvero, tutto ok. Ho poi provato a togliere il CH340 e a collegare il modulo BT HC-05 sui pin 1,2,3,16 e funziona alla grande anche quello e senza cambiare nulla nel firmware. allego un paio di foto
  6. Ho scoperto che il cambio filamento funziona perfettamente ma solo con stampa da SD, adesso vedo di capire come farglielo fare anche da PC. Tutti i consigli sono graditi.
  7. ma io il ch340 lo tolgo proprio e mi collego direttamente al processore, per il livello segnale, come dici tu, con 2 resistenze si risolve. Non sapevo di questo bug, con la USB non dà nessun problema. Le 2 seriali D1 e D2 finiscono al display, sezione LCD ma non si capisce dove. Ho provato a scollegare il connettore a 10 pin e a collegare il modulo sia sulla D1 che sulla D2. Su una suona sempre il cicalino, sull'altra non funziona più l'encoder e non trovo nessun schema. l'LCD dialoga con il processore per conto suo via I2C. Il mio display + encoder è questo: https://www.geeetech.com
  8. Fatto ma non è cambiato nulla, praticamente le ho provate tutte. Ho l'inpressione che non riconosca il pin28 di Y_MAX, eppure l'asse Z controllato da BL-TOUCH (fili bianco/nero) collegati al pin 32 lo riconosce benissimo. Ho pure provato ad usare il connettore di X_MAX, pin 24 nel timore che Y_max sia passato a miglior vita, ma non cambia nulla. Per ora continuo così, sensa sensore FF in attesa di una soluzione. Avrei un'altra cosa da chiedere ma non so se questa è la sezione giusta. In pratica io non ho la possibilità di avere la stampante vicino al PC ma devo tenerla dal
  9. Come spiegato nel primo post, sul connettore di Y_MAX, che non viene usato, quindi tra il pin 28 e massa. La mia macchina ha solo i micro di homing ossia X,Y,Z min, però su Z viene usato anche Z max per il BLTOUCH. Il sensore, con il filo è LOW, senza filo HIGH
  10. Hai ragione, scusa, chissà a cosa pensavo. Ti allego la foto
  11. Il sensore e il 3d-touch(clone del BLTOUCH) della Geeetech e l'ho collegato sul pin 28 (connettore Y_MAX, inutilizzato), per quello che avevo abilitato use_ymax_plug come gli altri pin di ingresso dei segnali di finecorsa XYZmin. Nel file src/pins/mega/...GT256_REV_A non esiste la possibilità di abilitarlo.
  12. advanced_pause_feature era già abilitata, comunque ti allego gli screeshots dei due file, magari ti suggeriscono qualche altra idea, per ora grazie
  13. Veniamo al dunque, ho provato ad installare il sensore di fine filamento con semplice micro, sulla mia Geeetech I3Pro W (scheda 2560 A+) ma non riesco a farlo funzionare. Il firmware è Marlin2.0.7.2 con i 2 file Configuration.h e Configuration.adv.h dedicati che compilo e carico con PlatformIO. Ho abilitato #define FILAMENT_RUNOUT_SENSOR ed ho aggiunto una linea #define FIL_RUNOUT_PIN 28 per abilitare il pin 28 dove l'ho collegato. Il pin 28, sulla mia scheda è Y_MAX ed è inutilizzato. Ho poi abilitato #define USE_YMAX_PLUG ma non succede nulla. Probabilmente c'è da cambiare qualcosa in Confir
  14. windom46

    Presentazione

    Eccoci qui con i problemi della stampa 3D, devo installare il sensore di fine filamento e mi serve una mano da parte vostra.
×
×
  • Crea Nuovo...