Vai al contenuto

Pausa prima di partire con la stampa da Octoprint


 Condividi

Messaggi raccomandati

Buongiorno a tutti, 

volevo una mano per capire il motivo per cui la stampante effettua delle pause prima di partire con la stampa, solo quando lancio una stampa da Octoprint. 

Quando lancio la stampa via web, la stampante porta in temperatura il piatto, l'ugello, fa l'homing e si mette in pausa prima di partire. Devo cliccare resume (per due volte) e poi va avanti fino alla fine senza problemi. La stampante prima di iniziare a stampare sembra rimanere in attesa di un input utente (per due volte), cosa che vorrei eliminare perché inutile e fastidiosa. Ovviamente se stampo da SD tutto ok. Suggerimenti su che cosa possa dipendere? E' nel GCODE o in qualche impostazione di Octoprint?

Link al commento
Condividi su altri siti

  • Risposte 6
  • Creato
  • Ultima Risposta

Miglior contributo in questa discussione

Giorni Popolari

@invernomuto il problema avviene con una stampante delta?

In rete dicono che se è una delta potrebbe dipendere dal fatto che richiede una potenza di calcolo tale, che potrebbe rallentare prima di partire, ma non so se può essere questo il problema.

Ho trovato anche che potrebbe dipendere dal comando M0 nel gcode. C'è un'opzione nelle impostazioni a cui togliere la spunta

settings -> Serial Connection -> Firmware & Protocol, and uncheck "Do not send M0/M1 commands to the firmware

Oppure edita il gcode rimuovendo il comando.

Dicono che usando la sd non va in pausa, proprio come hai descritto tu.

https://www.reddit.com/r/octoprint/comments/aoz4mq/octoprint_keeps_pausing_on_a_new_print_with_emder3/

 

Link al commento
Condividi su altri siti

@Davide87 ciao Davide, scusa ma dissento completamente della tua teoria della potenza di calcolo.... ovvero quando stampi con octoprint la stampante non viene in qualche modo sgravata dalla logica per caricare l'host octoprint...  octoprint continua a mandare il gcoce nè più nè meno come la sd e/o come un pc collegato, quindi la potenza di calcolo richiesta (effetivamente superiore  in una delta) continua ad essere un compito della scheda madre stampante nè più nè meno che come prima.

O almeno io la so così ma tant'è vero che quando provai octoprint sul mio RP B plus non ho dovuto mettere alcuna informazione di dettaglio della geometria della stampante (e se non conosci la geometria di una stampante delta col cavolo che la piloti).

Io avevo abbandonato perchè il mio RP B plus ( in pratica il primo rapsberry) non era abbastanza rapido per mandare i dati necessari e la stampante rallentava vistosamente nelle zone di stampe complicate (ma non è questo il suo caso sebbene possa sembrarlo). 

sui comandi M0 e M1 potersti avere ragione, in realtà non vedo motivo per cui siano presenti quei comandi in avvio di stampa.

 

Link al commento
Condividi su altri siti

5 minuti fa, marcottt dice:

Davide87 ciao Davide, scusa ma dissento completamente della tua teoria della potenza di calcolo.... ovvero quando stampi con octoprint la stampante non viene in qualche modo sgravata dalla logica per caricare l'host octoprint...  octoprint continua a mandare il gcoce nè più nè meno come la sd e/o come un pc collegato, quindi la potenza di calcolo richiesta (effetivamente superiore  in una delta) continua ad essere un compito della scheda madre stampante nè più nè meno che come prima.

O almeno io la so così ma tant'è vero che quando provai octoprint sul mio RP B plus non ho dovuto mettere alcuna informazione di dettaglio della geometria della stampante (e se non conosci la geometria di una stampante delta col cavolo che la piloti).

Scusami @marcottt, devo aver interpretato male io quello che c'era scritto, con ogni probabilità facevano riferimento a un problema di velocità di trasmissione dati, non di velocità di elaborazione dati, che in effetti non c'entra in questo caso

Link al commento
Condividi su altri siti

1 ora fa, Davide87 dice:

@invernomuto il problema avviene con una stampante delta?

In rete dicono che se è una delta potrebbe dipendere dal fatto che richiede una potenza di calcolo tale, che potrebbe rallentare prima di partire, ma non so se può essere questo il problema.

No, non è per la Delta ma per la Cartesiana. Non è un rallentamento, è proprio una pausa. Mi chiede un input utente per due volte. Una volta mi sono scordato di darlo ed è rimasta 10 minuti ferma a 190° / 55° in attesa del resume, cosa che ovviamente mi secca. Una volta dati i due resume, la stampa procede senza problemi fino alla fine con risultati più che buoni.

Cita

Ho trovato anche che potrebbe dipendere dal comando M0 nel gcode. C'è un'opzione nelle impostazioni a cui togliere la spunta

settings -> Serial Connection -> Firmware & Protocol, and uncheck "Do not send M0/M1 commands to the firmware

Oppure edita il gcode rimuovendo il comando.

Dicono che usando la sd non va in pausa, proprio come hai descritto tu.

https://www.reddit.com/r/octoprint/comments/aoz4mq/octoprint_keeps_pausing_on_a_new_print_with_emder3/

 

Stasera ti dico il GCode che uso. Quello che però non capisco è perché la pausa la faccia solo con Octoprint, non con la SD!

Link al commento
Condividi su altri siti

Partecipa alla conversazione

Puoi pubblicare ora e registrarti più tardi. Se hai un account, accedi ora per pubblicarlo con il tuo account.

Ospite
Rispondi a questa discussione...

×   Hai incollato il contenuto con la formattazione.   Rimuovere la formattazione

  Sono consentiti solo 75 emoticon max.

×   Il tuo collegamento è stato incorporato automaticamente.   Mostra come un collegamento

×   Il tuo contenuto precedente è stato ripristinato.   Pulisci editor

×   Non puoi incollare le immagini direttamente. Carica o inserisci immagini dall'URL.

 Condividi


×
×
  • Crea Nuovo...