Vai al contenuto

Retrazione in avvio


Messaggi raccomandati

Ciao a tutti, ho una U20 con su l'ultimo firmware ufficiale.

Sto stampando parecchio, per imparare e devo dire che i risultati sono davvero buoni, stampo solo pla e petg.

Da ieri all'improvviso in partenza la stampante mi lancia una retrazione che non sta da nessuna parte e ovviamente va a secco rovinando tutto.

Aumentare le linee di skirt o brim può essere una soluzione, ma vorrei davvero capire da dove viene sta retrazione, che tra l'altro appare anche su vecchi file stampati e ristampati.

Questo è il mio gcode 

E0 ; reset extruder

G1 Z1.0 F3000 ; move z up little to prevent scratching of surface

G1 X0.1 Y20 Z0.3 F5000.0 ; move to start-line position

G1 X0.1 Y200.0 Z0.3 F1500.0 E15 ; draw 1st line

G1 X0.4 Y200.0 Z0.3 F5000.0 ; move to side a little

G1 X0.4 Y20 Z0.3 F1500.0 E30 ; draw 2nd line

G92 E0 ; reset extruder

Come slicer uso ideamaker.....

Di fatto al 4 comando invece di estrudere ritrae e pure di tanto....

Accendere e spegnere non risolve.

A voi la sentenza, io penso trattasi di possessione demoniaca....

Link al commento
Condividi su altri siti

6 minuti fa, maggiolo72 ha scritto:

Questo è il mio gcode 

E0 ; reset extruder

G1 Z1.0 F3000 ; move z up little to prevent scratching of surface

G1 X0.1 Y20 Z0.3 F5000.0 ; move to start-line position

G1 X0.1 Y200.0 Z0.3 F1500.0 E15 ; draw 1st line

G1 X0.4 Y200.0 Z0.3 F5000.0 ; move to side a little

G1 X0.4 Y20 Z0.3 F1500.0 E30 ; draw 2nd line

G92 E0 ; reset extruder

Come slicer uso ideamaker.....

Di fatto al 4 comando invece di estrudere ritrae e pure di tanto....

Accendere e spegnere non risolve.

A voi la sentenza, io penso trattasi di possessione demoniaca....

Il primo comando E0 non ha senso. Il reset della posizione dell'estrusione è G92 E0. Cos' come è scritto se prima di partire hai fato andare avanti l'estrusore di 30mm o più è normale che al secondo e/o quarto movimento muova dalla parte sbagliata.

Rivedi lo start-gcode.

 

Link al commento
Condividi su altri siti

ciao grazie della risposta. 

così va bene ? 

 

G92 E0 ; reset extruder

G1 Z1.0 F3000 ; move z up little to prevent scratching of surface

G1 X0.1 Y20 Z0.3 F5000.0 ; move to start-line position

G1 X0.1 Y200.0 Z0.3 F1500.0 E15 ; draw 1st line

G1 X0.4 Y200.0 Z0.3 F5000.0 ; move to side a little

G1 X0.4 Y20 Z0.3 F1500.0 E30 ; draw 2nd line

G92 E0 ; reset extruder

 

Solo che non mi spiego perchè ho stampato ininterrottamente per giorni senza alcun problema, questo ad esempio è un pezzo di fusoliera, la riga è per un rinforzo in carbonio da 1mm, ne ho stampati 4 in fila ilgiorno prima dell'evento, 0 problemi

 

241749504_840539196833956_7314401641792401752_n.jpg

Link al commento
Condividi su altri siti

51 minuti fa, maggiolo72 ha scritto:

così va bene ? 

si

51 minuti fa, maggiolo72 ha scritto:

Solo che non mi spiego perchè ho stampato ininterrottamente per giorni senza alcun problema, questo ad esempio è un pezzo di fusoliera, la riga è per un rinforzo in carbonio da 1mm, ne ho stampati 4 in fila ilgiorno prima dell'evento, 0 problemi

Se accendi la stampante con il filamento già caricato fino al nozle, o riparti dopo una stampa con autohome non vedi differenze. Cambia solo se hai mosso l'estrusore prima dello start. Sicome di base il firmware interpreta le quote di G1 come assolute (c'è anche modi di impostare E come sempre incrementale ma secondo me da più problemi che altro) l'estrusore andrà avanti solo se è in posizione <15mm, altrimenti ritrae.

Il linguaggio Gcode non è molto complesso ma ha le sue regole di sintassi e di ordine dei comandi. Se non ci lavori o non l'hai fatto a scuola ci vuole un po a impararlo. 

  • Like 2
Link al commento
Condividi su altri siti

Ho effettuato la modifica ed è andato al primo colpo, incredibile, giuro che ho stampato per giorni interi con 0 problemi. Ne approfitto per un altra domanda, a volte specie sui primi Layer la ruota godronata mi scatta come se non riuscisse ad estrudere, succede un attimo e poi va. 

L'altezza è giusta, anche un pochino extra perchè sto stampando petg, anche la temperatura è ok ho fatto la torre e a 220 gradi avevo il risultato migliore.

La fine del filamento quando cambio rotolo si presenta cicciotta, credo sia quello ma non ho mai stampato oltre i 220 gradi e il teflon arriva a battuta sul noozle.

Che puo essere ?

 

242029291_1248816088922961_6091876532343853314_n.jpg

Link al commento
Condividi su altri siti

12 minuti fa, maggiolo72 ha scritto:

Che puo essere ?

Il primo strato di stampa più che scenza è arte 🤪.

Al di la delle facezie i fattori che fanno scattare l'estrusore possono essere tanti, per come la vedo io primo è l'impazienza che ti fa partire con la stampa appena vedi la temperatura anche se magari il nozle ci mette qualche secondo in più del termistore a scaldarsi, il secondo è il contrasto con il piano di stampa centinaia di gradi più freddo del filamento che ne blocca il flusso molto più del resto del modello qualche layer più su. E' per quello che in tutti gli slicer ci sono impostazioni di velocità temperatura e flusso indipendenti per il primo layer. Per quanto riguarda l'ingrossamento del il filamento può essere una causa ma non te lo saprei dire per certo: io uso solo gole all-metal e quei problemi non mi si sono mai presentati. Se sei sicuro che la temperatura sia corretta ti suggerirei di provare 5..10° in più per il primo layer e 25% di velocità in meno.

 

  • Like 2
Link al commento
Condividi su altri siti

Beh, per tante cose devi essere una specie di stregone per queste stampanti, specie per la fascia economica...

Allora per il petg vado a 225 per la velocità del primo layer mi sa che sono troppo lento, 25mm/s forse è anche quello il problema, che essendo così lenta non riesce ad estrudere bene. Disolito stampo il petg a 45mm/s adesso provo a mettere la velocità del primo layer a 40mm/s. Cmq sto valutando un direct drive o un tubo capricorn

 

Link al commento
Condividi su altri siti

Partecipa alla conversazione

Puoi pubblicare ora e registrarti più tardi. Se hai un account, accedi ora per pubblicarlo con il tuo account.

Ospite
Rispondi a questa discussione...

×   Hai incollato il contenuto con la formattazione.   Rimuovere la formattazione

  Sono consentiti solo 75 emoticon max.

×   Il tuo collegamento è stato incorporato automaticamente.   Mostra come un collegamento

×   Il tuo contenuto precedente è stato ripristinato.   Pulisci editor

×   Non puoi incollare le immagini direttamente. Carica o inserisci immagini dall'URL.

 Condividi


×
×
  • Crea Nuovo...