Vai al contenuto

Doppio asse z - steppers sfasati.


VITOM
 Condividi

Messaggi raccomandati

Salve. Ho comprato una IDEAFORMER GIANT con doppio asse Z. Prima di metterla in funzione ho fatto prove di spostamento e i 2 motori dell' asse Z si spostano in modo differente. Per 1 mm, uno fa un giro completo e l' altro circa un ottavo di giro.

Aggiungo che essendo un hobby non ho affatto esperienza, mi sono limitato ad un cilindro qualche anno fa con una economica. Però con AUTOCAD ci smanetto bene.

Link al commento
Condividi su altri siti

11 ore fa, VITOM ha scritto:

Per 1 mm, uno fa un giro completo e l' altro circa un ottavo di giro.

molto strano...

l'asse ti sembra dritto o palesemente storto? potrebbe essere che un motore non ce la fa a girare perche' la chiocciola è storta sulla vite?

 

hai provato a scambiare i fili dei motori? 

se li giri lentamente a mano senti differenze nell'attrito?

 

  • Like 1
Link al commento
Condividi su altri siti

Il 13/6/2022 at 20:22, FoNzY ha scritto:

1) l'asse ti sembra dritto o palesemente storto? potrebbe essere che un motore non ce la fa a girare perche' la chiocciola è storta sulla vite?

2) hai provato a scambiare i fili dei motori? 

3) se li giri lentamente a mano senti differenze nell'attrito?

 

Ciao.

1) Ho fatto la prova con i motori liberi dalle viti.

2) Ho scambiato proprio i motori ma i fili sarebbe infattibile perchè la distanza è troppo grande.

3) Ho scambiato i motori, e quindi non dovrebbe esserci attinenza con l' attrito.

Purtroppo non vedo in giro recensioni su ideaformer giant eppure mi sembra un buon affare con il cubo 40x40x40.

Link al commento
Condividi su altri siti

11 ore fa, VITOM ha scritto:

Purtroppo non vedo in giro recensioni su ideaformer giant eppure mi sembra un buon affare con il cubo 40x40x40.

lascia stare le recensioni, non servono a niente.

la stampante è ok, sicuramente in linea con le altre

11 ore fa, VITOM ha scritto:

1) Ho fatto la prova con i motori liberi dalle viti.

si ok e poi? le viti scorrono bene?

 

11 ore fa, VITOM ha scritto:

3) Ho scambiato i motori, e quindi non dovrebbe esserci attinenza con l' attrito.

il motore non è rotto, potrebbe essere il cavo o il driver ad esserlo...comunque dopo che hai scambiato i motori che è successo? sempre uguale?

Link al commento
Condividi su altri siti

Inviato (aggiornato)

Si sempre uguale. Quindi potrebbero essere i fili, ma allora sarebbe un difetto di fabbrica. E' improbabile che i fili debbano essere scambiati perchè, in quella stampante uno dei due motori ha il filo già predisposto, mentre l' altro l' ho dovuto mettere io, (credo di averlo messo bene), e la lunghezza dei fili è ridotta all' essenziale. Quindi non è possibile sia un problema di scambio di fili.

La prova con le viti l' ho fatta. Ho abbassato tutto l' asse e ho iniziato i movimenti, notando l' inclinazione. Quindi ho fatto la prova senza viti riscontrando il problema.

Modificato da VITOM
Link al commento
Condividi su altri siti

14 ore fa, VITOM ha scritto:

mentre l' altro l' ho dovuto mettere io

MA PORCA P.... magari dirlo prima? aò 99,99% il cavetto è fatto male e comunque non capisco perche' non c'era gia'...

dovrei spiegarti come fare un cavetto ma a lettere è difficile... prova tutte le combinazioni possibili dei 4 cavi prima o poi quella giusta la trovi...

  • Like 1
Link al commento
Condividi su altri siti

Solitamente è un problema piuttosto comune io quando ho messo il secondo asse nella Ender 3 Pro la porto dopo aver fatto l'homing dell'asse Z a 30mm poi con la bolla di livellamento la allineo girando a mano l'accoppiatore del secondo asse z.

Esistono altre soluzioni meccaniche su tutte le stampanti ma a livello firmware su Marlin ci sono diverse impostazioni per farlo autonomamente.

Il 15/6/2022 at 23:30, VITOM ha scritto:

sempre uguale. Quindi potrebbero essere i fili, ma allora sarebbe un difetto di fabbrica. E' improbabile che i fili debbano essere scambiati perchè, in quella stampante uno dei due motori ha il filo già predisposto, mentre l' altro l' ho dovuto mettere io, (credo di averlo messo bene), e la lunghezza dei fili è ridotta all' essenziale. Quindi non è possibile sia un problema di scambio di fili.

In serata devo farmi uno splitter per la CNC quindi ti posto delle foto con una spiegazione semplice su come fare a riconoscere i cavi con e senza colore e con intercambiare il tutto senza fatica

Link al commento
Condividi su altri siti

Il 20/6/2022 at 16:38, l0v3byte ha scritto:

Solitamente è un problema piuttosto comune io quando ho messo il secondo asse nella Ender 3 Pro la porto dopo aver fatto l'homing dell'asse Z a 30mm poi con la bolla di livellamento la allineo girando a mano l'accoppiatore del secondo asse z.

Esistono altre soluzioni meccaniche su tutte le stampanti ma a livello firmware su Marlin ci sono diverse impostazioni per farlo autonomamente.

In serata devo farmi uno splitter per la CNC quindi ti posto delle foto con una spiegazione semplice su come fare a riconoscere i cavi con e senza colore e con intercambiare il tutto senza fatica

Attendo con pazienza. Ma non so se è un fattore del livellamento l' asincronia dei motori. Cioè, le viti sono uguali ed i motori vanno per fatti loro, quindi la barra dell' estrusore si torce rischiando di spezzare le viti o la chiocciola. Prima di accendere la stampante devo risolvere il problema.

Link al commento
Condividi su altri siti

49 minuti fa, VITOM ha scritto:

Attendo con pazienza. Ma non so se è un fattore del livellamento l' asincronia dei motori. Cioè, le viti sono uguali ed i motori vanno per fatti loro, quindi la barra dell' estrusore si torce rischiando di spezzare le viti o la chiocciola. Prima di accendere la stampante devo risolvere il problema.

Allora lo vuoi, non non avendo avuto la risposta non lo mandato allora domani all'ora di pranzo di posto le foto.

Comunque se intendi che uno stepper manda un asse in giù e l'altro lo manda su allora i poli sono invertiti, come dicevo prima citando l'esempio sempre Creality le sue schede utilizzano i pinuot inverti degli stepper (che anche li non capisco la scelta che non ha senso) solitamente se uno ci mette un estrusore diretto tipo il DDE della triangle lab o il BMG ha due scelte:

1) Invertire i fili dal connettore o della scheda o dello stepper

2) Modificare il tutto dal firmware

La seconda scelta la fa chi ci mette un termoresitore più performante perché vuole stampare il nylon o il PEI e quindi usa temperature più elevate quindi al posto della sua pallina di vetro dell'estrusore stock ci mette minimo una pt1000, e visto che c'è ci aggiorna il numero dei passi dell'estrusore e i parametri di preriscaldamento del hotend, cose che può fare direttamente dalla stampante ma visto che c'è non se la mena due volte.

Chiedo ad @Alessandro Tassinari e a @Killrob se è passato il tempo giusto o ho il grado del forum adeguato per pubblicare nella sezione guide perché quando avevo fatto la guida su come modificare i parametri di LaserGRBL secondo le specifiche del proprio laser l'ho fatto sul un post nella sezione incisori laser ma questa va bene per tutte le macchine dalle CNC al laser e appunto alle stampanti 3d al limite se la guida risulta passabile le copiate voi sulla sezione guide.

Link al commento
Condividi su altri siti

Partecipa alla conversazione

Puoi pubblicare ora e registrarti più tardi. Se hai un account, accedi ora per pubblicarlo con il tuo account.

Ospite
Rispondi a questa discussione...

×   Hai incollato il contenuto con la formattazione.   Rimuovere la formattazione

  Sono consentiti solo 75 emoticon max.

×   Il tuo collegamento è stato incorporato automaticamente.   Mostra come un collegamento

×   Il tuo contenuto precedente è stato ripristinato.   Pulisci editor

×   Non puoi incollare le immagini direttamente. Carica o inserisci immagini dall'URL.

 Condividi


×
×
  • Crea Nuovo...