Vai al contenuto

Compilazione firmware Marlin ender 3v2 per estrusore Hemera


 Condividi

Vai alla soluzione Risolta da Killrob,

Messaggi raccomandati

Salve a tutti, premetto che sono nuovo al mondo della stampa 3D e anche se ho acquisito un bel po di nozioni sull'hardware a livello software sono ancora in alto mare...

Sto provando a compilare il firmware necessario ad installare L'hemera hot end sulla Creality ender 3v2, ma pur seguendo alla lettera le istruzioni rilasciate dalla E3d che è la casa produttrice dell'hemera...niente, il firmware non vuol saperne di funzionare correttamete.

Volevo chiedervi se qualcuno potesse seguirmi nell'intera procedura per capire dove e cosa sbaglio o comunque qualsiasi tipo di aiuto sarebbe ben accetto.

Grazie in anticipo a chi mi risponderà.

Link al commento
Condividi su altri siti

16 minuti fa, ReserB ha scritto:

Sto provando a compilare il firmware necessario ad installare L'hemera hot end sulla Creality ender 3v2, ma pur seguendo alla lettera le istruzioni rilasciate dalla E3d che è la casa produttrice dell'hemera...niente, il firmware non vuol saperne di funzionare correttamete.

Scusa la domanda ma l'Hemera è un estrusore diretto come ce ne sono tanti altri. Si differenzia dal bowden originale della Ender per step/mm e forse per senso di rotazione, entrambe modifiche che volendo non richiedono il cambio di firmware.

C'è qualche altra ragione che ti ha spinto all'impresa?

Comunque specifica quale sono i problemi che vediamo come risolvere.

  • Like 3
Link al commento
Condividi su altri siti

Inviato (modificato)

Non so di preciso, so solo che ovunque abbia letto dicono di ricompilare il firmware e da inesperto mi sono limitato a pensare "evita di essere arrogante e segui quel che dicono"

essendo anche riporetato nella guida ufficiale ho pensato fosse relativamente obbligatorio.

comunque penso che sia cambiata la posizione relativa di nozzle e bltouch quindi ora a partenza da endstop non si ritrovano piu le misure dell'homing.

ah ovviamente dovrei aumentare anche la temperatura massima portandola a 300 altrimenti non sfrutterei quella che è una delle caratteristiche di base dell'hemera con nozzle e gola in titanio, mi serve anche per il serraggio a caldo, dato che consigliano di farlo ad almeno 280 gradi e la temp massima attuale è 260

per il motore di estrusione e asse x mi sembra invece che ruotino nella corretta direzione gia con il mio vecchio firmware.

purtroppo non saprei che immagini allegare, perchè sono nel caos piu totale 😅

Modificato da ReserB
Avevo dimenticato di dire una cosa
Link al commento
Condividi su altri siti

nella prima immagine, è quello che mi appare appena inserisco i due file seguendo la guida, ci sono subito riportati 64 errori nel file configuration.h, nella seconda gli errori del file configuration_adv.h.

nella terza l'errore di compilazione

1.thumb.PNG.083679df18ff3a5e0f8c3d91fd0d705d.PNG

2.thumb.PNG.381b6d1113f01c94fc9fd07a69bdd239.PNG

3.thumb.PNG.91c368c3b20291417438c5b4d753f4fe.PNG

(questa è la guida a cui mi sto riferendo https://e3d-online.zendesk.com/hc/en-us/articles/360017968457-Hemera-Creality-Ender-3-V2-Firmware-Bl-touch-)

 

Link al commento
Condividi su altri siti

  • Soluzione
2 ore fa, ReserB ha scritto:

Salve a tutti, premetto che sono nuovo al mondo della stampa 3D e anche se ho acquisito un bel po di nozioni sull'hardware a livello software sono ancora in alto mare...

Sto provando a compilare il firmware necessario ad installare L'hemera hot end sulla Creality ender 3v2, ma pur seguendo alla lettera le istruzioni rilasciate dalla E3d che è la casa produttrice dell'hemera...niente, il firmware non vuol saperne di funzionare correttamete.

Volevo chiedervi se qualcuno potesse seguirmi nell'intera procedura per capire dove e cosa sbaglio o comunque qualsiasi tipo di aiuto sarebbe ben accetto.

Grazie in anticipo a chi mi risponderà.

allora... per prima cosa devi aprire la stampante e vedere che scheda monta perché o monta la 4.2.2 o la 4.2.7. se non parti da qui non ne verrai mai a capo.

Pirma recupera quell'informazione e poi proseguiamo

Link al commento
Condividi su altri siti

1 ora fa, Killrob ha scritto:

e visto l'errore che hai fatto vedere hai impostato anche la board giusta su configuration.h?

si penso di aver fatto giusto, nella guida mi dice di inserire questa stringa, e la mia scheda madre è la 4.2.2, per sicurezza ho ricontrollato per la 10 volta

639992660_schedamadre.thumb.PNG.e55d4eca761b908e05b2e52fbe961b9a.PNG

Link al commento
Condividi su altri siti

11 ore fa, ReserB ha scritto:

si penso di aver fatto giusto, nella guida mi dice di inserire questa stringa, e la mia scheda madre è la 4.2.2, per sicurezza ho ricontrollato per la 10 volta

Non ho capito se hai risolto o no. Per curiosità ho fatto la prova con la versione attuale del firmware e (con la solita correzione) compila correttamente.

immagine.thumb.png.4d49bf0b4c8592a37e4461050ccdc820.png

Link al commento
Condividi su altri siti

Partecipa alla conversazione

Puoi pubblicare ora e registrarti più tardi. Se hai un account, accedi ora per pubblicarlo con il tuo account.

Ospite
Rispondi a questa discussione...

×   Hai incollato il contenuto con la formattazione.   Rimuovere la formattazione

  Sono consentiti solo 75 emoticon max.

×   Il tuo collegamento è stato incorporato automaticamente.   Mostra come un collegamento

×   Il tuo contenuto precedente è stato ripristinato.   Pulisci editor

×   Non puoi incollare le immagini direttamente. Carica o inserisci immagini dall'URL.

 Condividi


×
×
  • Crea Nuovo...