Vai al contenuto

Piano Z del Bed troppo pesante che scende da solo e non resta ferm0 al fine corsa


Carlo50
 Condividi

Messaggi raccomandati

Serramazzoni Modena 19/10/2018

Ho appesantito troppo il piatto del Bed ed ora non resta fermo alla posizione che voglio.

Esiste un comando per tenere eccitato il motore passo passo in modo che rimanga bloccato in un punto senza muoversi?

Scheda 3dcontr con drv 8825 e telaio tronxy x5s.

Grazie Carlo Montecchi

Link al commento
Condividi su altri siti

  • Risposte 17
  • Creato
  • Ultima Risposta

Miglior contributo in questa discussione

Miglior contributo in questa discussione

Immagini Pubblicate

4 ore fa, carlo montecchi dice:

Esiste un comando per tenere eccitato il motore passo passo in modo che rimanga bloccato in un punto senza muoversi?

lo stepper mantiene la coppia quando la stampante è accesa di norma, infatti c'è il comando "disabilita' motori" in molte stampanti appunto per poter far girare liberamente i motori.

sicuro che il problema non sia meccanico? tipo che le barre girano a vuoto nella sede o che la puleggia gira sull'albero motore?

Link al commento
Condividi su altri siti

  • 3 settimane dopo...

Serramazzoni Modena 5/11/2018

Ho riscontrato un problema nel collegamento diretto del pin EN a massa; cioe' mi si e' quasi interrotto il comando del 2560, per cui adesso non si sposta l'asse Z.

Dico quasi, perche' la tensione cala da 5 a 2,5, ma non e' sufficiente per abilitare il driver.

Ho quindi collegato una resistenza da 3,9 kOhm fissa a massa ed ora ha ripreso a funzionare regolartmente.

Consiglio quindi a chi volesse fermare il piatto, di collegare EN a massa tramite una resistenza da 1 kOhm.

in modo da non sovracaricare l'uscita 88 del 2560.

Grazie dell'attenzione.

Carlo Montecchi

Link al commento
Condividi su altri siti

Salve a tutti, anche io posseggo una X5s ed improvvisamente riscontro un problema che non ho mai avuto. In pratica quando finisco la procedura di homing e XYZ sono in posizione, dopo alcuni secondi gli steppers dell'asse Z mollano la spinta facendo scendere il bed di alcuni cm da solo, premetto che il bed non è appesantito in alcun modo. Non capisco il perchè di questo problema, fino a poco fa per disabilitare gli stepper dovevo agire sulla apposita istruzione software. Il Firmware è un Marlin 1.1.7. Spero che qualcuno possa darmi una indicazione. Grazie.

Link al commento
Condividi su altri siti

Io non ho una esperienza vastissima in questo settore, ma non mi risulta che sia normale che a motori spenti l'asse z possa scendere da solo, il sistema di trascinamento dell'asse z a vite senza fine dovrebbe impedire questo effetto, forse più possibile con le viti trapezie dato il diverso angolo del passo. Per cui sei sicuro che la discesa avvenga davvero a motori spenti? Se sollevi l'asse z e poi spegni la  stampante scende da solo ?

Link al commento
Condividi su altri siti

si dopo alcuni secondi prestabiliti gli stepper si disattivano e gli assi scendono da soli,  la cosa avviene dopo un tot di 30 secondi non capisco come mai visto che posseggo questa stampante da svariati mesi e questo problema non lo avevo mai riscontrato.  Come dicevo fatto l'homing dopo circa 30 secondi l'asse Z scende e se spengo la stampante spingendo verso il basso scendono facilmente,  cmq tengo a precisare che tutti gli stepper si disattivano anche quelli assi XY, solo che questi ultimi essendo posizionati su asta stabile (Tronxy X5s) non creano problemi, mentre lo Z per ovvi motivi gravitazionali,  scende. Spero che ci sia qualcuno che possa indicarmi una via,  grazie in anticipo. 

Link al commento
Condividi su altri siti

Potrebbe essere l'alimentatore che si spegne, tieni presente che se sei collegato via usb la corrente che ti da l'usb è sufficiente a tenere acceso il display ed il firmware in funzionamento, verifica se quando capita questo problema continua a scaldare o meno. Tieni presente che questo tipo di problema nel caso che effettivamente ti manchi la corrente può dipendere anche da connettori di alimentazione in cattivo stato.

Se invece la mancanza avviene con regolarità (ossa sempre dopo lo stesso tempo esatto) allora il problema è molto probabilmente di firmware.

Link al commento
Condividi su altri siti

no l'alimentatore non si spegne, non sono collegato via usb. Appena torno a casa verifico con esattezza i tempi esatti di disattivazione cronometro alla mano, ma ad occhio mi sembra avvenga dopo un tempo costante. Ti aggiorno,  grazie. 

Link al commento
Condividi su altri siti

In Marlin, nel file Configuration_adv.h, precisamente nella sezione "Mechanical settings" trovate:

// Default stepper release if idle. Set to 0 to deactivate.
// Steppers will shut down DEFAULT_STEPPER_DEACTIVE_TIME seconds after the last move when DISABLE_INACTIVE_? is true.
// Time can be set by M18 and M84.
#define DEFAULT_STEPPER_DEACTIVE_TIME 120
#define DISABLE_INACTIVE_X true
#define DISABLE_INACTIVE_Y true
#define DISABLE_INACTIVE_Z true  // set to false if the nozzle will fall down on your printed part when print has finished.
#define DISABLE_INACTIVE_E true

Editando secondo le vostre esigenze dovreste risolvere.

Link al commento
Condividi su altri siti

Partecipa alla conversazione

Puoi pubblicare ora e registrarti più tardi. Se hai un account, accedi ora per pubblicarlo con il tuo account.

Ospite
Rispondi a questa discussione...

×   Hai incollato il contenuto con la formattazione.   Rimuovere la formattazione

  Sono consentiti solo 75 emoticon max.

×   Il tuo collegamento è stato incorporato automaticamente.   Mostra come un collegamento

×   Il tuo contenuto precedente è stato ripristinato.   Pulisci editor

×   Non puoi incollare le immagini direttamente. Carica o inserisci immagini dall'URL.

 Condividi


×
×
  • Crea Nuovo...