Vai al contenuto

Arduino errore avrdude


 Condividi

Messaggi raccomandati

Ciao a tutti, da poco mi sono regalato una r2 evo della quale vado molto fiero! Purtoppo da qualche giorno ho alcuni problemi con arduino. Dopo averla settata perfettamente procedo alla stampa ma prima ancora che questa parta la stampante si blocca, schermo LCD blu e tasto di reset che non risponde! Insomma tutto bloccato! Provo allora a reinstallare il marlinkimbra ma ricevo sempre un errore avrdude (di cui allego immagine) che non riesco a sistemare! 

 

Consigli? A qualcuno è gia successo?

Link al commento
Condividi su altri siti

  • Risposte 11
  • Creato
  • Ultima Risposta

Miglior contributo in questa discussione

Miglior contributo in questa discussione

Immagini Pubblicate

Ciao, questo è un problema di bootloader, dovresti riscriverlo e il tutto potrebbe funzionare, strano perche NicolaP avrebbe dovuto accorgersi che qualcosa era andato storto nel caricare il firmware. Quello che puoi fare è rimandare indietro l'arduino e fartelo sostituire. Oppure riscrivere il bootloader, ma per farlo servono un po di cooscenze di elettronica almeno base, e un altro arduino esterno. più cavi vari. 

Link al commento
Condividi su altri siti

51 minuti fa, leouz dice:

Ciao, questo è un problema di bootloader, dovresti riscriverlo e il tutto potrebbe funzionare, strano perche NicolaP avrebbe dovuto accorgersi che qualcosa era andato storto nel caricare il firmware. Quello che puoi fare è rimandare indietro l'arduino e fartelo sostituire. Oppure riscrivere il bootloader, ma per farlo servono un po di cooscenze di elettronica almeno base, e un altro arduino esterno. più cavi vari. 

Infatti NicolaP mi ha mandato l'arduino perfettamente funzionante, ho preso il kit, quindi mi sono occupato io di tutto l'assemblaggio e quindi dell'installazione fw, che ha funzionato da subito, mi è successo dopo aver settato a puntino la macchina...è successo in seguito ad un calo di corrente, ma non penso abbia danneggiato fisicamente la scheda

Link al commento
Condividi su altri siti

Ah ok quindi è successo qualcosa, 
Possibile che il calo di tensione si capitato mentre stavi scrivendo qualcosa sulla scheda? tipo valori eeprom o un firmware.

A questo punto devi provare scrivendo il bootloader, se hai una porta parallela sul pc puoi usare quella, ti serviranno anche un po di resistenze, oppure utilizzi direttamente un altro arduino anche uno per scrivere il bootloader. 

Link al commento
Condividi su altri siti

aspetta.....prova questa....

è probabile che la scheda non riceva il segnale di reset in fase di caricamento

-collega il cavo usb.(se riesci , meglio solo quello senza alimentazione 12V)

-provi a caricare il firmware tenendo premuto reset.......sino a che su arduino non si visualizza il totale della dimensione del file da caricare (ultimi quadratini verdi)

-istantaneamente lasci reset e controlli che il firmware venga caricato (led lampeggianti sulla scheda)

....

prova due o tre volte.

se non riesci ....bootloader

Ciao

Marco Capolino

Link al commento
Condividi su altri siti

Partecipa alla conversazione

Puoi pubblicare ora e registrarti più tardi. Se hai un account, accedi ora per pubblicarlo con il tuo account.

Ospite
Rispondi a questa discussione...

×   Hai incollato il contenuto con la formattazione.   Rimuovere la formattazione

  Sono consentiti solo 75 emoticon max.

×   Il tuo collegamento è stato incorporato automaticamente.   Mostra come un collegamento

×   Il tuo contenuto precedente è stato ripristinato.   Pulisci editor

×   Non puoi incollare le immagini direttamente. Carica o inserisci immagini dall'URL.

 Condividi


×
×
  • Crea Nuovo...