Vai al contenuto
  • Benvenuto!

     

Problema TFT 35 E3 V3


Shini3D
 Condividi

Messaggi raccomandati

Buongiorno, ho deciso di prendere lo schermo touch TFT 35 E3 V3 della bigtreetech, mi serviva lo schermo vecchio della ender per la migce, ho collegato tutto correttamente ma i problemi non sono mancati, oltre al fatto che ogni volta che accendo la stampante ci mette circa 30 secondi a connettersi, se passo alla modalità "marlin"  oltre al fatto che non me la fa selezionare con l'encoder ma devo cliccarla con il touch ripetutamente sembra ci sia una latenza nella connesione, il baudrate è settato a 115200 sia sullo schermo sia da firmware, mi rendo conto che la descrizione del problema non è chiarissima, ma è difficile da spiegare, ho notato latenza ed errori a settare la temperatura, un altra cosa molto strana è che io ho modificato il firmware impostando lo schermo corretto però non si installa, inserisco l'sd accendo la stampante e non succede niente, infatti il file all'interno della scheda rimane .bin  ma lo schermo "funziona" 

aiutatemi a capire perfavore.. 

Link al commento
Condividi su altri siti

Hemmm nemmeno io ho capito qual è il problema... Io ho il tft50 e funziona bene.... 

Se vuoi aggiornare il display oltre al file .bin devi mettere anche la cartella tft35 e il file config.ini. Se invece vuoi aggiornare la scheda, e dovrai farlo, devi vedere come funziona. Io non ho la tua stampante e non ti posso aiutare... 😅

  • Like 1
Link al commento
Condividi su altri siti

21 minuti fa, Killrob dice:

Chiarisci meglio che non ho capito, 

Scusatemi , cercherò di spiegarmi meglio,ogni volta che accendo la stampante, per almeno 30 secondi dice "stampante non connessa" poi si connette, questo schermo ha la possibilità di emulare l'interfaccia del vecchio schermo tenendo premuto l'encoder rotativo, viene visualizzata una schermata con le tue opzioni "tft" oppure "marlin" se ruoto l'encoder per cambiare selezione non succede nulla (dovrebbe cambiare appunto selezione) se clicco l'icona cambia interfaccia ma sembra che abbia una latenza nel rispondere ai comandi, ho difficoltà a settare la temperatura perché ogni tanto torna a 0 (penso perché si disconnette)

 

25 minuti fa, Killrob dice:

 se vuoi mettere il firmware nella scheda la SD la devi mettere nel lettore della scheda, se vuoi mettere il firmware nel monitor la SD la devi mettere nel monitor 

Si lo so, io volevo aggiornare il firmware della scheda madre perché per abilitare lo schermo bisogna disabilitare "CR10_stock display" e abilitare "reprap_discount ecc. ecc."  Quindi compilo il firmware e  inserisco la SD dentro ovviamente la scheda madre, non succede nulla, non si aggiorna..

29 minuti fa, Killrob dice:

cavi di collegamento hai messo anche quello nero? 

Si, facendo attenzione ai 5v

Link al commento
Condividi su altri siti

Che scheda monta la tua stampante? Se è una 8bit sei un po' fregato.... 😅 Ciò perché le 8 bit di solito hanno una seriale sola e puoi collegare il tft OPPURE il pc/OctoPrint. Ma insieme non puoi farlo pena comportamenti imprevisti. 

Se la scheda è 8bit la devi aggiornare con il pc e arduino ide. 

  • Like 2
Link al commento
Condividi su altri siti

5 minuti fa, Whitedavil dice:

Che scheda monta la tua stampante? Se è una 8bit sei un po' fregato.... 😅 Ciò perché le 8 bit di solito hanno una seriale sola e puoi collegare il tft OPPURE il pc/OctoPrint. Ma insieme non puoi farlo pena comportamenti imprevisti. 

Se la scheda è 8bit la devi aggiornare con il pc e arduino ide. 

È una skr 1.3..

Link al commento
Condividi su altri siti

Ok quindi siamo al punto che metti la SD col firmware.bin nello slot della scheda mamma e non succede una mazza.... Allora prova così, stacca il monitor, metti la scheda e accendi, aspetta 2 o 3 minuti poi spegni e vedi sul PC se il bin è diventato cur

P. S.: io sulla 1.4 ho dovuto abilitare sdsupport per farle funzionare entrambe, altrimenti mi funzionava solo quella del monitor

  • Like 1
Link al commento
Condividi su altri siti

2 ore fa, Killrob dice:

Ok quindi siamo al punto che metti la SD col firmware.bin nello slot della scheda mamma e non succede una mazza.... Allora prova così, stacca il monitor, metti la scheda e accendi, aspetta 2 o 3 minuti poi spegni e vedi sul PC se il bin è diventato cur

P. S.: io sulla 1.4 ho dovuto abilitare sdsupport per farle funzionare entrambe, altrimenti mi funzionava solo quella del monitor

Provo subito! da lcd non c'è neanche la funzione per leggere le sd della skr, devo metterlo in modalità "marlin" 

SD support è già abilitata 

 

Ok, cosi si è aggiornato, ora a parte un pò di latenza sembra tutto ok..  non sapevo avesse la possibilità di lanciare comandi direttamente da lcd, intendo tipo g28 x0y0z0 piuttosto che fare un pid tune fantastico!

  • Like 1
Link al commento
Condividi su altri siti

9 minuti fa, Killrob dice:

una delle figate è proprio quella, il gcode direttamente da LCD 😄

Ma tu riesci anche a stampare inserendo la scheda dentro la mobo o solo dentro LCD? io non ho trovato una funzione per stampare da mobo, posso stampare da mobo solo se vado in modalità "marlin"

Link al commento
Condividi su altri siti

15 minuti fa, Shini3D dice:

Ma tu riesci anche a stampare inserendo la scheda dentro la mobo o solo dentro LCD? io non ho trovato una funzione per stampare da mobo, posso stampare da mobo solo se vado in modalità "marlin"

sono sempre stato nelle tue stesse condizioni 😉  stampo da mobo solo in marlin, da touch solo quella del monitor funziona.

  • Like 1
Link al commento
Condividi su altri siti

4 minuti fa, Killrob dice:

sono sempre stato nelle tue stesse condizioni 😉  stampo da mobo solo in marlin, da touch solo quella del monitor funziona.

a posto perfetto, che poi a essere sinceri trovo anche più comoda la presa usb del LCD cosi ogni volta non devo staccare la micro SD dall'adattore appunto USB..

EDIT: non centra nulla con questa discussione ma attualmente sto stampando questo, sembra ""miracoloso"" anche i commenti promettono bene, sto stampando in tpu, si può usare su tutte le stampanti

  • Like 1
Link al commento
Condividi su altri siti

Il 23/7/2020 at 18:54, Killrob dice:

sono sempre stato nelle tue stesse condizioni 😉  stampo da mobo solo in marlin, da touch solo quella del monitor funziona.

mi è sorto un dubbio, quanti cavi hai collegati tu? io ho exp 1 exp 2 e quello nero, 3 in totale

Link al commento
Condividi su altri siti

  • 11 mesi dopo...
1 ora fa, marco1979 ha scritto:

cioa io ho questo problema vediamo se mi riuscite ad aiutare inserisco sd o usb dal tfc non le ritrova come bosoo fare devo aggiornare il firmawer  del lcd?

Apri un post apposito che questo è vecchio di un anno

Link al commento
Condividi su altri siti

Partecipa alla conversazione

Puoi pubblicare ora e registrarti più tardi. Se hai un account, accedi ora per pubblicarlo con il tuo account.

Ospite
Rispondi a questa discussione...

×   Hai incollato il contenuto con la formattazione.   Rimuovere la formattazione

  Sono consentiti solo 75 emoticon max.

×   Il tuo collegamento è stato incorporato automaticamente.   Mostra come un collegamento

×   Il tuo contenuto precedente è stato ripristinato.   Pulisci editor

×   You cannot paste images directly. Upload or insert images from URL.

 Condividi


×
×
  • Crea Nuovo...