Vai al contenuto

Octoprint tramite wan


 Condividi

Messaggi raccomandati

Buonasera a tutti, ho qualche problema a raggiungere il mio rpi b3+ da wan. Come server dns uso Dyndns.it e non ho nessun problema per le telecamere anche se sono in un'altra casa.

Partiamo dal modem, ho un modem tim fibra, ho aperto la porta 443 (perche ho utilizzato un protocollo https) sulla TCP e gli ho dato l'indirizzo ip del raspberry che ovviamente avevo già messo fisso.

poi ho configurato il dns ed il modem lo vede attivo

sul rasp ho installato il ddclient e configurato con i parametri trovati sul sito di dyndns.it se faccio un controllo con ddclient -dbug mi dice

ddclient -debug

DEBUG: proxy =

DEBUG: url = checkip.dyndns.it

DEBUG: server = checkip.dyndns.it

DEBUG: get_ip: using web, checkip.dyndns.it reports xx.xx.x.xxx (il mio indirizzo ip è giusto)

se non sbaglio, io dovrei vedere il mio rpi anche digitando il mio indirizzo ip e : porta es xx.xx.x.xxx:443 cosi dovrei escludere tutto il discorso dns giusto? ho provato ma non funziona ugualmente, ho provato a rimuovere i firmware dal modem senza risultato, ho chiesto assistenza a dyndns ma non mi hanno ancora risposto.

in rete locale non ho nessun problema...

Grazie a chi risponderà

Link al commento
Condividi su altri siti

  • Risposte 1
  • Creato
  • Ultima Risposta

Miglior contributo in questa discussione

Giorni Popolari

Miglior contributo in questa discussione

Giorni Popolari

Uhmm distinguiamo le due cose ovvero la risoluzione dns e il port forwarding.
Per il dns ti basta fare un ping al tuo dns name (o guardare il loro sito) e vedere se ip associato è quello del tuo IP pubblico (lo vedi con qualsiasi sito "show my IP" su Google oppure con app di tim).

Finito.

Per il port forwarding controlla ovviamente i parametri e se per caso hai il firewall attivo. Magari posta le schermate che proviamo oppure (se ti va) mandami gli indirizzi (non le password,, direi che basta vedere la schermata) che proviamo da esterno (oppure prova da telefonino senza wifi).


Inviato dal mio tablet utilizzando Tapatalk

Ah controlla se sul octoprint sia impostato il gateway correttamente.

Inviato dal mio tablet utilizzando Tapatalk

Link al commento
Condividi su altri siti

Partecipa alla conversazione

Puoi pubblicare ora e registrarti più tardi. Se hai un account, accedi ora per pubblicarlo con il tuo account.

Ospite
Rispondi a questa discussione...

×   Hai incollato il contenuto con la formattazione.   Rimuovere la formattazione

  Sono consentiti solo 75 emoticon max.

×   Il tuo collegamento è stato incorporato automaticamente.   Mostra come un collegamento

×   Il tuo contenuto precedente è stato ripristinato.   Pulisci editor

×   Non puoi incollare le immagini direttamente. Carica o inserisci immagini dall'URL.

 Condividi


×
×
  • Crea Nuovo...