Vai al contenuto

Firmware per Geeetech i3 Pro C e 3D Touch...consiglio


Guido
 Condividi

Messaggi raccomandati

Salve,

da poco mi è arrivato il sensore 3D Touch per la mia I3 Pro C.

Seguendo le varie istruzioni del manuale sto aggiornando il firmware della stampante, ma sul sito geeetech tra i vari firmware disponibili c'è ne già uno preconfigurato col 3D Touch,

Solo a verificare le varie voci con quanto scritto sul manuale e ho notato alcuni valori diversi....e qui avrei bisogno del vostro aiuto....

sul firmware preconfigurato trovo questi valori:

#define SERVO_ENDSTOP_ANGLES {0,0, 0,0, 70,0} ( nel manuale #define SERVO_ENDSTOP_ANGLES {0,0, 0,0, 10,90} )

 

#define Z_RAISE_BETWEEN_PROBINGS 5 ( nel manuale #define Z_RAISE_BETWEEN_PROBINGS 10 )

 

#define SERVO0_PIN         11 ( nel manuale #define SERVO0_PIN 32 )

 

sarà perché il manuale è generico mentre il firmware è già per la versione Pro C?

 

Link al commento
Condividi su altri siti

  • Risposte 14
  • Creato
  • Ultima Risposta

Miglior contributo in questa discussione

Miglior contributo in questa discussione

quando provo a settare la distanza tra il sensore e il piatto ho dei problemi.

da manuale mi indica alcuni comandi da inviare per settare la Z_offset

Cita

M851 Z-1.5 ; to set the offset you got in the previous step.

io inserisco il valore 3.06 che ho a display ma mi esce questo messaggio in repetier

Cita

echo:Z Offsetz_min: -15z_max: -5

di conseguenza se non è un valore tra -15 e -5 non mi fa settare lo Z offset

Link al commento
Condividi su altri siti

Per il pin del servo dipende da quale scheda hai. Se hai una gt2560 il 3dtouch, seguendo il manuale, lo puoi collegare al connettore dell'endstop z-max, e lo devi quindi impostare a 32.

Se hai una gt2560 rev A+ il 3dtouch lo colleghi al connettore servo (i tre pin che stanno vicino ai connettori dei termistori) e nel firmware lo devi impostare a 11. 

Link al commento
Condividi su altri siti

Il sensore è installato correttamente, ho provato i comandi di test e funziona.

Ora però non riesco ad impostare la distanza corretta dal piatto, perchè quando vado a dare il comando M851 Z(valore), mi restituisce sempre il messaggio

echo:Z Offsetz_min: -15z_max: -5

Link al commento
Condividi su altri siti

il firmware è settato come dalla guida che mi hai inviato, il problema non è qui.

 

Cita

Calibration

These instructions are written to explain how to calibrate using a computer connected through the USB port to your printer. This process also assumes that the EEPROM has been enabled in Marlin.

From the command window of Repetier Host or Simplify3D etc enter the following:

M851 ; note the number

M851 Z0 ; set the offset to zero

G28

G1 Z0

The LCD display should show Z = 0

From the display go to the Menu then Prepare/Move axis/0.1mm/Move Z

Now move the Z axis slowly down until the nozzle is the right distance from the build plate (folded piece of paper or thin card).


*Note the Z axis value on the display it should be something like -1.5

M851 Z-1.5 ; to set the offset you got in the previous step.

M500 ; Stores the values in EEPROM so that it is not reset when you power the printer off and on.

Now you are ready to print.


If you find that you need to increase or decrease the gap then do:

M851 Z-1.4 ; this would make the gap bigger or

M851 Z-1.6 ; this would make the gap smaller

M500 ; to save the value to EEPROM


*Remember the -1.4, -1.5 and -1.6 are just examples , yours will be different.

questi sono i comandi da utilizzare per la regolazione, ma il comando M851 a me non va perchè il valore che io provo a inviare non è compreso tra -15 e -5.

Io provo a inserire -3.1 come Z ma essendo inferiore a -5 non me lo accetta. Neanche M851 Z0 che server per settare a 0 l'offset accetta 

 

Penso che il problema sia in questo pezzo di codice della mia stampante:

// Custom M code points
#define CUSTOM_M_CODES
#ifdef CUSTOM_M_CODES
  #define CUSTOM_M_CODE_SET_Z_PROBE_OFFSET 851
  #define Z_PROBE_OFFSET_RANGE_MIN -15
  #define Z_PROBE_OFFSET_RANGE_MAX -5
#endif

 

Link al commento
Condividi su altri siti

Partecipa alla conversazione

Puoi pubblicare ora e registrarti più tardi. Se hai un account, accedi ora per pubblicarlo con il tuo account.

Ospite
Rispondi a questa discussione...

×   Hai incollato il contenuto con la formattazione.   Rimuovere la formattazione

  Sono consentiti solo 75 emoticon max.

×   Il tuo collegamento è stato incorporato automaticamente.   Mostra come un collegamento

×   Il tuo contenuto precedente è stato ripristinato.   Pulisci editor

×   Non puoi incollare le immagini direttamente. Carica o inserisci immagini dall'URL.

 Condividi


×
×
  • Crea Nuovo...