Vai al contenuto

asse z non va se non a microspostamenti


 Condividi

Messaggi raccomandati

Ciao a tutti... premetto che sono nuovo sia del forum sia del mondo della stampa 3d.


Ho terminato da poco l'assemblaggio di una prusa i3 rework (nessun kit mi sono prucurato ogni pezzo personalmente) e da subito mi si é palesato un problema che ancora non so come risolvere. Praticamente l'asse z non vuole fare movimenti più alti di un millimetro sia in una direzione sia nell'altra. Ma la cosa curiosa è che spostamenti fino a 1 (dal controllo manuale) li fa senza alcun tipo di problemi! Incluso l'homing dell'asse... gira che è una meraviglia... peró se io gli dico di spostarsi di 10 i motori fanno un paio di giri e poi si bloccano facendo un rumoraccio "elettronico".


Da allora ho cambiato tantissimi parametri del firmware (in particolare velocità accellerazione ecc...) ho aumentato la vref fino a 0.55 ho cambiato e lubrificato con del grasso apposta le barre filettate (m5) che a dita girano senza troppi sforzi. 


Non so più dove sbattere la testa qualcuno ha qualche idea? 


Monto una ramps 1.4 su un arduino mega originale con dei pololu a4988 e i motori girano a 1.7A con step di 0.9deg. Ah dimenticavo come firm ho messo su l'ultimo marlin.


Per ora ciao e grazie a chiunque mi sia anche solo minimamente d'aiuto!


Link al commento
Condividi su altri siti

  • Risposte 1
  • Creato
  • Ultima Risposta

Miglior contributo in questa discussione

Giorni Popolari

Miglior contributo in questa discussione

Sono riuscito finalmente a risolvere... dopo milioni di tentativi software e smontaggi e rimontaggi vari sia di elettronica che fisici ne sono arrivato a capo.

Lo scrivo nel caso possa servire ad altri che hanno lo stesso problema.

Nel firmware ho abbassato le velocità e feedrate secondo i parametri consigliati su questo forum e non solo ma abbassando ulteriormente il feedrate max dell'asse z fino al valore di 0.4...

Cosa che mi ero astenuto a fare prima poichè pensavo accettasse solo parametri interi... non preoccupatevi se vi sembra basso come valore, l'asse z non necessita di grossi spostamenti e la macchina rimane funzionale!

ciao a tutti!

P.s. come si mette risolto nel titolo?

Link al commento
Condividi su altri siti

Partecipa alla conversazione

Puoi pubblicare ora e registrarti più tardi. Se hai un account, accedi ora per pubblicarlo con il tuo account.

Ospite
Rispondi a questa discussione...

×   Hai incollato il contenuto con la formattazione.   Rimuovere la formattazione

  Sono consentiti solo 75 emoticon max.

×   Il tuo collegamento è stato incorporato automaticamente.   Mostra come un collegamento

×   Il tuo contenuto precedente è stato ripristinato.   Pulisci editor

×   Non puoi incollare le immagini direttamente. Carica o inserisci immagini dall'URL.

 Condividi


×
×
  • Crea Nuovo...