Vai al contenuto

Anycubic i3 Mega + problema con BLTOUCH (Error: Probin Failed)


Robocop

Messaggi raccomandati

Buongiorno a tutti.

Spero di trovare qualcuno che mi sappia dare una soluzione perchè non so proprio più cosa fare (problema sul BLtouch).

Possiedo una Anycubic i3 Mega sulla quale ho deciso di fare alcune modifiche (giusto per darvi il quadro della situazione):

- Installazione dei TMC2208 (questi https://www.amazon.it/gp/product/B07HRFHFQZ/ref=ppx_yo_dt_b_asin_title_o04_s02?ie=UTF8&psc=1)

- Installazione di due mosfet uno per il piano di stampa e uno per l'hotend (questi https://www.amazon.it/gp/product/B07CGL421Z/ref=ppx_yo_dt_b_asin_title_o07_s00?ie=UTF8&psc=1)

- Installazione di un nuovo alimentatore più potente (questo https://www.amazon.it/gp/product/B07FXHS8YL/ref=ppx_yo_dt_b_asin_title_o06_s00?ie=UTF8&psc=1)

- Installazione di nuove cinghie (questa https://www.amazon.it/gp/product/B07ZPGLF2X/ref=ppx_yo_dt_b_asin_title_o09_s01?ie=UTF8&psc=1

- Installazione del BLTOUCH (questo https://www.amazon.it/gp/product/B075B57CHD/ref=ppx_yo_dt_b_asin_title_o01_s00?ie=UTF8&psc=1)

Per l'installazione del BLtouch mi sono stampato il carrello aggiornato che potete trovare a questo indirizzo https://www.thingiverse.com/thing:3537449 ed ho seguito il seguente video come guida (ho scaricato il firmware che si trova nella descrizione del video).

https://www.youtube.com/watch?v=6fXoQUZgldU&t=961s

 

Esattamente come dice il video guida a circa il minuto 12.30 ho configurato il firmware secondo quanto ho installato.

Quindi i TMC2208 OK (compresa vref ecc..), mosfet ok, alimentatore ok, cinghie ok, ma BLTOUCH NON OK.

Oltre alle impostazioni che si trovano nel video, ho impostato la TRIGORILLA_VERSION al valore 0, in quanto la mia trigorilla non è la più aggiornata (vi lascio comunque in allegato il firmware di Marlin che ho caricato sulla stampante e la foto che mostra il logo della Trigorilla ed identifica la versione della scheda.

 

Il problema è che, quando lancio l'auto livellamento o con il comando G29, o direttamente dal nuovo menù la stampante inizia il programma ma  poi  si blocca e restituisce il seguente errore:

 

 - Error : Probing Failed

X:-5.00 Y:23.00 Z:11.50 E:0.00 Count X:-400 Y:1840 Z:4600

 

Vi lascio il link al video che mostra come si comporta la stampante quando lancio i comandi di auto livellamento del piano che è più facile a vedersi che non da descrivere.

https://www.youtube.com/watch?v=AjSEXh9U2OA&feature=youtu.be

Concludo dicendo che ho provato due BLtouch diversi (ma della stessa marca - vedi link sopra) quindi escluderei un problema di difettosità del sensore, ed escluderei anche la questione collegamento fili, altrimenti non riuscirei neppure a comandare il sensore.

Ringrazio in anticipo per la disponibilità.

Spero di aver esposto in maniera abbastanza chiara il problema.

 

20200606_104027.jpg

Marlin.zip

Link al commento
Condividi su altri siti

3 ore fa, Robocop dice:

Buongiorno a tutti.

Spero di trovare qualcuno che mi sappia dare una soluzione perchè non so proprio più cosa fare (problema sul BLtouch).

Possiedo una Anycubic i3 Mega sulla quale ho deciso di fare alcune modifiche (giusto per darvi il quadro della situazione):

- Installazione dei TMC2208 (questi https://www.amazon.it/gp/product/B07HRFHFQZ/ref=ppx_yo_dt_b_asin_title_o04_s02?ie=UTF8&psc=1)

- Installazione di due mosfet uno per il piano di stampa e uno per l'hotend (questi https://www.amazon.it/gp/product/B07CGL421Z/ref=ppx_yo_dt_b_asin_title_o07_s00?ie=UTF8&psc=1)

- Installazione di un nuovo alimentatore più potente (questo https://www.amazon.it/gp/product/B07FXHS8YL/ref=ppx_yo_dt_b_asin_title_o06_s00?ie=UTF8&psc=1)

- Installazione di nuove cinghie (questa https://www.amazon.it/gp/product/B07ZPGLF2X/ref=ppx_yo_dt_b_asin_title_o09_s01?ie=UTF8&psc=1

- Installazione del BLTOUCH (questo https://www.amazon.it/gp/product/B075B57CHD/ref=ppx_yo_dt_b_asin_title_o01_s00?ie=UTF8&psc=1)

Per l'installazione del BLtouch mi sono stampato il carrello aggiornato che potete trovare a questo indirizzo https://www.thingiverse.com/thing:3537449 ed ho seguito il seguente video come guida (ho scaricato il firmware che si trova nella descrizione del video).

https://www.youtube.com/watch?v=6fXoQUZgldU&t=961s

 

Esattamente come dice il video guida a circa il minuto 12.30 ho configurato il firmware secondo quanto ho installato.

Quindi i TMC2208 OK (compresa vref ecc..), mosfet ok, alimentatore ok, cinghie ok, ma BLTOUCH NON OK.

Oltre alle impostazioni che si trovano nel video, ho impostato la TRIGORILLA_VERSION al valore 0, in quanto la mia trigorilla non è la più aggiornata (vi lascio comunque in allegato il firmware di Marlin che ho caricato sulla stampante e la foto che mostra il logo della Trigorilla ed identifica la versione della scheda.

 

Il problema è che, quando lancio l'auto livellamento o con il comando G29, o direttamente dal nuovo menù la stampante inizia il programma ma  poi  si blocca e restituisce il seguente errore:

 

 - Error : Probing Failed

X:-5.00 Y:23.00 Z:11.50 E:0.00 Count X:-400 Y:1840 Z:4600

 

Vi lascio il link al video che mostra come si comporta la stampante quando lancio i comandi di auto livellamento del piano che è più facile a vedersi che non da descrivere.

https://www.youtube.com/watch?v=AjSEXh9U2OA&feature=youtu.be

Concludo dicendo che ho provato due BLtouch diversi (ma della stessa marca - vedi link sopra) quindi escluderei un problema di difettosità del sensore, ed escluderei anche la questione collegamento fili, altrimenti non riuscirei neppure a comandare il sensore.

Ringrazio in anticipo per la disponibilità.

Spero di aver esposto in maniera abbastanza chiara il problema.

 

20200606_104027.jpg

Marlin.zip 3 MB · 0 downloads

Ho visto l'inizio del video ma quello è il G28 che lo fa a lato o l'inizio del G29 fuori dal piatto, perchè non hai utilizzato il bltoruch come endstop?

  • Like 2
Link al commento
Condividi su altri siti

Non sono sicuro al 100%, ma ad occhio il finecorsa Z scatta prima del BL-Touch e probabilmente il firmware si aspetta il contrario. Se provi a spingere verso l'alto l'asta del BL-Touch subito dopo che va giù (simulando che abbia toccato il piatto), il processo prosegue al punto successivo?

  • Like 1
Link al commento
Condividi su altri siti

49 minuti fa, Basilietto dice:

Ho visto l'inizio del video ma quello è il G28 che lo fa a lato o l'inizio del G29 fuori dal piatto, perchè non hai utilizzato il bltoruch come endstop?

Il punto zero della stampante è in quel punto.... Cioè quando premo "home" lei automaticamente si sposta in quella posizione! Sinceramente nn so com'è impostata la mesh di ricerca dei punti... Credo che dove si blocca è il primo punto. 

8 minuti fa, Zmaster dice:

Non sono sicuro al 100%, ma ad occhio il finecorsa Z scatta prima del BL-Touch e probabilmente il firmware si aspetta il contrario. Se provi a spingere verso l'alto l'asta del BL-Touch subito dopo che va giù (simulando che abbia toccato il piatto), il processo prosegue al punto successivo?

Si ho provato a toccare il bltouch prima di arrivare a fine corsa e nn succede nulla.... Anzi il bltouch inizia a lampeggiare di rosso e da quello che ho capito è come se andasse in errore... Senza i fine corsa originali probabilmente andrei ad impattare sul piatto.... Cioè è come se il bltouch nn ci fosse! 

Link al commento
Condividi su altri siti

2 minuti fa, Robocop dice:

Il punto zero della stampante è in quel punto.... Cioè quando premo "home" lei automaticamente si sposta in quella posizione! Sinceramente nn so com'è impostata la mesh di ricerca dei punti... Credo che dove si blocca è il primo punto. 

Credo che tu abbia montato male il bltouch, 1-dovresti averlo inserito al posto del endstopz 2-la home te la deve fare alcentro bed (e qui devi mettere mano a marlin) 3-hai regolato l'offsetZ prima di fare il G29?

  • Like 2
Link al commento
Condividi su altri siti

Mmm.... 

1- nel video guida dice di "rubare" il segnale dal filo bianco e giallo che si trovano sul carrello ed io mi sono collegato lì...il bltouch ha 5 fili, che sono rosso marrone giallo bianco e nero... Il rosso è marrone sono +5V e gnd, il giallo è per il controllo servo, ed infine il nero ed il bianco li ho collegati ai fili del carrello rispettivamente nero con il bianco del carrello, che corrisponde a GND e il bianco del bltouch con il giallo del carrello, che corrisponde al segnale. 

2- ho provato anche a mettere lo zero al centro del piano di stampa ma nn è cambiato nulla... Se vuoi riprovo... Ora nn ricordo qual'e la riga su marlin ma nn è difficile. 

 

3- lo z-offset sinceramente mi è leggermente oscuro e nn ho ben capito come fare..... Nel video guida nn ne fa cenno quindi nn gli ho dato troppo peso. Mi sapresti indicare  come fare? 

 

 

Vi ringrazio tutti per le risposte. 

Link al commento
Condividi su altri siti

21 minuti fa, Robocop dice:

Mmm.... 

1- nel video guida dice di "rubare" il segnale dal filo bianco e giallo che si trovano sul carrello ed io mi sono collegato lì...il bltouch ha 5 fili, che sono rosso marrone giallo bianco e nero... Il rosso è marrone sono +5V e gnd, il giallo è per il controllo servo, ed infine il nero ed il bianco li ho collegati ai fili del carrello rispettivamente nero con il bianco del carrello, che corrisponde a GND e il bianco del bltouch con il giallo del carrello, che corrisponde al segnale. 

2- ho provato anche a mettere lo zero al centro del piano di stampa ma nn è cambiato nulla... Se vuoi riprovo... Ora nn ricordo qual'e la riga su marlin ma nn è difficile. 

 

3- lo z-offset sinceramente mi è leggermente oscuro e nn ho ben capito come fare..... Nel video guida nn ne fa cenno quindi nn gli ho dato troppo peso. Mi sapresti indicare  come fare? 

 

 

Vi ringrazio tutti per le risposte. 

Non conosco la tua stampante ma dal video sembra che si attivi un endstop meccanico e non il bltouch che dovrebbe darti l'endstop a centro bed, riguardo al offsetZ ti consiglio di seguire attentamente questo video 

https://www.youtube.com/watch?v=QcWJqR5vN90&list=PLFave6NKCpRFLnXGTTtj4C_u6Dcswet4Y&index=18&t=148s

 

  • Like 1
Link al commento
Condividi su altri siti

Buongiorno a tutti... 

Questa sera proverò ad abilitare i comandi per il test sui pin e vi riporterò il risultato. 

 

Il video lo avevo trovato pure io ma poi ho smesso di seguirlo in quanto lo Zzero software sembra nn esserci sulla mia stampante.... Cioè avevo provato ad aggiungere un Zzero molto alto per fare dei test ma poi, lanciando il comando di home viene totalmente ignorato il nuovo Zzero e l'asse Z continua a scendere fino a quando nn trova i fine corsa meccanici.

Correggimi se sbaglio, ma lo Zzero software nn dovrebbe permettere all'asse Z di scendere sotto a tale valore giusto? E teoricamente i fine corsa meccanici dovrebbero entrare in funzione solo il caso di emergenza!? 

Link al commento
Condividi su altri siti

Buongiorno,

per ora ho modificato il firmware (foto allegate).

Fatemi sapere se l'ho modificato in maniera corretta.

Le modifiche consistono nel:

- impostare lo 0 al centro del piatto di stampa.

- abilitare la funzione PINS_DEBUGGING.

 

Lascio comunque il firmware in allegato.

Se è tutto corretto questa sera lo carico e lancio i comandi per i pin.

 

Grazie

IMG 1.PNG

IMG 2.PNG

Marlin.zip

Link al commento
Condividi su altri siti

Partecipa alla conversazione

Puoi pubblicare ora e registrarti più tardi. Se hai un account, accedi ora per pubblicarlo con il tuo account.

Ospite
Rispondi a questa discussione...

×   Hai incollato il contenuto con la formattazione.   Rimuovere la formattazione

  Sono consentiti solo 75 emoticon max.

×   Il tuo collegamento è stato incorporato automaticamente.   Mostra come un collegamento

×   Il tuo contenuto precedente è stato ripristinato.   Pulisci editor

×   Non puoi incollare le immagini direttamente. Carica o inserisci immagini dall'URL.

×
×
  • Crea Nuovo...