Vai al contenuto
  • Iscriviti al forum

    Iscriviti al forum per usufruire di tutti i contenuti: la registrazione è gratuita!

harem68

SKR1.4 turbo con TMC2209 1.2 con endstop fisici.

Recommended Posts

Ciao a tutti mi chiamo Andrea e mi sono iscritto a questo forum perchè ho bisogno del vostro aiuto.

Ho acquistato una scheda skr 1.4 turbo con clock a 120 mhz e relativi driver tmc2209 V1.2 UART

E' una settimana che provo ma non riesco a far lavorare gli endstop meccanici della mia cr-10s.

Ho rimosso il pin diag dei driver perchè altrimenti l'M119 non triggerava.

Bene, ora triggera, vedo i cambiamenti di stato open-triggered ma il mio switch di fine corsa non si attiva.

Ho provato tutte le possibili conbinazioni del marlin 2.0 bugfix e anche altri ma senza risolvere. Non riesco a capire ma penso sia un problema hardware...non è che devo o cambiare qualche jumper ..?

I jumper sotto i driver sono come da configurazione bigtreetech......Non ho più idee..!!

Mi date una mano..?

 

Grazie

Condividi questo messaggio


Link di questo messaggio
Condividi su altri siti
1 minuto fa, harem68 dice:

Ciao a tutti mi chiamo Andrea e mi sono iscritto a questo forum perchè ho bisogno del vostro aiuto.

Ho acquistato una scheda skr 1.4 turbo con clock a 120 mhz e relativi driver tmc2209 V1.2 UART

E' una settimana che provo ma non riesco a far lavorare gli endstop meccanici della mia cr-10s.

Ho rimosso il pin diag dei driver perchè altrimenti l'M119 non triggerava.

Bene, ora triggera, vedo i cambiamenti di stato open-triggered ma il mio switch di fine corsa non si attiva.

Ho provato tutte le possibili conbinazioni del marlin 2.0 bugfix e anche altri ma senza risolvere. Non riesco a capire ma penso sia un problema hardware...non è che devo o cambiare qualche jumper ..?

I jumper sotto i driver sono come da configurazione bigtreetech......Non ho più idee..!!

Mi date una mano..?

Premesso che non ho i TMC2209 con quella scheda, mi sembrava di ricordare qualcosa nel manuale, guarda in questa pagina, la parte in rosso:

download.thumb.png.c01df7012a30943fe73899848a166e36.png

E sì, pure io sono basito: hanno fatto una scheda nuova dove devi ranzare via dei piedini al driver mentre nella SKR 1.3 non dovevi farlo...

Condividi questo messaggio


Link di questo messaggio
Condividi su altri siti
36 minuti fa, invernomuto dice:

E sì, pure io sono basito: hanno fatto una scheda nuova dove devi ranzare via dei piedini al driver mentre nella SKR 1.3 non dovevi farlo...

perchè danno per scontato che si faccia uso di UART, stallguard etc etc etc. Scheda nuova , driver nuovi, tutte funzioni nuove.

Scelta alquanto discutibile......... Io ad esempio non riesco ad usare i 2209 in standalone, mi prende fuoco il motore, sul gruppo mi hanno detto che di default sono UART 

Condividi questo messaggio


Link di questo messaggio
Condividi su altri siti
56 minuti fa, invernomuto dice:

Premesso che non ho i TMC2209 con quella scheda, mi sembrava di ricordare qualcosa nel manuale, guarda in questa pagina, la parte in rosso:

download.thumb.png.c01df7012a30943fe73899848a166e36.png

E sì, pure io sono basito: hanno fatto una scheda nuova dove devi ranzare via dei piedini al driver mentre nella SKR 1.3 non dovevi farlo...

Ciao ad entrambi. Si, ho seguito le descrizioni e ho inserito i jumper e tagliato il piedino altrimenti non cambiava di stato il trigger. Ora cambia di stato ma non sente il comando e quindi non si ferma il movimento....

Condividi questo messaggio


Link di questo messaggio
Condividi su altri siti
11 ore fa, harem68 dice:

Ciao ad entrambi. Si, ho seguito le descrizioni e ho inserito i jumper e tagliato il piedino altrimenti non cambiava di stato il trigger. Ora cambia di stato ma non sente il comando e quindi non si ferma il movimento....

Quindi è un problema software, visto che a video vedi il cambio di stato. Hai marlin come firmware? Come hai configurato la parte degli endstop?

Condividi questo messaggio


Link di questo messaggio
Condividi su altri siti
13 ore fa, invernomuto dice:

Premesso che non ho i TMC2209 con quella scheda, mi sembrava di ricordare qualcosa nel manuale, guarda in questa pagina, la parte in rosso:

 

E sì, pure io sono basito: hanno fatto una scheda nuova dove devi ranzare via dei piedini al driver mentre nella SKR 1.3 non dovevi farlo...

Confermo quanto detto per la skr v1.3 basta soltanto si disattivare lo stallguard 

io con i 2130 ho lasciato i piedini ed ho xy con il sensorless e endstop meccanici su z1 e z2 

vero che per configurarli sono diventato matto ..non ricordo se era anche per via della voce endstop pullup (non ricordo bene come si chiama) 

Consiglio di leggere bene la guida Marlin per la parte degli endstop

 

Condividi questo messaggio


Link di questo messaggio
Condividi su altri siti
1 ora fa, Tomto dice:

Confermo quanto detto per la skr v1.3 basta soltanto si disattivare lo stallguard 

io con i 2130 ho lasciato i piedini ed ho xy con il sensorless e endstop meccanici su z1 e z2 

vero che per configurarli sono diventato matto ..non ricordo se era anche per via della voce endstop pullup (non ricordo bene come si chiama) 

Consiglio di leggere bene la guida Marlin per la parte degli endstop

Ciao, grazie per le info. Mi sembra che sono tutte prove che ho fatto ( ne ho fatte talmente tante che ho perso la cognizione) ma questa sera riprovo. Ti saprò dare info a breve.

🤹

Condividi questo messaggio


Link di questo messaggio
Condividi su altri siti
3 ore fa, harem68 dice:

Ciao, grazie per le info. Mi sembra che sono tutte prove che ho fatto ( ne ho fatte talmente tante che ho perso la cognizione) ma questa sera riprovo. Ti saprò dare info a breve.

🤹

ne ho fatte tante anche io non mi ricordo nemmeno le combinazioni che ho provato. 

Un consiglio: fai le cose con calma e salva spesso gli screenshoot altrimenti rischi di sbagliare solo per aver on non aver decommentato qualcosa

Condividi questo messaggio


Link di questo messaggio
Condividi su altri siti
1 ora fa, Tomto dice:

ne ho fatte tante anche io non mi ricordo nemmeno le combinazioni che ho provato. 

Un consiglio: fai le cose con calma e salva spesso gli screenshoot altrimenti rischi di sbagliare solo per aver on non aver decommentato qualcosa

Si..concordo. il mi annoto anche sul cartaceo le variazioni in modo da ripescarle al volo...

Condividi questo messaggio


Link di questo messaggio
Condividi su altri siti
9 ore fa, Tomto dice:

Confermo quanto detto per la skr v1.3 basta soltanto si disattivare lo stallguard 

io con i 2130 ho lasciato i piedini ed ho xy con il sensorless e endstop meccanici su z1 e z2 

vero che per configurarli sono diventato matto ..non ricordo se era anche per via della voce endstop pullup (non ricordo bene come si chiama) 

Consiglio di leggere bene la guida Marlin per la parte degli endstop

 

Ciao. Il marlin bugfix li stallguard è disabile di default. Il pullup endstop è disable... Ancora nn ho risolto........ufff...

Modificato da harem68
Corretto

Condividi questo messaggio


Link di questo messaggio
Condividi su altri siti
Il 4/2/2020 at 21:37, harem68 dice:

Ciao. Il marlin bugfix li stallguard è disabile di default. Il pullup endstop è disable... Ancora nn ho risolto........ufff...

Nel file di configurazione è però attivo:

#define ENDSTOPPULLUPS

Hai provato tutte le configurazioni?
Su che stato li hai a video quando NON è attivo l'endstop?
Ti da triggered a video quando li premi ma poi non ferma i motori?

Condividi questo messaggio


Link di questo messaggio
Condividi su altri siti
42 minuti fa, invernomuto dice:

Nel file di configurazione è però attivo:


#define ENDSTOPPULLUPS

Hai provato tutte le configurazioni?
Su che stato li hai a video quando NON è attivo l'endstop?
Ti da triggered a video quando li premi ma poi non ferma i motori?

Ciao. Grazie per l'aiuto ma il file da decommentare è questo:

Se a video vedete il trigger dei vari endstop ma i motori non si fermano. bisogna abilitare l'endstop_always_on_default che è disabilitato.

 // @section homing
 
// If you want endstops to stay on (by default) even when not homing
// enable this option. Override at any time with M120, M121.
#define ENDSTOPS_ALWAYS_ON_DEFAULT
 

Condividi questo messaggio


Link di questo messaggio
Condividi su altri siti

Ciao. Si, come ho scritto il problema è che a video vedo il cambio di stato dello switch ma il motore non si arresta al comando. La riga è commentata di default e quindi inattiva. Abilitata, ora se premo lo switch impartisco il comando e il motore si ferma. Nn capisco come mai questa riga sia disabilitata e come mai nessuno lamenta il mio problema. Il mio marlin è originale scaricato dal sito ed è il bugfix ma ho provato anche tutte le altre release e tutte fanno il problema. Grazie x esserti preso la briga di aiutarmi...😃

Condividi questo messaggio


Link di questo messaggio
Condividi su altri siti

Ciao, ho il tuo stesso identico problema e da giorni ci sto impazzendo!

Anch'io ho BTT SKR1.4Turbo e TMC2209 v1.2 installati però su Ender 3 Pro.

Ho abilitato anche il comando #define ENDSTOPS_ALWAYS_ON_DEFAULT ma niente da fare.

Temo però che il mio problema sia dato dal fatto che non ho ancora tagliato il pin Diag sul TMC2209, ed infatti col comando M119 non vedo cambiare di stato gli interruttori: rimangono sempre costantemente ed imperturbabilmente in OPEN:

SENDING:M119
Reporting endstop status
x_min: open
y_min: open
z_min: open

Tu hai risolto semplicemente tagliando il pin Diag ed abilitando il comando ENDSTOPS_ALWAYS_ON_DEFAULT?

Non sarà proprio possibile evitare di tagliare quel pin? Mi scoccia manomettere dei driver nuovi...

Grazie per l'aiuto.

 

Condividi questo messaggio


Link di questo messaggio
Condividi su altri siti
30 minuti fa, El_Barto dice:

Ciao, ho il tuo stesso identico problema e da giorni ci sto impazzendo!

Anch'io ho BTT SKR1.4Turbo e TMC2209 v1.2 installati però su Ender 3 Pro.

Ho abilitato anche il comando #define ENDSTOPS_ALWAYS_ON_DEFAULT ma niente da fare.

Temo però che il mio problema sia dato dal fatto che non ho ancora tagliato il pin Diag sul TMC2209, ed infatti col comando M119 non vedo cambiare di stato gli interruttori: rimangono sempre costantemente ed imperturbabilmente in OPEN:

SENDING:M119
Reporting endstop status
x_min: open
y_min: open
z_min: open

Tu hai risolto semplicemente tagliando il pin Diag ed abilitando il comando ENDSTOPS_ALWAYS_ON_DEFAULT?

Non sarà proprio possibile evitare di tagliare quel pin? Mi scoccia manomettere dei driver nuovi...

Grazie per l'aiuto.

 

Ciao. Io l'ho tagliato perché non vedo problemi nel farlo. Il giorno che ne avrò bisogno lo dissaldo e lo ripristino. Tu puoi piegarlo in dentro, ovvero lato interno, perché se lo pieghi fuori ti andrà a sbattere al driver accanto. Vedrai che risolvi...😜

Condividi questo messaggio


Link di questo messaggio
Condividi su altri siti
6 minuti fa, harem68 dice:

Ciao. Io l'ho tagliato perché non vedo problemi nel farlo. Il giorno che ne avrò bisogno lo dissaldo e lo ripristino. Tu puoi piegarlo in dentro, ovvero lato interno, perché se lo pieghi fuori ti andrà a sbattere al driver accanto. Vedrai che risolvi...😜

Grazie mille!

In effetti è esattamente la prova che stavo facendo in questi minuti e pare funzionare:

SENDING:M119
Reporting endstop status
x_min: TRIGGERED
y_min: open
z_min: open

Lanciato anche il comando dell'homing ed effettivamente l'ha finalmente eseguito.

Nel frattempo avevo già mandato una email direttamente a BigTreeTech per chieder loro se hanno una soluzione a tale inconveniente e ti terrò aggiornato se mi risponderanno.

Ancora grazie ed a presto...

Condividi questo messaggio


Link di questo messaggio
Condividi su altri siti
1 ora fa, El_Barto dice:

Grazie mille!

In effetti è esattamente la prova che stavo facendo in questi minuti e pare funzionare:

SENDING:M119
Reporting endstop status
x_min: TRIGGERED
y_min: open
z_min: open

Lanciato anche il comando dell'homing ed effettivamente l'ha finalmente eseguito.

Nel frattempo avevo già mandato una email direttamente a BigTreeTech per chieder loro se hanno una soluzione a tale inconveniente e ti terrò aggiornato se mi risponderanno.

Ancora grazie ed a presto...

Anche io ho fatto un paio di email nelle settimane scorse in btt tutte al vento. Forse il virus..?..cmq la mia cr-10s ora stampa veramente bene..

A presto..

Condividi questo messaggio


Link di questo messaggio
Condividi su altri siti

Per caso tu usi anche il BLTouch?

Sull'asse Z anzichè gli interruttori endstop stock della stampante ho montato un BLTouch originale ANTCLAB, ma seppur apparentemente funzioni, ma non mi consente di fare nè l'homing nè il livellamento del piatto, nè col pin Diag dei TMC2209 connesso nè scollegato! Lanciando il livellamento fa l'homing degli assi X e Y, porta l'estrusore al centro del piatto, si alza qualche millimetro,fa un autotest estraendo e ritraendo un paio di volte il pultale, ma prima che l'asse Z possa iniziare ad abbassarsi, sul display compare la scritta "ARRESTATO" e dopo qualche secondo il sensore inizia a lampeggiare rosso...

Se anzichè il livellamento, lancio l'homing, fa esattamente la stessa cosa...

Condividi questo messaggio


Link di questo messaggio
Condividi su altri siti

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Ospite
Rispondi a questa discussione...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Caricamento...



×
×
  • Crea Nuovo...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.