Vai al contenuto

Geeetech Prusa i3 pro b - Z-axis motori vanno in direzioni opposte


Chicca
 Condividi

Messaggi raccomandati

Ciao a tutti,

abbiamo comprato una Geeetech Prusa i3 Pro b. L’abbiamo montata seguendo le istruzioni e dopo aver cliccato auto-home i due motori dell’asse z hanno iniziato a girare in direzioni opposte. Un motore va verso l’alto e l’altro verso il basso.

Come possiamo rimediare?

Grazie!!

Link al commento
Condividi su altri siti

  • Risposte 5
  • Creato
  • Ultima Risposta

Miglior contributo in questa discussione

Miglior contributo in questa discussione

46 minuti fa, Chicca dice:

Ciao a tutti,

abbiamo comprato una Geeetech Prusa i3 Pro b. L’abbiamo montata seguendo le istruzioni e dopo aver cliccato auto-home i due motori dell’asse z hanno iniziato a girare in direzioni opposte. Un motore va verso l’alto e l’altro verso il basso.

Come possiamo rimediare?

Grazie!!

basta invertire i fili nel motore che gira nella direzione opposta.

quando dai il comando home i motori devono portare il piano verso l'alto ma uno dei due tenta di portarlo verso il basso, su questo motore se adesso i 4 fili che lo alimentano sono collegati con lo schema 1234 basta invertirli mettendoli in configurazione 4321.

Link al commento
Condividi su altri siti

Il 30/1/2019 at 18:55, FoNzY dice:

basta invertire i fili nel motore che gira nella direzione opposta.

quando dai il comando home i motori devono portare il piano verso l'alto ma uno dei due tenta di portarlo verso il basso, su questo motore se adesso i 4 fili che lo alimentano sono collegati con lo schema 1234 basta invertirli mettendoli in configurazione 4321.

Grazie FoNzY!

In reatà mio figlio si è sbagliato....uno dei due motori non andava...ora funziona ma quando mettiamo su autohome l'asse z sale invece di scendere.

Secondo lui si dovrebbe ricaricare il firmware ma si dovrebbe usare Arduino 1.0.1 ed il suo MAC non lo supporta. Lui ha mojave e Arduino 1.8.

Consigli su come procedere?

Grazie

Link al commento
Condividi su altri siti

11 minuti fa, Chicca dice:

Secondo lui si dovrebbe ricaricare il firmware ma si dovrebbe usare Arduino 1.0.1 ed il suo MAC non lo supporta. Lui ha mojave e Arduino 1.8.

NO! scaricare un firmware implica il fatto di doverlo editare MANUALMENTE e mi sembra di aver capito che le sonoscenze in materia di stampanti 3d non siano sufficenti per farlo.scaricare un firmware da neofita è un modo sicuro per "abbandonare" la stampante in soffita.....

ARDUINO NON SERVE!. credo che ci sia stato un problema di comunicazione...arduino non serve per usare la stampante 3d.......

arduino ide serve solo a caricare il firmware, ma come ho detto non deve farlo!

ti serve un software cad-->> il programma per disegnare

ti serve il programma per esportare il disegno fatto con il cad in formato .stl--> questo viene fatto spesso dal software cad.

il software di slicing-->> il programma che trasforma l'oggeto (esportato in formato .stl) in movimenti macchina, questi movimenti si chiamano Gcode.

Gcode--> sono solo numeri e lettere ed è l'unico formato che puo' essere interpretato dalla macchina

questo gcode puo' essere trasmesso alla macchina tramite cavo usb o salvato sulla scheda di memoria(se la stampante lo supporta)

il firmware gira nella scheda madre della stampante e non ha iterazioni con altro hardware(nel modo piu' assoluto). esso si occupa esclusivamente di gestire la stampante e NON SI INTERFACCIA IN MODO DIRETTO CON IL PC con la conseguenza che al firmware non importa nulla da quale pc esso viene comandato in quanto esso non è in grado di riconoscerlo!

la soluzione è la stessa dell mio primo post:

se i cavi dei motori sono in posizione 1234 basta invertire in 4321 (per entrambi i motori) questo fa in modo che il motore cambi il senso di rotazione pur ricevendo lo stesso impulso. di conseguenza se prima con l'impulso A girava a destra(in basso) con i fili invertiti gira a sinistra(in alto)

Link al commento
Condividi su altri siti

Ciao FoNzY!

Grazie!! 

Gli diró di fare come dici tu! Lui non ha conoscenze di stampanti 3d ma sa programmare con Arduino.

In ogni modo mi sembra nettamente più semplice invertire i cavi che perdersi nei firmare di Arduino. 🙂

Ti farò sapere come va.....mi sa che avremo un altro milione di domande! 

Grazie ancora

Chicca

 

Link al commento
Condividi su altri siti

Ciao FoNzY!

Abbiamo fatto come hai detto tu ed invertito i cavi.

I problemi sono:

1) Quando clicchiamo AUTO-HOME i motori vanno verso il basso ma solo di poco, poi si fermano (senza essere arrivati al fine corsa)

2) Quando proviamo a portare i motori dell'asse Z  per esempio a 80mm, i motori vanno verso il basso e tornando verso lo ZERO non tornano indietro.

Siamo fermi, HELP!!!

 

 

Link al commento
Condividi su altri siti

Partecipa alla conversazione

Puoi pubblicare ora e registrarti più tardi. Se hai un account, accedi ora per pubblicarlo con il tuo account.

Ospite
Rispondi a questa discussione...

×   Hai incollato il contenuto con la formattazione.   Rimuovere la formattazione

  Sono consentiti solo 75 emoticon max.

×   Il tuo collegamento è stato incorporato automaticamente.   Mostra come un collegamento

×   Il tuo contenuto precedente è stato ripristinato.   Pulisci editor

×   Non puoi incollare le immagini direttamente. Carica o inserisci immagini dall'URL.

 Condividi


×
×
  • Crea Nuovo...