Vai al contenuto

Termocoppia, resistenza o firmware?


 Condividi

Messaggi raccomandati

Ciao, ho una Prusa I3 Pro b. L' estrusore mk8 non raggiunge i 210 gradi impostati, ma si aggira intorno ai 150. Ho già cambiato l' estrusore una volta, pensando che quello che avessi fosse difettato. I motori e il piatto caldo funzionano, quindi ho escluso il problema della scheda madre. Il firmware che uso è il Marlin e il programma PC è Repetier. 

Grazie a chi riuscirà ad aiutarmi nel farla partire.

Link al commento
Condividi su altri siti

Per il rilevamento della temperatura esistono diversi termistori, in genere si utilizzano termistori da 100k ma ne esistono di tutti i tipi ed a volte i costruttori cambiano il tipo di terrmistore utilizzato, Per prima cosa dovresti verificare che termistore hai e se non è da 100k devi correggere il Marlin che prevede i diversi termistori, come pure più probabilmente può essere che tu abbia un regolare termistore da 100K e che il tuo Marlin non sia regolato per questo termistore. Il fatto che abbia cambiato l'estrusore e non sia modificato nulla fa propendere per questa seconda soluzione che per altro è più difficile che di verifichi come problema.

Escludo che sia un problerma meccanico dato che dici che lo hai cambiato e suppongo che tu lo abbia cambiato tutto e non in parte.

Io come prima cosa ti consiglierei di scaricare il firmware per la tua stampante , verificare nel Marlin, nel file configuration.h  che la sezione Thermal Settings sia regolata su un termistore da 100k, dopo di che lo inserisci nella stampante.

Se la stampante è nuova puoi chiedere anche informazioni al fornitore, in genere sono più che disponibili.

  • Like 1
Link al commento
Condividi su altri siti

Se prima ha funzionato e ad un certo punto la temperatura si è fermata ai 150 gradi, anche cambiando l'estrusore, allora probabilmente la porta del convertitore della scheda è andata o si è alterata la resistenza di pull-up. Ma che scheda hai montata ?

Link al commento
Condividi su altri siti

Anche senza termometro basta vedere se il filamento si fonde o meno per capire se i 150 gradi sono reali o farlocchi, in genere 

di natura loro (poi il firmware li limita) gli estrusori sono in grado di arrivare senza problemi ai 300 gradi, Se la macchina è nuova e monta una gt2560 contatta il fornitore che molto probabilmente ti manda una gt2560 nuova. 

Probabilmente è difettoso il relativo circuito  di controllo 

Link al commento
Condividi su altri siti

.Se sai dove mettere le mani potresti dare una 12 volt esterna direttemente all estrusore ovviamente staccando il connettore dalla scheda. La polarità in questo caso non è importante. Prima però memorizza il tempo necessario per arrivare ai famosi 150 gradi. Vedi se in questo tempo riesci a raggiungere una temperatura più alta.Sarebbe anche una buona cosa collegare in serie alla 12 v un amperometro per vedere la corrente assorbita che dovrebbe essere intorno ai 2.5 ampere se non ricordo male.Ovviamente al di sotto di tale valore l estrusore potrebbe essere di 24 volt

  • Like 1
Link al commento
Condividi su altri siti

Ok facci sapere se riesci a far funzionare il tutto. Io ho avuto diverse noie con la 2560 e la ramps anche con l estrusore.Infatti da maker puro me ne sono costruita una con un microcontrollore diverso da arduino e ho scritto anche il software per il controllo

Link al commento
Condividi su altri siti

Partecipa alla conversazione

Puoi pubblicare ora e registrarti più tardi. Se hai un account, accedi ora per pubblicarlo con il tuo account.

Ospite
Rispondi a questa discussione...

×   Hai incollato il contenuto con la formattazione.   Rimuovere la formattazione

  Sono consentiti solo 75 emoticon max.

×   Il tuo collegamento è stato incorporato automaticamente.   Mostra come un collegamento

×   Il tuo contenuto precedente è stato ripristinato.   Pulisci editor

×   Non puoi incollare le immagini direttamente. Carica o inserisci immagini dall'URL.

 Condividi


×
×
  • Crea Nuovo...