Vai al contenuto

problema homing


 Condividi

Messaggi raccomandati

salve... posseggo una prusa i 3 con ramps 1.4 e l'ho configurata con marlin.


quando stampo la stampante funziona molto bene nessun problema...


l'unico problema è che quando finisce di stampare la stampante non ritorna nell punto di homing sarebbe piu comodo che la stampante si porti da sola alla fine della stampa al suo min (homing) in modo da poter togliere più facilmente il pezzo e essere pronta per nuova stampa...


è possibile fare queste regolazioni ma soprattutto come faccio???


Link al commento
Condividi su altri siti

  • Risposte 10
  • Creato
  • Ultima Risposta

Miglior contributo in questa discussione

ciao! basterebbe aggiungere alla fine del gcode i comandi per mandare in home gli assi X e Y ! 


Se utilizzi cura è un procedimento semplicissimo basta che nella barra a sinistra vai su "Start/End-Gcode"  selezioni end-code 


 


A questo punto trovi la linea di codice con scritto G28 e la trasformi in G28 X0 Y0


 


Fammi sapere! 


Link al commento
Condividi su altri siti

io efiterei di fare l'home dell'asse z, in quanto rischi che l'asse sbatti contro l'oggetto stampato!

per la ventola dell'estrusore non capisco perche vuoi accenderla anche durante il riscaldamento, aumenti di molto l'attesa prima di stampare comunque il comando è questo 

M106 S150

con il 150 che può essere una valore che varia tra (0-255) dove 255 è la velocità massima e 0 è spento 

Link al commento
Condividi su altri siti

grazie mille


la voglio accendere perche altrimenti il filo mi si fonde anche sopra all estrusore e poi non estrude piu... anche se per far riscaldare l'estrusore ci vuole poco il problema è il letto che ci mette una 10 di min 


per l'asse z hai ragione non serve perche tanto prima di cominciare a stampare fa l'homing e poi comincia ma prima (con il problema dei fine corsa) non mi faceva l'homing.


Link al commento
Condividi su altri siti

  • 3 settimane dopo...

ho riscontrato un  problema ovvero quando mando in stampa lui va in home e poi si posiziona dove ho messo l'oggetto su cura ma l'asse z va ancora piu giu di quanto possa andare pure se il fine corsa glielo impedisce lui continua infatti ogni volta devo manualmente far girare i motori e alzare un po l'asse z altrimenti l'ugello sta proprio attaccato al piatto e non esce il filamento...

da cosa puo dipendere un errore mio nel firmere di arduino o una cosa di cura...
perche quando gli dico di fare home dallo schermo lui fa una homing perfetto...

quindi secondo me dipende da cura....

Link al commento
Condividi su altri siti

  • 1 mese dopo...

ciao andrea 123, ho avuto un problema simile con la mia prusa. non uso pronterface e non uso cura; io ho modificato i parametri del firmware (io ho marlin) e dopo alcuni tentativi sono riuscito a farlo funzionare in modo corretto; in questo modo non sei obbligato ad inserire nessun valore aggiuntivo a pronterface perchè è già tutto nel firmware.


fammi sapere se hai già risolto il problema che in caso contrario cerco di darti una mano :)

Link al commento
Condividi su altri siti

Partecipa alla conversazione

Puoi pubblicare ora e registrarti più tardi. Se hai un account, accedi ora per pubblicarlo con il tuo account.

Ospite
Rispondi a questa discussione...

×   Hai incollato il contenuto con la formattazione.   Rimuovere la formattazione

  Sono consentiti solo 75 emoticon max.

×   Il tuo collegamento è stato incorporato automaticamente.   Mostra come un collegamento

×   Il tuo contenuto precedente è stato ripristinato.   Pulisci editor

×   Non puoi incollare le immagini direttamente. Carica o inserisci immagini dall'URL.

 Condividi


×
×
  • Crea Nuovo...