Vai al contenuto
  • Iscriviti al forum

    Iscriviti al forum per usufruire di tutti i contenuti: la registrazione è gratuita!

Recommended Posts

salve a tutti, oggi ho provato a fare un test sul retraction sul PLA con la mia X5S. il test l'ho trovato sul thingiverse ed è venuto fuori sta roba qua

https://www.thingiverse.com/thing:909901

i parametri di stampa su cura sono temperatura nozzle 210°C, temperatura bed 50°C, retraction 4.9mm, retraction speed 40mm/s, layer 0.1mm. avevo pure attivato lo Z-hop when retracted.

20190402_202036.thumb.jpg.1707d7fefcd3af7acb67170525688dae.jpg

qua un'altra angolazione

20190402_202102.thumb.jpg.cb0ce45d9077e97b01c48afc18fec612.jpg

 

Avete qualche idea per risolvere il problema? Va aumenta la retraction o la speed? 

Condividi questo messaggio


Link di questo messaggio
Condividi su altri siti
12 ore fa, I3D&MLab dice:

Avete qualche idea per risolvere il problema? Va aumenta la retraction o la speed? 

Devi lavorare su entrambi. Prima aumenta la retraction finchè non scompare lo stringing (senza arrivare a valori assurdi), poi una volta che lo stringing scompare aumenti la velocità mantenendo un rumore accettabile dell'estrusore. Trovata la velocità, provi ad abbassare la distanza di retraction.

In pratica, stando al manuale Prusa, devi avere la retracion distance il più bassa possibile e la velocità più alta possibile, senza introdurre artefatti nelle stampe (retraction troppo alta) o far fare rumori strani all'estrusore (velocità troppo alta)

Anche l'accelerazione a livello firmware è importante (altrimenti devi salire tantissimo con la velocità) e la velocità dei travel (movimenti non di stampa)

Prova con questo file di @Tomto fatto per me, ma va bene anche a te. 

Fa in una singola stampa, 6 test diversi di retraction. Prendi il migliore e lavora a partire da quello.

Condividi questo messaggio


Link di questo messaggio
Condividi su altri siti
12 minuti fa, iLMario dice:

Devi lavorare su entrambi. Prima aumenta la retraction finchè non scompare lo stringing (senza arrivare a valori assurdi), poi una volta che lo stringing scompare aumenti la velocità mantenendo un rumore accettabile dell'estrusore. Trovata la velocità, provi ad abbassare la distanza di retraction.

In pratica, stando al manuale Prusa, devi avere la retracion distance il più bassa possibile e la velocità più alta possibile, senza introdurre artefatti nelle stampe (retraction troppo alta) o far fare rumori strani all'estrusore (velocità troppo alta)

Anche l'accelerazione a livello firmware è importante (altrimenti devi salire tantissimo con la velocità) e la velocità dei travel (movimenti non di stampa)

Prova con questo file di @Tomto fatto per me, ma va bene anche a te. 

Fa in una singola stampa, 6 test diversi di retraction. Prendi il migliore e lavora a partire da quello.

ah ok non sapevo questi particolari, lo provo sicuramente quel test. grazie mille 🙂

su Ultimaker Cura non me lo fa aprire, probabile perchè non riesce a gestire lo start e l'end g-code

Aperto su repetier comunque. a fine stampa va a X=0 ma continua a muoversi fino a Y=180, hai la home li sulla tua?

838027894_retractiontomto.thumb.png.6c7001be5eed9888ae20a2aa5cdefc50.png

Condividi questo messaggio


Link di questo messaggio
Condividi su altri siti
58 minuti fa, I3D&MLab dice:

Aperto su repetier comunque. a fine stampa va a X=0 ma continua a muoversi fino a Y=180, hai la home li sulla tua?

 

No, avendo il sensore la mia home è al centro del bed.

Condividi questo messaggio


Link di questo messaggio
Condividi su altri siti

ecco altri due test che ho fatto alzando la retraction e la retraction speed, purtroppo entrambi presentano ancora il problema.

1) temperatura nozzle 210°C, temperatura bed 50°C, retraction 5.5mm, retraction speed 50mm/s, layer 0.1mm. avevo pure attivato lo Z-hop when retracted.

20190403_212806.thumb.jpg.51d8b2ee34a63b1781a197b030891116.jpg

 

2) temperatura nozzle 210°C, temperatura bed 50°C, retraction 6.0mm, retraction speed 60mm/s, layer 0.1mm. avevo pure attivato lo Z-hop when retracted.

20190403_212820.thumb.jpg.e77b7d16fd24731e3542512ff3b5451d.jpg

e poi come consigliatomi da @iLMario ho provato il test di @Tomto ed è venuta fuori sta cosa mostruosa

20190403_212353.thumb.jpg.cc79a05adc8657b082b8eac3c1f21f85.jpg

qui un'altra vista dove ho indicato con la freccia in rosso dove la situazione sembra migliorare. Ragazzi a quell'altezza dove non si rileva il problema (segnata dalla freccia) che parametri di retraction e retraction speed avete impostato nel g-code?

20190403_212409.thumb.jpg.693d20bd5c6d598e1caffa1b68add911.jpg

 

ps

mi sono accorto che mentre la temperatura del nozzle del g-code era fissata a 205°C sull'LCD segnava a tratti anche 195°C. dite che può influire sul problema?

Condividi questo messaggio


Link di questo messaggio
Condividi su altri siti
12 minuti fa, I3D&MLab dice:

mi sono accorto che mentre la temperatura del nozzle del g-code era fissata a 205°C sull'LCD segnava a tratti anche 195°C. dite che può influire sul problema?

Si.

10 gradi sono troppi, sistema prima questa cosa, poi il resto

Condividi questo messaggio


Link di questo messaggio
Condividi su altri siti

il gcode è per extrusion width 0.4 flow 1 ma quei valori di retrazione acc. sono adatti ad estrusore 3:1clone e tubo teflon capricorn clone(il classico tubo cinese non va bene)

Condividi questo messaggio


Link di questo messaggio
Condividi su altri siti
26 minuti fa, iLMario dice:

Si.

10 gradi sono troppi, sistema prima questa cosa, poi il resto

Questa problematica non l'avevo riscontrata fino ad ora sulle altre stampe che facevo anche a 210 gradi con bed a 50 gradi. in quei casi peró il g-code lo creavo in ultimaker cura quindi credo dipenda dal codice se in questa stampa del test di @Tomto succede. Oppure e questa é un'altra possibilitá il piano a 60 gradi e l'estrusore a 205 gradi assorbono troppa potenza per l'alimentatore?

21 minuti fa, Tomto dice:

il gcode è per extrusion width 0.4 flow 1 ma quei valori di retrazione acc. sono adatti ad estrusore 3:1clone e tubo teflon capricorn clone(il classico tubo cinese non va bene)

Aspetta non ti seguo, quindi che modifiche si dovrebbero fare? io ho un mk10 con tubo ptfe 

Condividi questo messaggio


Link di questo messaggio
Condividi su altri siti
30 minuti fa, I3D&MLab dice:

Questa problematica non l'avevo riscontrata fino ad ora sulle altre stampe che facevo anche a 210 gradi con bed a 50 gradi. in quei casi peró il g-code lo creavo in ultimaker cura quindi credo dipenda dal codice se in questa stampa del test di @Tomto succede. Oppure e questa é un'altra possibilitá il piano a 60 gradi e l'estrusore a 205 gradi assorbono troppa potenza per l'alimentatore?

Aspetta non ti seguo, quindi che modifiche si dovrebbero fare? io ho un mk10 con tubo ptfe 

Io e  @iLMario abbiamo lo stesso tipo di estrusore e tubo teflon e hothend . Lui tramite wall test ha ottenuto una extrusion width di 0.4. Da li gli o passato un mio g code. Tu hai bisogno di retrazioni più alte e velocità(quale hotend usi) per via dei tubi cinesi con diametri interni "eccessivi"(creano un effetto molla)che non sono presenti in tale g code. Se mi dici quale è il tuo flow ed extrusion  width e quali valori di retrazione e velocità vorresti provare posso darti un g code che fa al caso tuo

Condividi questo messaggio


Link di questo messaggio
Condividi su altri siti
1 ora fa, Tomto dice:

Io e  @iLMario abbiamo lo stesso tipo di estrusore e tubo teflon e hothend . Lui tramite wall test ha ottenuto una extrusion width di 0.4. Da li gli o passato un mio g code. Tu hai bisogno di retrazioni più alte e velocità(quale hotend usi) per via dei tubi cinesi con diametri interni "eccessivi"(creano un effetto molla)che non sono presenti in tale g code. Se mi dici quale è il tuo flow ed extrusion  width e quali valori di retrazione e velocità vorresti provare posso darti un g code che fa al caso tuo

io uso questo mk10 con un bowden extruder.

image.png.b0bd66d0c0a1039fc2072f6ad03c0457.png

il flow è impostato su 100% che è il valore stock di Cura e che io non ho modificato mentre l'extrusion width non lo trovo su cura ma credo che dovrebbe coincidere con il diametro del nozzle ovvero 0.4mm

Se potessi modificare il g-code per adattarlo allamia x5s sarebbe fantastico, scusa se ti rompo le scatole ma non saprei dove mettere mano sul codice per sistemarlo 🙂 . volevo capire la logica del test, salendo di quota aumenta sia retraction speed che retraction?

Condividi questo messaggio


Link di questo messaggio
Condividi su altri siti
11 minuti fa, I3D&MLab dice:

io uso questo mk10 con un bowden extruder.

image.png.b0bd66d0c0a1039fc2072f6ad03c0457.png

il flow è impostato su 100% che è il valore stock di Cura e che io non ho modificato mentre l'extrusion width non lo trovo su cura ma credo che dovrebbe coincidere con il diametro del nozzle ovvero 0.4mm

Se potessi modificare il g-code per adattarlo allamia x5s sarebbe fantastico, scusa se ti rompo le scatole ma non saprei dove mettere mano sul codice per sistemarlo 🙂 . volevo capire la logica del test, salendo di quota aumenta sia retraction speed che retraction?

in linea di massima si 3mm di retazione non sembrano andar bene nel tuo caso possiamo partire con quello ed arrivare a 6mm con differenti velocità . In cura la larghezza della linea (extrusion width) è 0.45 di default(nel menu qualità è la terza voce) . ma devi fate il thin wall test per assicurarti che tale valore sia rispettato.

Condividi questo messaggio


Link di questo messaggio
Condividi su altri siti
6 minuti fa, Tomto dice:

in linea di massima si 3mm di retazione non sembrano andar bene nel tuo caso possiamo partire con quello ed arrivare a 6mm con differenti velocità . In cura la larghezza della linea (extrusion width) è 0.45 di default(nel menu qualità è la terza voce) . ma devi fate il thin wall test per assicurarti che tale valore sia rispettato.

trovato ora, cercavo extrusion width per quello non lo trovavo

width.png.79b4f75e1be6e90297e2f559eafcd5cb.png

il test del wall l'ho fatto perchè avevo un problema di striature

e se il wall lo imposto 0.4mm ovvero un solo perimetro e vado a fare la misura col calibro esce fuori proprio 0.4mm

 

Condividi questo messaggio


Link di questo messaggio
Condividi su altri siti
9 ore fa, I3D&MLab dice:

trovato ora, cercavo extrusion width per quello non lo trovavo

il test del wall l'ho fatto perchè avevo un problema di striature

e se il wall lo imposto 0.4mm ovvero un solo perimetro e vado a fare la misura col calibro esce fuori proprio 0.4mm

 

Ok dimmi quali valori di retraction vuoi provare e a quali velocità così ti passo il gcode 

Condividi questo messaggio


Link di questo messaggio
Condividi su altri siti
50 minuti fa, Tomto dice:

Ok dimmi quali valori di retraction vuoi provare e a quali velocità così ti passo il gcode 

ad ora i test che ho fatto in cui c'era il problema sono stati a 210°C/50°C :

1) 4.9mm di restraction e 40mm/s di speed retraction

2) 5.5mm di restraction e 50mm/s di speed retraction

3) 6.0mm di restraction e 60mm/s di speed retraction

Nel tuo test invece al quarto piano della torretta non si è verificato il problema, li a quanto stanno retraction e speed retraction?

image.png.575bce1d713239cd0ce0aa8a0dabd209.png

Condividi questo messaggio


Link di questo messaggio
Condividi su altri siti
3 minuti fa, Tomto dice:

3mm retraction 45mm/s pulitura ugello 2mm

allora direi di stare con valori attorno a quelli li. ogni piano della torre avrà una sua combinazione di retraction e retraction speed giusto quindi si possono fare 6 combinazioni?

 

Condividi questo messaggio


Link di questo messaggio
Condividi su altri siti
29 minuti fa, I3D&MLab dice:

allora direi di stare con valori attorno a quelli li. ogni piano della torre avrà una sua combinazione di retraction e retraction speed giusto quindi si possono fare 6 combinazioni?

 

si

Condividi questo messaggio


Link di questo messaggio
Condividi su altri siti
9 minuti fa, Tomto dice:

si

ok allora direi di fare una prova con temperature 210°C/50°C:

1)4.0mm con 45mm/s

2)3.5mm con 45mm/s

3)3.0mm con 45mm/s

4)2.5mm con 45mm/s

5)3.0mm con 40mm/s

6)3.0mm con 50mm/s

grazie ancora 🙂

Condividi questo messaggio


Link di questo messaggio
Condividi su altri siti

Eccomi coi risultati gente

@Tomto quasta volta è andata meglio della prima 🙂

20190404_144052.thumb.jpg.5406b3fe29a60aaef80d39dd22512f68.jpg

e direi che il migliore sembra il secondo piano, quindi 3.5mm di retraction a 45mm/s. la pulitura ugello dove la si trova in Cura?

20190404_144136.thumb.jpg.e9fb4549cb93597f6264f497ea78bfc1.jpg

ps

anche a sto giro la temperatura segnata dal LCD per quanto riguarda il nozzle era intorno a 195°C invece dei 210°C del g-code. boh devo indagare la cosa, penso di modellare la cosa in solidworks e di creare il g-code con Cura e vedere se ricapita

Condividi questo messaggio


Link di questo messaggio
Condividi su altri siti

Tutti quei fili spenzoloni li non mi sembrano problemi di retraction. La retraction di solito ti fa fare fili sottili, tipo capelli o oozing vicino al pezzo (ad esempio a sinistra del 4). Li io vedo proprio una estrusione quasi completa.

Condividi questo messaggio


Link di questo messaggio
Condividi su altri siti
1 minuto fa, iLMario dice:

Tutti quei fili spenzoloni li non mi sembrano problemi di retraction. La retraction di solito ti fa fare fili sottili, tipo capelli o oozing vicino al pezzo (ad esempio a sinistra del 4). Li io vedo proprio una estrusione quasi completa. 

si li pare il problema sia la mancanza di sostegno nel bridge e probabile anche il raffreddamento materiale un po scarso. penso che stamperò quanto prima un nuovo condotto di raffreddamento radialfang perchè quello stock spara l'aria in alto e non mi pare molto intelligente.

Io mi riferivo al secondo piano come il migliore perchè oltre a non presentare i filamenti, la forma della superficie del cilindro a sinistra (dove c'è la freccia rossa) non è minimamente sporcata da quei riccioli. boh penso che farò qualche prova a 3.5mm e 45mm/s a varie temperature ora così vedo che succede

20190404_144136.thumb.jpg.7d0ec53c5f22790bc042dbe1f3a8ef7d.jpg

Condividi questo messaggio


Link di questo messaggio
Condividi su altri siti
1 ora fa, I3D&MLab dice:

si li pare il problema sia la mancanza di sostegno nel bridge e probabile anche il raffreddamento materiale un po scarso. penso che stamperò quanto prima un nuovo condotto di raffreddamento radialfang perchè quello stock spara l'aria in alto e non mi pare molto intelligente.

Io mi riferivo al secondo piano come il migliore perchè oltre a non presentare i filamenti, la forma della superficie del cilindro a sinistra (dove c'è la freccia rossa) non è minimamente sporcata da quei riccioli. boh penso che farò qualche prova a 3.5mm e 45mm/s a varie temperature ora così vedo che succede

 

Comunque da slicer i parametri di ponte son impostati, ma questo più che altro è un test per la retraction i ponti servono solo per indicare in che punto è stato impostato un determinato valore.

Condividi questo messaggio


Link di questo messaggio
Condividi su altri siti
1 ora fa, Tomto dice:

Comunque da slicer i parametri di ponte son impostati, ma questo più che altro è un test per la retraction i ponti servono solo per indicare in che punto è stato impostato un determinato valore.

si certo il focus è sul retraction. ho riprovato il test di thingiverse con cui avevo iniziato ma impostando questa volta su Cura retraction 3.5mm e speed retracion 45mm/s a 210°C/50°C  e  200°C/50°C ma il problema ancora persiste, che cavolo sarà? provo a salire di speed?🤔

20190404_171350.thumb.jpg.2862a008f3143cf294f122fca41ea416.jpg

 

 

Condividi questo messaggio


Link di questo messaggio
Condividi su altri siti

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Ospite
Rispondi a questa discussione...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Caricamento...



  • Contenuti simili

    • Da Davide Vignati
      Salve, io utilizzo una macchina Anycubic i3 mega S, e come slicer cura. 
      Qualcuno puo dirmi come poter salvare nel gcode una procedura che mi permette di stampare, finito un pezzo, subito un altro? Ovviamente tenendo le dovute distanze per non intersecare le une con le altre.
    • Da I3D&MLab
      Salve a tutti,
      è da un pezzo che manco per problemi di lavoro, spero di non essere fuori tempo massimo 🙂 .
      qualche mese fa avevo in cantiere di fare un kit di upgrade per la mia Tronxy X5S al fine di poter riallineare le cinghie degli assi X e Y che stock erano parecchio incasinate e tendevano a innescare un meccanismo di pulsazione del carrello del nozzle. Ho riprogettato le piastre degli stepper poste sul posteriore aggiungendo un rinforzo laterale e spostando i motori verso l'esterno.

      Allo stesso tempo  ho rifatto le piastre anteriore in modo tale da sdoppiare le pulegge di X e Y (le pulegge sono quelle di Shurak prese sul thingiverse)  in maniera di avere delle cinghie allineate con le pulegge degli stepper. Ecco il risultato

      qui si vede il doppio piano delle pulegge e anche il sistema per tendere la cinghia

    • Da I3D&MLab
      Tronxy X5S

      Link al sito del produttore
      http://www.tronxy.com/web/index.php?topclassid=11&classid=17&id=43&lanstr=en&wap=1
       
      Supporto
      http://www.tronxy.com/web/index.php?topclassid=57&classid=61&lanstr=en&wap=1
       
      Descrizione stampante
      La X5S è entrata in commercio nel gennaio 2018, è una stampante FDM di tipologia CoreXY. Questo modello è stato sostituito dalla X5SA con elettronica aggiornata

      Caratteristiche tecniche

      -Alimentatore stock  360W a 12V

       
      -Firmware  Marlin
       
      -Mainboard Melzi 8bit
      -
      -Hotend MK10

      -Cooling System a doppia ventola

       
      -Heatedbed da 330x330 mm Reprap MK3a 12V/24V
      NB. la saldatura dei cavi sulle piastre dell'heatedbed era fatta male perchè a 12V va saldato un ponte fra 2 e 3 affinchè il piano possa riscaldarsi completamente e questo mancava

      Video sull'assemblaggio
       
      Consigli sulla manutenzione
      il produttore della stampante non fa minimamente menzione al discorso manutenzione quindi meglio colmare la lacuna. Vanno oliate le barre di Z su cui scorrono i cuscinetti lineari almeno mensilmente. Io uso l'olio per macchine da cucire e funziona bene. Sulle barre filettate trapezie va messo il grasso, io uso quello al litio e questo raccoglie lo sporco quindi va pulito regolarmente e riapplicato. Consiglio di dare una pulita all'ugello dell'hotend prima di ogni stampa perchè eventuali residui possono inficiare la qualità della stampa.
      Procedure di calibrazione
      Prima di ogni stampa in "Prepare" impostare gli end-stop e dare il comando Auto-home, dopodichè livellare il piano usando uno spessimetro con spessore 0.1mm.
      Effettuare la calibrazione usando un cubetto 20x20x20 andando a modificare la sringa di comando contenente il comando M92 ogni volta che si tensionano le cinghie.
       
      Impostare Cura Engine su Repetierhost v 2.1.3 e su Ultimaker Cura 4.0.0 per il PLA

      Test di stampa
      Cubetto alfabetagamma
              
       
      Retraction
      Raccolta di VideoReview sulla X5S
      Sgabolab
       
      DIY3DTECH.com
      3DMN
      Chris Riley
       
       
      Upgrade
      24V Bed +external Mosfet
       
      Allineamento cinghie
       
      Link upgrade su Thingiverse
       
       
       
      varianti della Tronxy X5S
      X5SA (ha una nuova mainboard e un LCD con touchsreen)

       
      X5S-2E ha il doppio estrusore

      X5S-400 ha volume di stampa 400mm x 400mm x 400mm

      X5S-500 ha volume di stampa 500mm x 500mm x 500mm

       
       
       
       
       
       
       
       
       
       
       
       
       
    • Da I3D&MLab
      Salve a tutti sono Angelo e avrei qualche domanda relativa a Cura. ho provato a cercare nell'elenco del software il mio modello ma purtroppo non c'è quindi mi pare di capire dovrei scegliere quello custom. dove potrei trovare i valori da inserire nel form?
       
      Edit
      riporto in questo primo post qualche screebshot della configurazione che ho impostato e testato con successo.
       
      RepetierHost v2.1.3 Cura Engine
      Fonzy ha creato un profilo specifico per Cura Engine della X5S per stampa del PLA
      profilo tronxy Fonzy.rcp
      in RepetierHost basta scegliere come slicer CuraEngine e importare il profilo
       
      Ultimaker Cura 4.0.0
      una volta ggiunta un nuova stampante Custom e rinominata Tronxy X5S si procede impostando gli offset in Printer Settings. In printhead Settings ho messo 0 perchè non mi interessa l'ingombro della testa di stampa andando a stampare i componenti sul piano tutti in parallelo.

      si deve poi inserire lo start g-code che dirà alla stampante come muovere l'estrusore e prepararsi per il riscaldamento dell'hotend e dell'heatedbed
      Start G-code
      M92 X81.21 Y80.4 E93.70
      G28
      G1 Z15 F100
      M107
      G90
      M82
      M190 S50
      M104 T0 S210
      G92 E0
      M109 T0 S210
      End G-code
      M107
      G91
      G1 Z60 F100
      T0
      G1 E-1
      M104 T0 S0
      G90
      G92 E0
      M140 S0
      M84
      questi invece i setting per l'estrusore

       
       
       
      appena finisco i test posto gli screenshot anche dei vari parametri di stampa
       
  • Discussioni

  • Collaboratori più popolari

  • Chi sta navigando

    Nessun utente registrato visualizza questa pagina.

×
×
  • Crea Nuovo...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.