Vai al contenuto

MarlinKimbra Firmware


 Condividi

Messaggi raccomandati

Ciao a tutti, non so se questa è la sezione giusta per questo argomento, e in caso chiedo ai mod di spostare il post.

Vengo al dunque...

Premetto che di firmware e modifiche con arduino ecc ecc, ci capisco poco e sto cercando di imparare "facendo", quindi chiedo scusa per l'ignoranza. In pratica vorrei provare il firmware di cui in oggetto sulla mia prusa hephestos, avendone letto un gran bene.

Come prima cosa ho pensato di provare la versione che si ottiene con il configuratore  online scegliendo  il modello preconfigurato, che da quello che ho letto è stato fatto prendendo altri firmware provenienti dalle hephestos; quindi una volta scelto il modello, scorro fino alla fine con il tasto next fino a scaricare il firmware sul mio pc.

Scompatto il file zip, apro il file con arduino 1.6.7 e qui partono i problemi; nello specifico, una volta aperto il file .ino clicco sul tasto "verifica" e parte il compilatore. Tutto a un tratto cominciano a venire tante scritte in arancio in basso fino a bloccare il compilatore con dichiarazioni di errore.

Quello che non capisco è : essendo il file scaricato direttamente dal configuratore per la hephestos, senza modifica alcuna, non dovrebbe essere privo di errori di compilazione?

Altro passaggio

Ho provaro anche a fare una versione custom, per un'altra stampante che sto facendo in casa, che utilizza sempre ramps 1.4 ma con lcd 12864.; ho provveduto a settarlo in fase di configurazione, e poi una volta in arduino ho caricato le librerie U8glib.h, ma anche li una sfilza di errori e nulla più.

Provando a compilare un marlin normale invece riesco a portare in fondo la compilazione e il caricamento sulla mega (sempre scollegata dalla ramps).

Sicuramente sto commettendo errori grossolani, ma non capisco quali. Se qualche anima buona  può indicarmi un sentiero da seguire,.....gliele sarei molto grato.

Grazie

Pino

Link al commento
Condividi su altri siti

  • Risposte 3
  • Creato
  • Ultima Risposta

Miglior contributo in questa discussione

Miglior contributo in questa discussione

Immagini Pubblicate

Alla fine prova e riprova sono riuscito a caricare il firmware anche se gli errori di compilazione rimangono. La compilazione comunque non si blocca e sembra, nonostante tutte le scritte arancio in basso , che funzioni. Ho caricato il tutto sulla Arduino mega, a fatto un test sulla meccanica in fase di assemblaggio. Per ora sono contento, ora continuo a montare gli ultimi pezzi e poi iniziò con le tarature vere e proprie.

 

Link al commento
Condividi su altri siti

Guarda che se va in errore o perchè non trova una libreria, o perchè c'è qualche valore o percorso sbagliato, mi risulta che si blocca la compilazione.Se la compilazione va a buon fine quindi quelle scritte rosse non dovrebbero segnalare errori ma semplicemente "operazioni" durante la compilazione...

Le ho anche io con tutte le versioni che compilo.....

Link al commento
Condividi su altri siti

Partecipa alla conversazione

Puoi pubblicare ora e registrarti più tardi. Se hai un account, accedi ora per pubblicarlo con il tuo account.

Ospite
Rispondi a questa discussione...

×   Hai incollato il contenuto con la formattazione.   Rimuovere la formattazione

  Sono consentiti solo 75 emoticon max.

×   Il tuo collegamento è stato incorporato automaticamente.   Mostra come un collegamento

×   Il tuo contenuto precedente è stato ripristinato.   Pulisci editor

×   Non puoi incollare le immagini direttamente. Carica o inserisci immagini dall'URL.

 Condividi


×
×
  • Crea Nuovo...