Vai al contenuto

Riccardo Betteti

Membri
  • Numero contenuti

    15
  • Iscritto

  • Ultima visita

Reputazione Forum

2 Neutral

Su Riccardo Betteti

Visite recenti

Il blocco dei visitatori recenti è disabilitato e non viene mostrato ad altri utenti.

  1. si ma nel documento "Configuration.h" devo mettere io che display sto usando. Il problema è anche software. ho fatto come hai detto ma lo schermo non si accende, ho visto che quel tizio metteva una sd con dentro un file ma a me non funziona. Già che ci sei dimmi dove devo attaccare i cavi, su tft o exp?
  2. Lo schermo attuale è solo touch e ha 4 cavi che escono. I normali schermi si attaccano con molti più pin. Poi del resto non so, solo che non trovo nemmeno il nome e quindi non posso configurare marlin per usarlo.
  3. Salve, ho recentemente installato marlin sulla mia stampante ma ho un dubbio: voglio capire se posso tenere lo schermo in stock. Il fatto è che funziona solo col touch screen (non ha la rotella) e non ha i normali attacchi per "EXP1" e "EXP2", ha 4 cavi con nome "tx" "rx" "np" e "GND". ho visto un tizio che attacca i cavi nella presa "TFT" della scheda, ma non spiega bene la parte software. Inoltre il tizio ha messo il software che era in stock. Qualcuno mi sa aiutare?
  4. Ok ho risolto e finalmente marlin va (ho scaricato una versione gia compilata). Unico problema il fatto che è settata per un display diverso dal mio e mi chiedevo se posso mantenere il display originale della ender 5 plus. ho cercato su internet ma non trovo il nome e ho visto che collegano alla sceda due cavi (mentre il mio display ne ha 1 solo).
  5. nella versione che hai citato manchino le impostazioni per lo schermo in stock, e io non lo voglio cambiare. Dice: 'DGUS_SERIAL' was not declared in this scope; e poi 'DGUS_BAUDRATE' was not declared in this scope;
  6. Ho rifatto da capo e ora è sparito il problema delle directory, ma....si è aggiunto un errore nel file "DGUSDisplay.cpp" che mi dice che non ho definito una cosa. Sussiste il problema dei pins.
  7. adesso ho disinstallato platformio ma il computer ha deciso di diventare lento. tu hai scaricato l versione bugfix o quella normale?
  8. appena fatto ma da lo stesso errore. mancano delle cartelle in ".pio". adesso lo reinstallo e ci riprovo ma sussiste l'altro errore dei pin (nonostante io abbia rimesso il file originale)
  9. no l'enviroment è già "LPC1769". la mia stampante è una ender 5 plus e la scheda una skr 1.4 turbo originale prima ho commentato l'errore dalla SanityCheck e mi ha dato quegli errori che riguardano la directory
  10. ho riguardato adesso e i pin che sono in conflitto sono: "e serial tx pin" con "e1 cs pin" e "e0 cs pin". penso che sia giusto che coincidano però. ------------------------------------------------------------ questi sono i pin degli stepper: #define X_STEP_PIN P2_02 #define X_DIR_PIN P2_06 #define X_ENABLE_PIN P2_01 #ifndef X_CS_PIN #define X_CS_PIN P1_10 coincide #endif #define Y_STEP_PIN P0_19 #define Y_DIR_PIN
  11. l'errore c'era anche prima e sono sicuro che il nome è quello giusto. riguardo la versione si tratta già di una versione bugfix
  12. avevo lo stesso problema e ho risolto: devi staccare l'heater block dal dissipatore (quello rosso). per farlo dovrebbe esserci una vitina alla base del dissipatore. a questo punto sviti l'estrusore, poi avviti più in fondo il "tubo" metallico che collega dissipatore a heater block. a questo punto basta riattaccare l'estrusore. se parte della filettatura dell'estrusore rimane fuori (quando lo avviti fino in fondo) vuol dire che l'hai fatto bene. spiego meglio: il tubo che ospita al suo interno il ptfe deve toccare l'estrusore e per essere sicuro che tocchi la migliore cosa da fare è avvita
  13. Salve, sto cercando di mettere marlin sulla mia nuova scheda, ma quando faccio partire il "Build" (uso platformIO su Visual Studio Code) mi da un messaggio di errore ( Serial port pins conflict with E stepper pins). Ora, io sto cercando di mettere marlin su una skr 1.4 turbo, e sono sicuro di avere assegnato i giusti pin ai file "pins_BTT_skr_1_4.h" e a "pins_BTT_skr_common.h" (a parte le parti oscurate, che quindi il programma non dovrebbe vedere). Come faccio? ho già passato 2 giornate a configurarla! PS: l'errore non è dato da Visual Studio, bensì da "sanitycheck.h".
×
×
  • Crea Nuovo...

Informazioni importanti

Abbiamo inserito dei cookies nel tuo dispositivo per aiutarti a migliorare la tua esperienza su questo sito. Puoi modificare le impostazioni dei cookie, altrimenti puoi accettarli cliccando su continua.