Vai al contenuto
  • Benvenuto!

     

Temperatura estrusore sballata


Messaggi raccomandati

Premetto che, per non saper ne leggere ne scrivere, ho cambiato il gruppo estrusore completo  e non contento ho cambiato scheda madre.

Il problema è il seguente: Lancio una stampa che deve andare a 225° l'estrusore va in temperatura poi parte la stampa. Dopo poco da display vedo la temperatura variare da 180° a 240° decisamente un po troppo. Precedentemente mi ero letto un post di @FoNzY e quindi ho fatto il pid autotuning quindi ho salvato con i valori nuovi usando M500 (forse non funziona e non capendo un tubo di firmware ho trascritto i valori nello start gcode come consigliato). Purtroppo anche con questa soluzione la temperatura dell'estrusore oscilla in maniera oscena.

Purtroppo non so più che pesci pigliare...spero in un consiglio da chi ne sa più di me.

Grazie

Link al commento
Condividi su altri siti

11 minuti fa, gregorio56sm ha scritto:

Premetto che, per non saper ne leggere ne scrivere, ho cambiato il gruppo estrusore completo  e non contento ho cambiato scheda madre.

Il problema è il seguente: Lancio una stampa che deve andare a 225° l'estrusore va in temperatura poi parte la stampa. Dopo poco da display vedo la temperatura variare da 180° a 240° decisamente un po troppo. Precedentemente mi ero letto un post di @FoNzY e quindi ho fatto il pid autotuning quindi ho salvato con i valori nuovi usando M500 (forse non funziona e non capendo un tubo di firmware ho trascritto i valori nello start gcode come consigliato). Purtroppo anche con questa soluzione la temperatura dell'estrusore oscilla in maniera oscena.

Purtroppo non so più che pesci pigliare...spero in un consiglio da chi ne sa più di me.

Grazie

A me Marlin 2.0.7.2 mi ha sempre fatto sempre un PID autotune sballato e mi ha sempre fornito valori di Kp troppo bassi per cui, durante la stampa, sembrava che la cartuccia non ce la faceva a riscaldare, appena partiva la ventola del modello la temperatura si abbassava anche di 10 gradi.

Sono passato appositamente a Marlin 2.0.9.1 ed ora il PID autotune me lo fa correttamente.

Link al commento
Condividi su altri siti

15 minutes ago, gregorio56sm said:

Premetto che, per non saper ne leggere ne scrivere, ho cambiato il gruppo estrusore completo  e non contento ho cambiato scheda madre.

..... ma queste operazioni le hai fatte a seguito del problema o dopo averle fatte hai avuto il problema?

  • Like 1
Link al commento
Condividi su altri siti

49 minuti fa, muffo ha scritto:

Io su una vecchia prusa avevo lo stesso problema, l' ho risolto mettendo della pasta termica nella sede della cartuccia.

vero hai risolto il problema ma per esperienza abbastanza diretta (è successo ad un mio amico) te ne sei creato un altro di problema, spera di non dover mai cambiare la cartuccia perché la pasta termica cementifica a quelle temperature ed il mio amico, che ha fatto come te, ha buttato cartuccia e blocchetto di alluminio che erano diventati un tutt'uno.

io con marlin 2.0.7.2 ho fatto il pid su un paio di stampanti e problemi non me ne ha dati, piuttosto controlla bene che il termistore resti nella sua sede ben fissato.

  • Like 3
Link al commento
Condividi su altri siti

14 ore fa, gregorio56sm ha scritto:

Premetto che, per non saper ne leggere ne scrivere, ho cambiato il gruppo estrusore completo  e non contento ho cambiato scheda madre.

Il problema è il seguente: Lancio una stampa che deve andare a 225° l'estrusore va in temperatura poi parte la stampa. Dopo poco da display vedo la temperatura variare da 180° a 240° decisamente un po troppo. Precedentemente mi ero letto un post di @FoNzY e quindi ho fatto il pid autotuning quindi ho salvato con i valori nuovi usando M500 (forse non funziona e non capendo un tubo di firmware ho trascritto i valori nello start gcode come consigliato). Purtroppo anche con questa soluzione la temperatura dell'estrusore oscilla in maniera oscena.

Purtroppo non so più che pesci pigliare...spero in un consiglio da chi ne sa più di me.

Grazie

Faccio una domanda stupida, però non si sa mai. Prima del comando M500 hai utilizzato il comando M301 per settare i nuovi valori? Se invii il solo comando M301 (senza parametri) la stampante ti restituiscei valori che hai impostato tu?

Link al commento
Condividi su altri siti

2 ore fa, Salvogi ha scritto:

Faccio una domanda stupida, però non si sa mai. Prima del comando M500 hai utilizzato il comando M301 per settare i nuovi valori? Se invii il solo comando M301 (senza parametri) la stampante ti restituiscei valori che hai impostato tu?

Barbatrucco:
M303 C10 S210 E0 U1

Con U1 finale già te li setta a memoria. Basta un M500 dopo.

@gregorio56smpotrebbe essere, come ti ha già detto Fonzy, un problema di sensore. Puoi copia-incollare qui il risultato di un M503 della tua stampante, dopo averla accesa? I PID corrispondono a quelli che hai impostato tu? Hai acceso la ventola e dato 10 cicli quando hai fatto l'M303?
Altra cosa, puoi linkare il ricambio acquistato e dirci quale è la marca della tua stampante?

 

  • Like 2
Link al commento
Condividi su altri siti

5 ore fa, invernomuto ha scritto:

Barbatrucco:

Ringrazio per il barbatrucco.

La stampante e la Geeetech A10

Quando ho fatto m303 la ventola era accesa e ho fatto 8 cicli

La scheda che ho cambiato l'avevo in casa da 2 anni comunque è la GT2560_V3.0

Estrusore

https://www.amazon.it/Geeetech-Estrusore-Hotend-stampante-A10/dp/B07XT8FGV2/ref=sr_1_4?__mk_it_IT=ÅMÅŽÕÑ&dchild=1&keywords=estrusore+geeetech+A10&qid=1626963036&sr=8-4

Comunque tutti e due i ricambi me li aveva dati direttamente la Geeetech

La prova del M503 la farò domenica adesso sono preso con il lavoro

domanda

quale è la stringa giusta

M303 C10 S210 E0 U1

M500

OPPURE

M303 C10 S210 E0 U1 M500

Grazie sempre

 

 

Link al commento
Condividi su altri siti

3 ore fa, gregorio56sm ha scritto:

quale è la stringa giusta

M303 C10 S210 E0 U1

M500

Avvii la ventola con M106 + INVIO

Dai M303 C10 S210 E0 U1  + INVIO per far partire il PID autotune

M503 + INVIO per verificare che ti abbia effettivamente memorizzato i PID

M500 + INVIO per salvare

 

  • Like 1
  • Thanks 1
Link al commento
Condividi su altri siti

Per adesso tutte le stampe che devo fare le ho passate sulla Tronxy.

I lavori di prova, riparazione, e ripristino della A10 sono rimandati alle ferie.

Mi correggo, i lavori sono rimandati alla pensione (01/08/2021) non mi sembra vero ma sono passati 45 anni in un soffio.

 

  • Like 3
Link al commento
Condividi su altri siti

4 minuti fa, gregorio56sm ha scritto:

Per adesso tutte le stampe che devo fare le ho passate sulla Tronxy.

I lavori di prova, riparazione, e ripristino della A10 sono rimandati alle ferie.

Mi correggo, i lavori sono rimandati alla pensione (01/08/2021) non mi sembra vero ma sono passati 45 anni in un soffio.

 

Complimenti e Beato te!!!!! A me  qualche anno fa è arrivata la famigerata busta arancione dell ' INPS e mi pare di aver letto 2047......non ricordo bene perché subito dopo a forza di tirare testate sul muro ho perso i sensi.

  • Confused 1
  • Sad 2
Link al commento
Condividi su altri siti

1 minuto fa, muffo ha scritto:

Complimenti e Beato te

E' arrivata, forse troppo in fretta...

Sono ancora confuso e sembra quasi che mi manchi il terreno sotto ai piedi.

Boh!!!!!! Non pensavo mi facesse questo effetto... passerà

Dai... magari 2027, in questo caso 6 anni volano😁

Link al commento
Condividi su altri siti

3 minuti fa, gregorio56sm ha scritto:

E' arrivata, forse troppo in fretta...

Sono ancora confuso e sembra quasi che mi manchi il terreno sotto ai piedi.

Boh!!!!!! Non pensavo mi facesse questo effetto... passerà

Secondo me a breve arriverà @eaman a consigliarti di costruirti una voron durante la pensione....

  • Haha 5
Link al commento
Condividi su altri siti

Il 22/7/2021 at 10:49, invernomuto ha scritto:

risultato di un M503 della tua stampante,

15:17:13.419 : echo:  G21    ; Units in mm
15:17:13.420 : echo:  M149 C ; Units in Celsius
15:17:13.421 : echo:Filament settings: Disabled
15:17:13.423 : echo:  M200 D1.75
15:17:13.423 : echo:  M200 D0
15:17:13.424 : echo:Steps per unit:
15:17:13.426 : echo:  M92 X80.30 Y80.80 Z400.00 E400.00
15:17:13.427 : echo:Maximum feedrates (units/s):
15:17:13.430 : echo:  M203 X400.00 Y400.00 Z400.00 E45.00
15:17:13.431 : echo:Maximum Acceleration (units/s2):
15:17:13.432 : echo:  M201 X5000 Y5000 Z50 E5000
15:17:13.436 : echo:Acceleration (units/s2): P<print_accel> R<retract_accel> T<travel_accel>
15:17:13.438 : echo:  M204 P1000.00 R2000.00 T1000.00
15:17:13.442 : echo:Advanced: S<min_feedrate> T<min_travel_feedrate> B<min_segment_time_us> X<max_xy_jerk> Z<max_z_jerk> E<max_e_jerk>
15:17:13.445 : echo:  M205 S0.00 T0.00 B20000 X20.00 Y20.00 Z0.40 E5.00
15:17:13.446 : echo:Material heatup parameters:
15:17:13.447 : echo:  M145 S0 H190 B60 F0
15:17:13.448 : echo:  M145 S1 H240 B90 F0
15:17:13.450 : echo:PID settings:
15:17:13.451 : echo:  M301 P26.44 I2.65 D66.05
15:17:13.453 : echo:  M304 P182.46 I35.92 D231.70
 @invernomutoDopo avere rifatto il pid secondo le tue indicazioni i valori risultano memorizzati corretti e questo è già un passo avanti.

Adesso faccio una piccola prova tanto per vedere come si comporta la stampante

  • Like 1
Link al commento
Condividi su altri siti

@invernomuto  Ho lanciato una piccola stampa da repetier (15 minuti) in modo da poter seguire il grafico della temperatura sia dell'estrusore che del piatto.

Tutti e due nell'arco dei 15 minuti hanno avuto una oscillazione di 1° cosa che reputo più che ottima.

Praticamente i grafici erano delle linee rette.

Conclusione:

Quando ho fatto il primo pid ho fatto un pasticcio e non ho memorizzato niente (sono un pirla)

Quando ho fatto il secondo pid ho fatto altro pasticcio (doppio pirla)

Morale... altro che pensione devo cercarmi un posto al ricovero per poveri stampatori.

Comunque adesso lancio una stampa seria e vedo che succede, spero e mi auguro che tutto fili liscio come l'olio.

Sempre grazie a tutti

  • Haha 4
Link al commento
Condividi su altri siti

Il 25/7/2021 at 16:16, gregorio56sm ha scritto:

Praticamente i grafici erano delle linee rette.

Ottimo. Se puoi montarli, consiglio quei rivestimenti in silicone per l'hotend, costano poco e vanno benissimo, la temperatura non oscilla più neppure di un decimo di grado. Nel tuo caso però da quello che dici non ne hai bisogno.
Bene così.

  • Thanks 1
Link al commento
Condividi su altri siti

15 minuti fa, gregorio56sm ha scritto:

@invernomuto A questo punto faccio lo sfacciato... come si fa il pid del piatto 

Grazie sempre

M303 C10 S60 E-1 U1

10 cicli, temperatura piatto 60°. Ovviamente metti la temperatura a te più congeniale modificando quell' S60 con la temperatura che vuoi. 
Verifichi poi che i PID che ti ha mostrato a video siano stati memorizzati con M503 e salvi con M500, come per il PID autotune per l'estrusore.

Ciao

  • Like 2
  • Thanks 1
Link al commento
Condividi su altri siti

44 minuti fa, gregorio56sm ha scritto:

@invernomuto A questo punto faccio lo sfacciato... come si fa il pid del piatto 

Grazie sempre

 

25 minuti fa, invernomuto ha scritto:

M303 C10 S60 E-1 U1

10 cicli, temperatura piatto 60°. Ovviamente metti la temperatura a te più congeniale modificando quell' S60 con la temperatura che vuoi. 
Verifichi poi che i PID che ti ha mostrato a video siano stati memorizzati con M503 e salvi con M500, come per il PID autotune per l'estrusore.

Ciao

Giusto quanto scritto da @invernomuto ma occorre che nel firmware sia abilitato #define PIDTEMPBED

Comunque per il piatto è meno importante il controllo PID quindi, se dovesse essere disabilitato, non è un grosso problema.

 

  • Like 1
Link al commento
Condividi su altri siti

Partecipa alla conversazione

Puoi pubblicare ora e registrarti più tardi. Se hai un account, accedi ora per pubblicarlo con il tuo account.

Ospite
Rispondi a questa discussione...

×   Hai incollato il contenuto con la formattazione.   Rimuovere la formattazione

  Sono consentiti solo 75 emoticon max.

×   Il tuo collegamento è stato incorporato automaticamente.   Mostra come un collegamento

×   Il tuo contenuto precedente è stato ripristinato.   Pulisci editor

×   You cannot paste images directly. Upload or insert images from URL.

 Condividi


×
×
  • Crea Nuovo...