Jump to content

Marlin 2.0.9 e homing con bltouch


Recommended Posts

Salve a tutti ho compilato il Marlin 2.0.9 per la mia Biqu B1 con Bltouch, facendo questi passaggi:

Ho scaricato il Marlin 2.0.9 e ho scaricato i config preparati per la versione 2.0.9, ho copiato i 2 file configuration nella cartella marlin sostituendo i 2 già esistenti.

Avendo il bltouch e volendolo usare come endstop ho decommentato dentro  il file configuration.h le linee:

- USE_PROBE_FOR_Z_HOMING

- Z_SAFE_HOMING

Successivamente ho compilato il tutto con Visual Studio Code, ottenendo il file firmware.bin da caricare

cariato il tutto e controllato che gli assi si muovono nella direzione giusta, ho effettuato l'homing.

Asse x e assa y hamnno eseguito l'homing la Z ha estratto il pistoncino del bltouc e si è preparata per fare l'homing, ma lo ha eseguito non al cento del piatto, o meglio considerando che il piatto è da 23,5cm x 23,5cm ha eseguito l'homing su x 9cm e y 13.

quì mi sono fermato non andando avanti con le operazioni di ABL.

La mia domanda è come posso correggere questo errore e dove lo devo correggere?

Grazie

Link to comment
Share on other sites

  • Replies 2
  • Created
  • Last Reply

Top Posters In This Topic

Popular Days

Top Posters In This Topic

Ciao, non mi e' chiara una cosa nella tua spiegazione. Se X e Y hanno fatto homing, il nozzle non e' gia' posizionato al centro del piatto? Hai inoltre verificato che le dimensioni del piatto siano correttamente configurate

Link to comment
Share on other sites

2 ore fa, dnasini ha scritto:

Ciao, non mi e' chiara una cosa nella tua spiegazione. Se X e Y hanno fatto homing, il nozzle non e' gia' posizionato al centro del piatto? Hai inoltre verificato che le dimensioni del piatto siano correttamente configurate

mi sono spiegato male x e y hanno fatto scattare gli endstop meccanici e poi si sono posizionati non al centro del piatto per fare homing dell'asse z.

Si le dimensioni del piatto sono giuste, l'errore potrebbe essere lo Z-probe?

Leggendo la eeprom mi da risposta:

M851 X12.00 Y-43.00 Z-1.50

I valori potrebbero essere questi sbagliati?  Perchè in realtà per come è montato il mio bltouch X dovrebbe essere 0 dato che è perfettamente allineato al nozzle e non è spostato ne a desta o a sinistra.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share


×
×
  • Create New...