Vai al contenuto
  • Benvenuto!

     

interferenze e problemi con octoprint su ender 5


Messaggi raccomandati

ciao, 

 

oggi ne ho scoperta un'altra..... 

stavo stampando da octoprint ed aziono la serranda elettrica ,    octoprint si disconnette..... ottimo. finalmente ho riscontrato cosa puo' interrompere la connessione USB tra la mainboard  creality e orangepi....

 

e pensare che oggi avevo anche cambiato il cavo USB.

 

alla fine cambiando presa con una prolunga ho capito che la stampante ne risente quando aziono la serranda ed e' utilizzata la presa piu' vicina alla serranda.  

Ieri anche sul linux  dmesg della board orangepi avevo captato ieri un indizio, oggi idem:

 

usb usb6-port1: disabled by hub (EMI?), re-enabling...
usb 6-1: USB disconnect, device number 7
ch341-uart ttyUSB0: ch341-uart converter now disconnected from ttyUSB0
ch341 6-1:1.0: device disconnected

 

spostando l'alimentatore della board orangepi e lasciando la stampante collegata alla solita presa ho lo stesso problema di interferenze.

ci tengo a sottolineare che prese di forza e tapparelle sono su due linee differenti che pero' partono dallo stesso quadro.

 

ora volevo chiedervi sono l'unico ad aver notato problemi del genere ? 

 

avete messo qualche filtro di rete  o UPS ?

 

pensando ai mesi scorsi, un giorno ho stampato per una decina di ore e tutto filava liscio. Poi errore di disconnessione, ora che ci penso era sera e di sicuro avro' tirato giu' serranda.

 

ciao

Link di questo messaggio
Condividi su altri siti
  • Risposte 15
  • Creato
  • Ultima Risposta

Miglior contributo in questa discussione

Miglior contributo in questa discussione

Messaggi Popolari

ciao,    ieri ho trovato un'ora di tempo ed ho installato una DC-DC  converter LM2596 per alimentare direttamente l'orangepi.   sembra che il problema si sparito, almeno tirando su

io ieri durante il test di assorbimento non avevo periferiche ma ho lanciato un un ciclo in loop per caricare la CPU, i effetti dovevo lanciarne 4, uno per core. comunque l'orangepi e' dedicato q

lol io ho un sintetizzatore con tastiera capacitiva (microfreak) e per riuscire a suonarlo nella stanza dei computers lo devo mettere a terra con la mia panza! Tipo bracciale anti statica 😛

1 ora fa, soldato ha scritto:

stavo stampando da octoprint ed aziono la serranda elettrica ,    octoprint si disconnette.....

Ma si resetta la scheda della stampante o la orangePi?

Sono entrambe collegate alla stessa presa?

Link di questo messaggio
Condividi su altri siti
10 ore fa, eaman ha scritto:

Ma si resetta la scheda della stampante o la orangePi?

Sono entrambe collegate alla stessa presa?

dal log dmesg di orangepi sembra che l'interferenza causi il down della porta USB per le interferenze (EMI).  passata l'interferenza l'USB rivede la stampante che a sua volta si resetta. cosa che fa sempre alla connessione e che @KillRob dice essere normale ad ogni connessione.

 

diciamo che ora  vorrei lavorare per filtrare ed  eliminare quest'interferenza dovuta ai motori 220v.

poi mi piacerebbe evitare il riavvio della stessa quando fai connect da octoprint ma se la board e' fatta cosi' non credo di avere alternative se non cambiare la board.

 

 

Link di questo messaggio
Condividi su altri siti
2 ore fa, soldato ha scritto:

dal log dmesg di orangepi sembra che l'interferenza causi il down della porta USB per le interferenze (EMI).

Sicuro che sia "interferenza su USB"? Non e' che la scheda della stampante viene alimentata dalla orangepi e questa gia' e' tanto se sta su da sola, quindi va' giu' il power?

Se usi un cavo USB solo dati si resetta lo stesso? E' una cosa che fa per permettere l'upload del firmware?

Magari prova con: https://www.thingiverse.com/thing:3044586

Non so che scheda monti ma se e' una Atmel Atmega/ Arduino che si resetta a ogni connesione seriale magari si puo' inibire il reset: https://playground.arduino.cc/Main/DisablingAutoResetOnSerialConnection/

Link di questo messaggio
Condividi su altri siti
1 ora fa, eaman ha scritto:

Se usi un cavo USB solo dati si resetta lo stesso? 

fino a qualche giorno fa avevo isolato il +5v di un cavo usb e lo faceva lo stesso. ma non ho idea se venisse loggato dal kernel. rifaro' la prova piu' tardi.

1 ora fa, eaman ha scritto:

Non e' che la scheda della stampante viene alimentata dalla orangepi e questa gia' e' tanto se sta su da sola, quindi va' giu' il power?

ho gia' provato due alimentatori ed uno e' specifico per RPI 4 con ben 4A di corrente. 

 

la cosa interessante comunque e' che sul /var/log/messages non viene riportato questo errore di interferenze EMI mentre sul dmesg  l'errore c'e' ed e' per questo che non me ne sono accorto prima. e  anche altri non se ne sono accorti....

 

sempre legato a questo tema ieri sera ho trovato un thread su plcforum du disturbi al Pc e monitor qquando avviano una lavatrice....

   

Link di questo messaggio
Condividi su altri siti

Dho, se vuoi fare una prova prima di comprare un UPS attivo e stabilizzato: prova a far pilotare la scheda da octoprint che gira su un portatile alimentato a batteria, per quanto immagino che la stampante abbia comunque un ground condiviso con la rete e quindi con quella presa di corrente.

Non hai poi detto se hai orange + stampante collegate alla stessa presa di corrente, in caso contrario potresti avere un ground loop che  un po' di rumore potrebbe farlo di suo.

Certo che la orange ciuccia un bel po', vorrei montarne una anche io ma mi sarebbe piaciuto alimentarla dall'alimentatore della stampante, bisognera' vedere se uno step down solito riesce a tenerla su'...

Link di questo messaggio
Condividi su altri siti
6 ore fa, eaman ha scritto:

Non hai poi detto se hai orange + stampante collegate alla stessa presa di corrente, in caso contrario potresti avere un ground loop che  un po' di rumore potrebbe farlo di suo.

 

Fino a ieri stampante e alimentatore orangepi erano sulla stessa ciabatta. Durante le prove di ieri sera li avevo separati e con una prolunga ho provato a lasciare un dispositivo alla volta alla presa a muro e l'altro  ben distante. 

Lasciando la stampante alla presa vicino alla serranda la segnalazione sul log è sistematica.

 

Io ho preso uno step down 24 5v 5A devo solo trovare il tempo di montarlo. 

 

Vorrei solo andare per step in modo da capire meglio l'origine del problema e la soluzione.

Domani se ho tempo mi armo di oscilloscopio e guardo le varie tensioni dalla rete al +5v anche non è facile vedere gli Spike almeno con la mia attrezzatura.

 

Ciao

Link di questo messaggio
Condividi su altri siti

Io prima di inventare soluzioni, cercherei bene la causa.

Prima di tutto verificherei se il problema si manifesta quando la serranda del garage parte, oppure si ferma.

Verificato questo, poi si passa a controllare il motore e parte elettrica della serranda.

La soluzione di cui discutete è una delle ultime da prendere in considerazione e comunque va prima trovata la causa.

Potrebbe essere un problema della serranda del garage, oppure potrebbe essere anche l'impianto elettrico dell'abitazione dimensionato male.

è come dire che sono sul titanic, becco l'iceberg e tiro fuori il secchio per gettare via l'acqua che entra anzichè riparare le falle, o correre alle scialuppe.... 😅

In generale,se il problema lo fa quando la serranda parte, è perchè il motore ciuccia troppa corrente. Li è da vedere l'assorbimento di targa del motore, misurare quello reale, verificare che la linea di alimentazione sia dimensionata correttamente ecc.

Se invece te lo fa quando la serranda si ferma, allora sono disturbi introdotti dal motore, dal relè che lo comanda e dalla sua elettronica in generale.

Link di questo messaggio
Condividi su altri siti

Aggiungo un paio di informazioni,

La stampante nell'ultimo mese a causa DAD l'ho spostata da una stanza all'altra e ha manifestato lo stesso problema in entrambe le stanze ed è praticamente sempre vicina ad una finestra sempre dotata di tapparella elettrica.

Credo che la la causa non sia proprio delle tapparelle elettriche anche perché oggi ho rilevato tre errori sul log dmesg del Orangepi e sono assolutamente certo che le tapparelle fossero ferme. 

La questione tapparelle è venuta fuori perché mi sono trovato davanti alla stampante nel mentre  azionavo il motore e questa anomalia in questo caso aiuta perché è facile riprodurre il problema azionando il motore della tapparella.

 

A mio avviso anche il numero di thread sul forum octoprint riguardo le disconnessioni o per l'alimentatore scarso o il cavo USB non schermato ecc ecc, rivela il fatto che ci sia un qualcosa che va approfondito.

Del resto se la board rileva un'interferenza EMI e  l'usb si disconnette qualcosa ci sarà.

Un'altra cosa che mi viene in mente è che la board è in un box di plastica senza schermature.

Domani farò ancora una cosa, tiro giù il magnetotermico delle tapparelle disalimentandole del tutto.

Il prossimo step potrebbe essere di spostarla in un ambiente completamente diverso e con impianto elettrico ed utilizzatori differenti.

Ciao

 

Link di questo messaggio
Condividi su altri siti

questa mattina ho effettuato due prove:

1) ho collegato all'usb dell'orangepi una chiavetta USB

2) ho collegato al "solito" cavo usb una GOPRO 

 

in entrambi i casi non ho rilevato nessuna disconnessione USB e messaggi relativi alle interferenze (EMI) azionando la tapparella.

collegata la stampante..... sono ritornati gli errori  sul log (EMI).

ora mi documento sulla questione ground-loop come suggerito da @eaman

ieri sera ho trovato un thread  riguardo un problema di EMI che si verificava quando si azionava una tapparella elettrica ed al passaggio di motociclette nelle vicinanze (dovuto alla bobina d'accensione che emette disturbi creando un loop/antenna tra bobina e cavi candele).  https://electronics.stackexchange.com/questions/31417/how-can-i-improve-usb-emi-insensitivity.

ciao e grazie

Link di questo messaggio
Condividi su altri siti

Bho, se e' un problema di tensione puoi provare a mettere tra la orange e il microcontrollore un hub usb alimentato.

Io alimenterei direttamente la orange con l'alimentatore della stampante se hai gia' lo step down, almeno ti cavi di torno un elemento.

Link di questo messaggio
Condividi su altri siti
Il 3/4/2021 at 15:28, eaman ha scritto:

Bho, se e' un problema di tensione puoi provare a mettere tra la orange e il microcontrollore un hub usb alimentato.

Io alimenterei direttamente la orange con l'alimentatore della stampante se hai gia' lo step down, almeno ti cavi di torno un elemento.

ciao, 

 

ieri ho trovato un'ora di tempo ed ho installato una DC-DC  converter LM2596 per alimentare direttamente l'orangepi.

 

sembra che il problema si sparito, almeno tirando su e giu' le tapparelle.  per ora va alla grande, non si disconnette piu' e non logga errori di interferenze.

 

per la cronaca l'orange pi assorbe al massimo 500mA col wifi acceso, misurato da me nella mia configurazione quindi abbondamente sotto il mio DC-DC converter LM2596  che eroga 2A con un massimo di 3A.

 

a questo punto credo che questa modifica sia un must se si vogliono collegare board esterne.

 

grazie a @eaman per la dritta sul ground-loop. per chi vuiole approfondire consiglio questo link semplice e ben spiegato  https://www.ligra.it/media/cose-ground-loop-loop-massa/

 

CIAO 

  • Like 1
Link di questo messaggio
Condividi su altri siti

Buon per te e anche per me che usero' pure io uno step down.

1 ora fa, soldato ha scritto:

per la cronaca l'orange pi assorbe al massimo 500mA col wifi acceso, misurato da me nella mia configurazione quindi abbondamente sotto il mio DC-DC converter LM2596  che eroga 2A con un massimo di 3A.

Io ho una Orange PC e con l'alimentazione e' un po' stronza... Si rischia di dover spendere di piu' per un alimentatore che per 'ste schede! Conta che quegli affari possono avere dei power throttle abbastanza importanti quindi  vanno testati anche sotto sforzo computazionale, poi bisogna cercare di evitare di usarli come alimentatori per le periferiche USB.

Link di questo messaggio
Condividi su altri siti
6 ore fa, eaman ha scritto:

Buon per te e anche per me che usero' pure io uno step down.

Io ho una Orange PC e con l'alimentazione e' un po' stronza... Si rischia di dover spendere di piu' per un alimentatore che per 'ste schede! Conta che quegli affari possono avere dei power throttle abbastanza importanti quindi  vanno testati anche sotto sforzo computazionale, poi bisogna cercare di evitare di usarli come alimentatori per le periferiche USB.

io ieri durante il test di assorbimento non avevo periferiche ma ho lanciato un un ciclo in loop per caricare la CPU, i effetti dovevo lanciarne 4, uno per core.

comunque l'orangepi e' dedicato quindi non dovrei avere sorprese.  oggi 2 stampe senza problemi. 

ciao

  • Like 1
Link di questo messaggio
Condividi su altri siti
20 ore fa, soldato ha scritto:

sembra che il problema si sparito, almeno tirando su e giu' le tapparelle.  per ora va alla grande, non si disconnette piu' e non logga errori di interferenze.

chissà forse mi avete spiegato perchè mi si fermava la stampante quando accendevo la luce della camera...

Link di questo messaggio
Condividi su altri siti

lol io ho un sintetizzatore con tastiera capacitiva (microfreak) e per riuscire a suonarlo nella stanza dei computers lo devo mettere a terra con la mia panza!

Tipo bracciale anti statica 😛

  • Haha 1
Link di questo messaggio
Condividi su altri siti

Partecipa alla conversazione

Puoi pubblicare ora e registrarti più tardi. Se hai un account, accedi ora per pubblicarlo con il tuo account.

Ospite
Rispondi a questa discussione...

×   Hai incollato il contenuto con la formattazione.   Rimuovere la formattazione

  Sono consentiti solo 75 emoticon max.

×   Il tuo collegamento è stato incorporato automaticamente.   Mostra come un collegamento

×   Il tuo contenuto precedente è stato ripristinato.   Pulisci editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Crea Nuovo...