Vai al contenuto
  • Iscriviti al forum

    Iscriviti al forum per usufruire di tutti i contenuti: la registrazione è gratuita!

Carlo50

tre ventole indipendenti

Recommended Posts

Serramazzoni Modena 14/12/2019

In attesa della fysetc F6, sto lavorando alla 3darag modificata con tre estrusori.

Ho separati i tre comandi delle ventole fan, fan1 e fan2 collegandoli ai pin 49, 47, 44 che sono identici alla Fysetc F6, ma non riesco ad accenderne piu' di una ed oltretutto repetier me ne consente solo 2.

Ho inserito un po' ovunque #define FANS 3 ma non viene considerato, anche se compilato regolarmente da arduino.

Cosa sto tralasciando?

Carlo Montecchi

 

 

Condividi questo messaggio


Link di questo messaggio
Condividi su altri siti

Non serve inserire nulla un po' ovunque, rischi solo di aver problemi di compilazione. 

Io ho 4 ventole attaccate e lavorano senza problemi. 

Che comandi dai in gcode per utilizzare le ventole? 

Ti consiglio di andare sul sito di marlin e li trovi tutti i comandi utilizzati e relativa spiegazione 

Condividi questo messaggio


Link di questo messaggio
Condividi su altri siti

Ho trovato in giro un set di istruzioni per definire a piacere il numero delle ventole e che allego in formato txt. ma una volta eliminati tutti gli errori generati e compilato-caricato, le ventole visualizzate a destra restano sempre massimo 2.

Il comando  M106 P0,1,2 effettivamente funziona, quindi mi considero soddisfatto, grazie.

Carlo

Marlin 2.0 3 FAN.txt

Condividi questo messaggio


Link di questo messaggio
Condividi su altri siti

Effettivamente anche con il Marlin per due fan, se ne possono accendere anche 3, vorrei avere anche sul monitor la possibilita' di accenderle, regolarne l'intensita' e spegnerle senza lanciare il comando M106P...

Grazie Carlo

Condividi questo messaggio


Link di questo messaggio
Condividi su altri siti

Quando riesco a cavare il ragno dal buco, faccio sapere a tutti come si fa.

Intanto ho installata la fysets f6 e funziona quasi tutto.

Ho problemi con i fine corsa:

1) a cosa servono i ponticelli +- X +- Y +- Z

2) occorrono normalmente apoerti o normalmente chiusi

3) collegati ad S e + oppure -

Carlo

Condividi questo messaggio


Link di questo messaggio
Condividi su altri siti

Ho scaricato un poco di documentazione e credo di aver trovato il modo di collegare i fine corsa.

Ma non si muove nessun motore, quindi non posso testarli.

Allego una foto con scritte a bordo.

Cerca di spiegarmi la faccenda, cosi' faccio pace con le stampanti 3D.

Grazie Carlo

Scheda superiore con ponticelli.bmp

Condividi questo messaggio


Link di questo messaggio
Condividi su altri siti

Che driver monti innanzitutto? Se tipo tmc, configurati come? Quei ponticelli tipo XYZ sono relativi ai driver. Se non usi tmc devi lasciarli aperti, sennò dipende. 

Poi per gli endstop, dipende dalla logica dell'interruttore, s sicuramente. 

Il fw che ti ho dato aveva una base, poi devi addattarli alla tua macchina. Io non posso sapere se i tuoi endstop sono collegati normalmente aperti o chiusi.

Io per esempio, contrariamente alla maggior parte li uso invertiti. 

 

Condividi questo messaggio


Link di questo messaggio
Condividi su altri siti

i driver sono drv 8825 ed i fine corsa sono nc con -.

Ho anche cambiato da true a false in config.h, ma il problema principale e' che non mi si muovono i motorini passo-passo.

Ho visto uno schema che ho seguito alla lettera, ma non vanno.

Le alimentazioni dovrebbero esserci, dato che gli estrusori ed il piano funzionano perfettamente.

Carlo

FYSETC F6_Istruzioni sommarie.pdf

Condividi questo messaggio


Link di questo messaggio
Condividi su altri siti

Se fai m119 dovresti vedere lo stato degli endstop, in modo anche che puoi provarli. 

Se sono nc lo devi collegare tra + e S. 

In teoria se sono loro a darti problemi, gli assi vanno solo in un senso. 

Ma i motori sono morti, sono bloccati ma in coppia(cioè alimentati), ronzano...? 

Condividi questo messaggio


Link di questo messaggio
Condividi su altri siti

I motori non si muovono e sono liberi, cioe' si spostano manualmente senza problemi, quindi non viene attivato neppure EN.

I ponticelli sotto i driver penso di averli poisizionati bene, ma non trovo istruzioni riguardo quelli sul lato corto che sono 4x2 e 3x1.

Riguardo i fine corsa, solo che riesca a far muovere qualcosa, posso risolvere, ma prima debbo veder spostare qualche motore.

Grazie

Portato su repetier e configuration.h il baud a 250000

portato sempre su configuration.h CS di tutti i driver a -1

Saldati assieme nei driver SLP e RST (come erano quelli di futura)

Non risolto nulla attendo notizie.

Carlo

Condividi questo messaggio


Link di questo messaggio
Condividi su altri siti

Scusatemi, ma ho imparato troppo tardi che il problema si trovava nei capicorda molto delicati e minuscoli.

Avevo acquistata una pinza crimpatrice che, quando ho visto i capicorda, ho capito essere troppo grossa.

Ho quindi deciso di saldare i fili, ma subentrano problemi di inserimento e relativo contatto.

Sto vedendo qualche movimento, per cui cambiero' appena possibile la pinza e dovrei risolvere i problemi.

Scusatemi ancora.

Carlo

Condividi questo messaggio


Link di questo messaggio
Condividi su altri siti

Serramazzoni Modena 16/01/2020

Ho cambiato la pinza ed ora funziona bene, ma ho un problema con gli assi X ed Y.

Si muovono sincronizzati come se il funzionamento fosse quello inventato da Tronxy, mentre io ho separati i comandi e vorrei con X comandare soltanto il motore X, mentre con Y solamente Y.

Sai suggerirmni la modifica su Marlin?

Carlo Montecchi

Condividi questo messaggio


Link di questo messaggio
Condividi su altri siti

Devi verificare il tipo di cinematica all'inizio del file configuration. Non vorrei che ti ho lasciato l'opzione corexy abilitata. Tu hai una cartesiana per cui non devi abilitare nessun modello di cinematica 

Condividi questo messaggio


Link di questo messaggio
Condividi su altri siti

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Ospite
Rispondi a questa discussione...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Caricamento...



×
×
  • Crea Nuovo...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.