Vai al contenuto
  • Iscriviti al forum

    Iscriviti al forum per usufruire di tutti i contenuti: la registrazione è gratuita!

Davide87

Problema rumore Z hop dopo installazione SKR V1.3 con TMC 2208 su Ender 3 - Risolto

Recommended Posts

Ciao a tutti,

Vi scrivo perchè dopo aver aggiornato la mia Ender 3 con la mainboard SKR V1.3 con i TMC 2208 in modalità UART, ho potuto riscontrare numerosi miglioramenti, ma ho notato un problema quando lo Z hop è attivo.

In pratica durante la fase di Z hop, la stampante produce una coppia di schiocchi molto rumorosi, all'inizio e al termine dello Z hop stesso. Inoltre in un paio di occasioni, specialmente se lo Z hop veniva ripetuto per molte volte, è capitato che la stampante sembava perdere il riferimento dopo aver sollevato l'hot end ed abbassarsi eccessivamente toccando al passaggio successivo la superficie già stampata, rovinando tutto quello già stampato e rischiando di danneggiare anche la stampante stessa.

Quando sono andato a registrare il rumore per farvi capire di cosa trattava nel dettaglio, era però sparito :hushed:...

Infatti, per evitare possibili danni avevo smesso di utilizzare questa funzione, ma nel frattempo ho installato l'estensione creawsome su Cura e direi che con ogni probabilità ha variato dei parametri sul movimento dell'asse Z, che ha risolto perlomeno il problema del rumore, poi devo ancora verificare se perde ancora il riferimento durante una stampa lunga.

in tutta onestà non so quale parametro sia stato modificato dall'estensione per risolvere il problema, ma ho vistto che Creawsome imposta la velocità massima dell'asse Z uguale a 0 (così da utilizzare quella presente nel frimware 5mm/s), invece cura di base utilizza 1 mm/s, se non ricordo male.

Non so dire invece se sono cambiate accelerazione e jerk....

Carico per completezza di informazioni i miei file configuration e configuration adv..

 

Configuration.h Configuration_adv.h

Condividi questo messaggio


Link di questo messaggio
Condividi su altri siti

Hai decommentato #define HYBRID_THRESHOLD si attiva in z quando supera i 3mm/s ,come pensavo .Tu hai 5mm/s quindi si attiva praticamente ad ogni z hop .questa funzione in z non serve . Quando entra in funzione  la modalità ibrida te ne accorgi subito , perche la stampante diventa rumorosa.

puoi decommentarla solo per questo asse o mettere un acc, più alta in modo che non si attivi

le acc. sono tipiche della ender 3 vanno bene .In x e y hai un jerk 10  va bene, ma se in alternativa vuoi puoi utilizzare la junction deviation

Condividi questo messaggio


Link di questo messaggio
Condividi su altri siti

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Ospite
Rispondi a questa discussione...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Caricamento...



×
×
  • Crea Nuovo...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.