Vai al contenuto
  • Iscriviti al forum

    Iscriviti al forum per usufruire di tutti i contenuti: la registrazione è gratuita!

Guido

Problema stampa con i3 Pro C

Recommended Posts

Salve, ho da poco assemblato la stampante e cercato di settare al meglio il piatto.

Ho alcuni problemi:

1. La stampa parte a circa 2 millimetri dal piatto, cosi ho settato offset Z a -0.2 e forse ho risolto questo problema

2. quando l'estrusore si sposta in Z è come si il gap fosse troppo alto....ho provato a stampare un cubo 20x20 ma il risultato è una matassa di filamento molto alta. Guardando lo slicer invece, dovrebbe essere alto solo pochi millimetri.

Allego due foto:

 

 

Grazie

IMG_20181227_175234.jpg

IMG_20181227_175228.jpg

Condividi questo messaggio


Link di questo messaggio
Condividi su altri siti
3 ore fa, Guido dice:

1. La stampa parte a circa 2 millimetri dal piatto, cosi ho settato offset Z a -0.2 e forse ho risolto questo problema

se ci sono due millimetri come fa' ad andare a zero con un off-set di 2 decimi? qualcosa non torna....🤔

3 ore fa, Guido dice:

2. quando l'estrusore si sposta in Z è come si il gap fosse troppo alto....ho provato a stampare un cubo 20x20 ma il risultato è una matassa di filamento molto alta. Guardando lo slicer invece, dovrebbe essere alto solo pochi millimetri.

il primissimo layer come viene stampato? bene o male?

Condividi questo messaggio


Link di questo messaggio
Condividi su altri siti

Ciao grazie per le risposte.

53 minuti fa, FoNzY dice:

il primissimo layer come viene stampato? bene o male?

abbastanza male e non attaccato al piano.

Cercando su internet qualcosa ho risolto.

in pratica ho capito che la Pro C con le barre filettate (diciamo a spirare) e non le classiche M8 bisogna impostare il valore 400 anziché 2560.

Ho ricaricato il firmware e ho settato sia lingua italiana che a 400 il parametro.

Risultato ho migliorato la stampa ma ora l'asse Z sale e scende molto lentamente.

Stampando il solito cubo ho notato uno schiacciamento, ossia ad un certo punto l'asse Z si era come bloccato e stampava sempre sullo stesso livello.

Ho provato anche in manuale ed effettivamente l'asse Z era bloccato non salive ne scendeva....dopo vari tentativi è ripartito e ora sale e scende senza problemi....

Dove posso impostare e a che velocità il valore dell'asse Z?

 

p.s. filamento PLA 1.75

Condividi questo messaggio


Link di questo messaggio
Condividi su altri siti

Sta salendo e scendendo alla sua velocità corretta, prima era molto più veloce perchè i passi erano impostati male, (la stampante faceva girare il motore come se avesse barre normali e non trapezie col risultato che saliva 4 volte più veloce). quindi più veloce ma in condizioni di non stampare.

Se per assurdo la regolassi per andare più veloce perderebbe troppo in precisione sull'home z e non riusciresti a stampare decentemente il primo layer col risultato di non riuscire a stampare.

Condividi questo messaggio


Link di questo messaggio
Condividi su altri siti
8 ore fa, Alep dice:

Sta salendo e scendendo alla sua velocità corretta, prima era molto più veloce perchè i passi erano impostati male, (la stampante faceva girare il motore come se avesse barre normali e non trapezie col risultato che saliva 4 volte più veloce). quindi più veloce ma in condizioni di non stampare.

Se per assurdo la regolassi per andare più veloce perderebbe troppo in precisione sull'home z e non riusciresti a stampare decentemente il primo layer col risultato di non riuscire a stampare.

Quindi aver impostato il Vzmax a 400 anziché 2 è sbagliato?

la lentezza la noto anche quando non è in fase di stampa.

queste sono le impostazioni di default che ho caricato:

// default settings

#define DEFAULT_AXIS_STEPS_PER_UNIT   {78.74,78.74,400,95}  // MXL, Z M8=1.25, MK8
#define DEFAULT_MAX_FEEDRATE          {400, 400, 400, 45}    // (mm/sec)
#define DEFAULT_MAX_ACCELERATION      {5000,5000,50,5000}    // X, Y, Z, E maximum start speed for accelerated moves. E default values are good for Skeinforge 40+, for older versions raise them a lot.

ho modificato il  #define DEFAULT_MAX_FEEDRATE da {400, 400, 2, 45}  a  {400, 400, 400, 45} per velocizzare l'asse Z lasciando gli axis_steps_per_unit in modo da lavorare col le barre trapezie.

Condividi questo messaggio


Link di questo messaggio
Condividi su altri siti

La lentezza direi che la si vede solo in fase di spostamento non in stampa perchè l'elevazione durante la stampa è cosi minimale che dubito che ti accorga del tempo che ci mette. 

Come dice la parola stessa il DEFAULT_MAX_FEEDRATE non indica la velocità di spostamento ma la massima velocità di spostamento, diciamo che è un parametro di sicurezza, e per l'asse z questa viene limitata a livello di programma di stampa (ossia dipende dai gcode che il programma invia alla stampante), questo perchè il progettista del software cerca una via di mezzo tra la massima velocità di elevazione che si può raggiungere e la necessità che durante l'home il movimento sia lento per amplificare la risposta del sensore (sia che sia uno switch, un sensore di prossimità od un sistema touch), perchè più è lento il movimento è più precisa sarà la taratura di home Z. E ben sappiamo quanto è delicata e fondamentale la fase di home Z.

D'altronde gli spostamenti in Z sono cosi rari e minimali se paragonati alla durata di una stampa da non costituire un problema. 

In pratica molto probabilmente con la regolazione

 #define DEFAULT_MAX_FEEDRATE {400, 400, 400, 45} non hai effettuato nessuna modifica visibile, oltre che non hai riportato la velocità massima dell'asse z a quella degli altri assi ma la hai aumentato (ad occhio) di oltre 3 volte perchè la rotazione completa di un asse x o y implica un avanzamento di circa 3 cm, quella di Z circa 1 cm .

Condividi questo messaggio


Link di questo messaggio
Condividi su altri siti
2 ore fa, Alep dice:

La lentezza direi che la si vede solo in fase di spostamento non in stampa perchè l'elevazione durante la stampa è cosi minimale che dubito che ti accorga del tempo che ci mette. 

Come dice la parola stessa il DEFAULT_MAX_FEEDRATE non indica la velocità di spostamento ma la massima velocità di spostamento, diciamo che è un parametro di sicurezza, e per l'asse z questa viene limitata a livello di programma di stampa (ossia dipende dai gcode che il programma invia alla stampante), questo perchè il progettista del software cerca una via di mezzo tra la massima velocità di elevazione che si può raggiungere e la necessità che durante l'home il movimento sia lento per amplificare la risposta del sensore (sia che sia uno switch, un sensore di prossimità od un sistema touch), perchè più è lento il movimento è più precisa sarà la taratura di home Z. E ben sappiamo quanto è delicata e fondamentale la fase di home Z.

D'altronde gli spostamenti in Z sono cosi rari e minimali se paragonati alla durata di una stampa da non costituire un problema. 

In pratica molto probabilmente con la regolazione

 #define DEFAULT_MAX_FEEDRATE {400, 400, 400, 45} non hai effettuato nessuna modifica visibile, oltre che non hai riportato la velocità massima dell'asse z a quella degli altri assi ma la hai aumentato (ad occhio) di oltre 3 volte perchè la rotazione completa di un asse x o y implica un avanzamento di circa 3 cm, quella di Z circa 1 cm .

capito

io volevo aumentare solo la velocità del rientro in Home Z....

Quando l'asse Z sale o scende, avverto un rumore tipo strofinio tra ferro...ho provato a levigare i fori, allentare un pò le cinghie, usare spray lubrificante, ecc ma quando l'asse Z sale fa sempre questo rumore molto marcato.

 

Per la velocità massima di stampa sua i3 pro C quale mi consigliate?

 

Condividi questo messaggio


Link di questo messaggio
Condividi su altri siti
Il 28/12/2018 at 14:21, Alep dice:

Per la lubrificazione possibilmente utilizza vasellina tecnica. 

ok, provvedo.

anche se le barre sono ben lubrificare....non riesco a capire da dove proviene il rumore.

Una domanda, quando ho scelto la stampante ho valutato anche questa immagine in allegato, dove mostra la possibilità di stampare con il doppio estrusore un singolo oggetto, ma su Cura o Repetier-Host non trovo l'opzione...vorrei usare i due estrusori per velocizzare i tempi di stampa è possibile?

$_10.jpg

Condividi questo messaggio


Link di questo messaggio
Condividi su altri siti

Si, io ti so spiegare come fare su Repetier, (non uso cura da solo ma solo tramite Repetier), non so perchè ma questo della stampa a più colori è un argomento di cui si parla pochissimo e pur essendo semplice da mettere in atto è tutt'altro che intuitivo.

Non conoscendo le tue conoscenza su questo argomento porta pazienza ma parto da zero.

Per stampare a più colori occorre creare tanto oggetti quanti sono i colori che devi stampare costruiti in modo tale che non ci siano sovrapposizione di materiale ma che i diversi oggetti (nel tuo caso due) messi assieme formino un umico oggetto

Metto qui per chiarire meglio le idee i due piccoli oggetti che io uso per tarare i due estrusori tra di loro

Allineamento2Colori.png.73354e7bb7a65cf4a3072c2eb6a8dd01.png

AllnementoColore1.stl

AllnementoColore2.stl

dopo di che li carichi entrambi in Repetier e Repetier li caricherà come due oggetti separati, a questo punto prendi il secondo oggetto dalla lista che ti propone repetier sulla destra e lo trascini sulla riga del primo oggetto e lo rilasci e repetier magicamente li disporrà come un unico oggetto.

Se su repetier scegli due colori diversi per i due estrusori l'effetto visibile sarà ancora più evidente,

A questo punto lanci lo slicer e stampi.

Ti metto qui l'immagine di repetier con un altra stampa mia a due colori

Stampa2Colori2.thumb.png.ba9c6f4cb117b685227f89c1b6f70d6c.png

Stampa2Colori3.thumb.png.f5fb38334ca59fa17dc26dfa2ac957db.png

nota come l'oggetto blu ha lo scavo in corrispondenza di dove dovrà andare la scritta.celeste

Quindi i due estrusori non possono essere usati per stampare contemporaneamente i due estrusori e velocizzare la stampa come vorresti tu ma solo per stampare oggetti a più colori/materiali in quanto in ogni caso stampano solo con un estrusore alla volta. Per ogni layer stampa prima il primo estrusore, poi il secondo e poi cambia layer e cosi via.

Condividi questo messaggio


Link di questo messaggio
Condividi su altri siti

Ottima guida grazie.

Come slicer meglio usare Slic3r o CuraEngine?

Volendo invece stampare un solo oggetto con due estrusori senza dividere per colore è possibile?

Condividi questo messaggio


Link di questo messaggio
Condividi su altri siti

No la stampa a più estrusori pretende più oggetti, non esistono slicer (e sarebbe comunque parecchio complesso farli ) che possano usare più ugelli su una stessa stampa, anche il Marlin non lo prevede. Il problema non è di stampante ma di slicer, il Marlin sarebbe relativamente facile da adattare per questo scopo ma lo slicer davvero la vedo ardua, Devi tenere presente che i due estrusori si muovo assieme il che prevederebbe oggetti che hanno molte parti identiche o simmetriche, diciamo che per stampare un cubo così sarebbe semplice ma se già devi stampare una scatola sarebbe praticamente inutile usare due estrusori contemporaneamente tranne che per il fondo della scatola.

Dire se è meglio slic3r o cura è difficile, io dopo aver per anni usato Slic3r adesso preferisco Cura, mi trovo meglio per come collega i perimetri all'infill, e perchè a parità di oggetto impiega meno tempo ed usa meno materiale, cosa penso dovuta ad un infill più elementare.

 

Condividi questo messaggio


Link di questo messaggio
Condividi su altri siti

Capito, ho notato da alcune immagini su internet che su alcuni estrusori ci sono dei connettori...ha senso metterlo sugli estrusori non bowden?

Non ho neanche cominciato a stampare e sto già pensando di convertire la stampante da acrilico a profili vslot 2040. Ho trovato un progetto su thingverse e mi ha colpito tantissimo... 

Condividi questo messaggio


Link di questo messaggio
Condividi su altri siti

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Ospite
Rispondi a questa discussione...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Caricamento...



×
×
  • Crea Nuovo...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.