Vai al contenuto
SI-DESIGN
  • Iscriviti al forum

    Iscriviti al forum per restare aggiornato sulle ultime novità e poter usufruire di maggiori contenuti

deiv

Geeetech I3 Pro B - BLtouch e Z-offset

Recommended Posts

Ho installato il sensore, aggiornato il FW marlin (1.1.x) con la configurazione della mia stampante con BLTouch su scheda GT2560 A+. C'ho messo un po' a capire che il sensore di livellamento andava sullo Z-max e non sul min che invece rimane attivo con lo switch ma adesso sembra ok.

Ciò detto, faccio il livellamento e lo fa anche con 2 problemi… il primo che l'ultima fila Y è troppo avanti, il piatto arriva al limite e gratta un po'. Ma questo in qualche maniera lo risolvo, mentre l'altro è che non so come settare precisamente lo Z-offset. Per montarlo sto usando questo https://www.thingiverse.com/thing:2039119

Potete darmi un suggerimento?

 

Grazie!

Condividi questo messaggio


Link di questo messaggio
Condividi su altri siti

Grazie per il PM con la guida al BLTouch...

Ho solo una grossa perplessità riguardo alla sequenza di azioni da fare: cioè ora sto facendo

1) Accendo stampante e collego a Repetier

2) Faccio il bed leveling con LCD della stampante

3) faccio lo slicing del pezzo da stampare

4) invio la stampa

Questo è corretto? Sembrerebbe di no perchè mi aspetterei sullo stesso layer di veder muovere anche se poco l'asse Z per adattarsi alla mappa del leveling (ho un piano veramente poco "piano", quando al centro ho 0 ai bordi ho tipo -1.5mm). Invece rimane sempre alla stessa altezza con i prevedibili errori di livello.

Le mie ipotesi sono:

a) dopo aver fatto il leveling non faccio un'operazione necessaria al suo utilizzo (attivazione? salvataggio?)

b) la generazione del Gcode non va bene

 

Scusate l'ignoranza.

 

d.

Condividi questo messaggio


Link di questo messaggio
Condividi su altri siti
1 ora fa, deiv dice:

) dopo aver fatto il leveling non faccio un'operazione necessaria al suo utilizzo (attivazione? salvataggio?)

M500

Condividi questo messaggio


Link di questo messaggio
Condividi su altri siti

Dopo qualche ricerca/esperimento/log ho capito l'arcano, che posto nel caso che ci siano altri niubboni come me visto che secondo il mio modestissimo parere non è per niente ovvio: il comando G28 resetta l'utilizzo del bed leveling (ma perchè?)... Cura manda come Start G-code questo, a cui ho aggiunto le righe in grassetto per recuperare i dati salvati e abilitare il leveling

; Default start code
G28 ; Home extruder
M501; Load data 
M420 S1; enables leveling
M420 V; Prints leveling status

G1 Z15 F{Z_TRAVEL_SPEED}
M107 ; Turn off fan
G90 ; Absolute positioning
M82 ; Extruder in absolute mode
{IF_BED}M190 S{BED}
; Activate all used extruder
{IF_EXT0}M104 T0 S{TEMP0}
G92 E0 ; Reset extruder position
; Wait for all used extruders to reach temperature
{IF_EXT0}M109 T0 S{TEMP0}

 

Naturalmente questo comportamento può essere sistemato anche nel FW...

Condividi questo messaggio


Link di questo messaggio
Condividi su altri siti

Crea un account o accedi per lasciare un commento

You need to be a member in order to leave a comment

Crea un account

Iscriviti per un nuovo account nella nostra comunità. È facile!

Registra un nuovo account

Accedi

Sei già registrato? Accedi qui.

Accedi Ora

Arianeplast


  • Contenuti simili

    • Da Filippo01
      Salve chiedo aiuto per un problema con il sensore Bltouch. Ho una stampante geetech i3 pro b .Ho cercato su internet per installarlo sia via software che hardware , ho fatto dei test per verificarne il corretto funzionamente, e i comandi per muovere la barretta funzionano ma appena provo il G28 il sensore rileva il piatto e si alza ma gli stepper continuano a scendere obbligandomi a fare uno spegnimento di emergenza . Potete aiutarmi? Grazie
    • Da Marcottt
      Ciao a tutti, dopo aver qualche settimana fa aggiornato la mia anycubic delta plus al marlin 1.1.8 oggi ho montato il BLtouch originale.... dal punto di vita meccanico e elettronic dovrebbe essere tutto ok fa le sue belle cosine... si muove... etc etc ma non riesco ad usarlo.....

      Ho abilitato nel firmware il bltouch e l'UBL (infatti ora ho una marea di opzioni sul display..)  e quando uso alcuni comandi smbra andare tutto bene... però se do G28 e dopo G29... non succede nulla....
      Ho trovato una guida che diceva di fare:
       
      G28 ; Home the machine.  G29 P1 ; Universal Bed Level. This will probe a bunch of places on the bed. Takes two to four minutes.  G29 P3 ; Calculate the remaining grid/matrix. Just do it.  G29 S1 ; Saves the resulting grid to EEPROM, in slot 1  
      e dopo di mettere nello script iniziale:
      G28
      G29  (oppure G29 L1)
      però non cambia nulla... il comando G29 da solo peraltro non esegue nulla. 
       
      il comando G29 T stampa una mappa:
      READ: (0,6) (6,6)
      READ: (-115,115) (115,115)
      READ: . -4.724 -4.941 -5.157 -5.093 -5.219 -5.219
      READ: -2.917 -3.929 -4.941 -4.999 -5.093 -5.219 -5.219
      READ: -3.299 -3.929 -4.558 -4.860 -4.996 -5.204 -5.204
      READ: -2.670 -3.566 -4.463 [-4.863] -5.078 -5.267 -5.538
      READ: -2.034 -3.204 -4.375 -4.913 -5.191 -5.426 -5.426
      READ: . -3.630 -4.287 -4.944 -5.377 -5.619 -5.619
      READ: . . -4.510 -4.944 -5.377 -5.619 -5.619
      READ: (-115,-115) (115,-115)
      READ: (0,0) (6,0)
      quindi dovrebbe aver memorizzato le distante... però non riesco ad usarle, quando stampa il nozzle rimane a circa 5mm dal piatto....
      ho bisogno di aiuto.... allego i file di configurazione.
      Configuration.h
      Configuration_adv.h
  • Discussioni

  • Collaboratori più popolari

  • Chi sta navigando

    Nessun utente registrato visualizza questa pagina.

×

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.