Vai al contenuto
  • Iscriviti al forum

    Iscriviti al forum per usufruire di tutti i contenuti: la registrazione è gratuita!

Jiraya

problema bltouch u30pro

Recommended Posts

Allora finito di installare e configurare il bltouch su la mia u30pro come da guida...... premetto che il piatto magnetico della ender che per carità fa quello che può....

1 Domanda... sbaglio qualcosa io (probabile)....o pretendo troppo dal bltouch? su 64 punti di calibrazione....

in foto anche star e end gcode..... ho aggiunto g29 e m420 s1 dopo il g28

2 C'è un qualche sistema per far scaldare il nozzle dopo che ha finito la calibrazione? il piatto giusto che si scaldi a temp di stampa ma il nozzle gocciola è mi fa un disatro...

ps altezza primo layer 0.2

 

 

1.jpg

end.jpg

start.jpg

Condividi questo messaggio


Link di questo messaggio
Condividi su altri siti

nello start non vedo i comandi per scaldare nozzle o piatto prima della calibrazione

Condividi questo messaggio


Link di questo messaggio
Condividi su altri siti

ti posso garantire che li scalda.....

 

Condividi questo messaggio


Link di questo messaggio
Condividi su altri siti

Se non sbaglio gli slicer generano per prima cosa il codice che imposta la temperatura e aspetta che hotend e piatto siano caldi, dopo mette lo start gcode. Se non sbaglio slic3r permetteva di mettere i comandi della temperatura nello start gcode ed in quel caso evitava di impostarli lui come prima cosa. Però vado a memoria. Diciamo che se si può fare e come dipende dallo slicer.

Riguardo al problema principale, secondo me quel piatto è troppo irregolare. 64 punti sono già tantissimi, ma per compensarlo avresti bisogno di tipo un punto ogni 5mm. Dovresti sistemare il piatto, le compensazioni sono solo per lievi variazioni, non per un percorso da motocross 😉

  • Like 1
  • Haha 1

Condividi questo messaggio


Link di questo messaggio
Condividi su altri siti
2 ore fa, Jiraya dice:

ti posso garantire che li scalda.....

 

allora posta le prime 100 righe di un gcode generato e postale qui che vediamo dove stà l'inghippo

1 ora fa, Zmaster dice:

Se non sbaglio gli slicer generano per prima cosa il codice che imposta la temperatura e aspetta che hotend e piatto siano caldi, dopo mette lo start gcode. Se non sbaglio slic3r permetteva di mettere i comandi della temperatura nello start gcode ed in quel caso evitava di impostarli lui come prima cosa. Però vado a memoria. Diciamo che se si può fare e come dipende dallo slicer.

Riguardo al problema principale, secondo me quel piatto è troppo irregolare. 64 punti sono già tantissimi, ma per compensarlo avresti bisogno di tipo un punto ogni 5mm. Dovresti sistemare il piatto, le compensazioni sono solo per lievi variazioni, non per un percorso da motocross 😉

ho controllato hai ragione, Cura imposta il riscaldamento prima dello start gcode

Condividi questo messaggio


Link di questo messaggio
Condividi su altri siti

ecco qua le prime righe di gcode generate da cura:

;FLAVOR:Marlin
;TIME:4244
;Filament used: 1.02922m
;Layer height: 0.1
;MINX:31.4
;MINY:31.4
;MINZ:0.2
;MAXX:188.6
;MAXY:188.6
;MAXZ:2
;Generated with Cura_SteamEngine 4.6.1
M140 S50
M105
M190 S50
M104 S205
M105
M109 S205
M82 ;absolute extrusion mode
; -- START GCODE --
G21        ;metric values
G90        ;absolute positioning
M82        ;set extruder to absolute mode
M107       ;start with the fan off
G28 X0 Y0  ;move X/Y to min endstops
G28 Z0     ;move Z to min endstops
G29
m500
M420 S1
G1 Z1 F1000             ;move up slightly
G1 Y60.0 Z0 E9.0 F1000.0;intro line
G1 Y100.0 E21.5 F1000.0 ;continue line
G92 E0                  ;zero the extruded length again
G1 F80
;Put printing message on LCD screen
M117 Printing...
; -- end of START GCODE --
G92 E0
G92 E0
G1 F2700 E-5
;LAYER_COUNT:19
;LAYER:0
M107
G0 F1500 X185.54 Y31.857 Z0.2
;TYPE:SKIRT
G1 F2700 E0
G1 F1500 X186.03 Y31.983 E0.01599
G1 X186.494 Y32.185 E0.03198
G1 X186.92 Y32.457 E0.04795
G1 X187.298 Y32.792 E0.06391
G1 X187.618 Y33.183 E0.07987
G1 X187.873 Y33.62 E0.09586
G1 X188.056 Y34.091 E0.11182
G1 X188.163 Y34.585 E0.12779
G1 X188.199 Y35.24 E0.14852
G1 X188.2 Y184.304 E4.85852
G1 X188.191 Y185.031 E4.88149
G1 X188.145 Y185.534 E4.89745
G1 X188.02 Y186.024 E4.91343

Condividi questo messaggio


Link di questo messaggio
Condividi su altri siti

Si scalda tutto prima di calibrare 

Condividi questo messaggio


Link di questo messaggio
Condividi su altri siti

e come posso fare a risolvere? cioè farlo scaldare dopo l' autolivellamento?

Condividi questo messaggio


Link di questo messaggio
Condividi su altri siti
18 minuti fa, Jiraya dice:

e come posso fare a risolvere? cioè farlo scaldare dopo l' autolivellamento?

Potresti provare a impostare 0 temperatura su cura e aggiungerla nello start gcode della stampante dopo G29 opuure m420 s1 per il richiamo del livellamento

Condividi questo messaggio


Link di questo messaggio
Condividi su altri siti

e altro dubbio..... per autolivellare il piatto...dopo il G28 Z0     ;move Z to min endstops ho messo il g29....

dopo il g29 cosa devo mettere? nella guida che ho seguito dicevano di far seguire al g29 il comando M420 S1 senza l'm500...

sul forum invece g29 poi m500....... altri solo g29.....  che faccio?

 

Condividi questo messaggio


Link di questo messaggio
Condividi su altri siti
1 minuto fa, Jiraya dice:

e altro dubbio..... per autolivellare il piatto...dopo il G28 Z0     ;move Z to min endstops ho messo il g29....

dopo il g29 cosa devo mettere? nella guida che ho seguito dicevano di far seguire al g29 il comando M420 S1 senza l'm500...

sul forum invece g29 poi m500....... altri solo g29.....  che faccio?

 

M420 S1 va messo senza il G29 perché serve a far richiamare le mesh, M500 serve a salvare il livellamento sulla eeprom dopo il G29 e puoi anche non metterlo perché per quella stampa utilizzerà quel livellamento. Però che palle ad ogni stampa il livellamento, ti consiglio di farglielo fare con pronterface, salvi con M500 e nello start gcode dopo il G28 aggiungi M420 S1

Condividi questo messaggio


Link di questo messaggio
Condividi su altri siti

ma non mi disturba piu di tanto..... quindi basta mettere g29 e basta? o meglio se lo salvo con un m500 per sicurezza? m420 quindi se ho capito bene se livello ogni volta serve 0....

Condividi questo messaggio


Link di questo messaggio
Condividi su altri siti
4 ore fa, Jiraya dice:

ma non mi disturba piu di tanto..... quindi basta mettere g29 e basta? 

Si

 

4 ore fa, Jiraya dice:

 m420 quindi se ho capito bene se livello ogni volta serve 0....

Esatto non serve se metti G29 nello start gcode, te l'ho detto M420 S1 devi metterlo solo se non utilizzi G29 nello start gcode

Condividi questo messaggio


Link di questo messaggio
Condividi su altri siti

perfetto! grazie mille!!!!!

e per non scaldare l'ugello prima del g29?

 

Condividi questo messaggio


Link di questo messaggio
Condividi su altri siti
Il 9/7/2020 at 19:15, Jiraya dice:

perfetto! grazie mille!!!!!

e per non scaldare l'ugello prima del g29?

 

Questo è un enigma, ho risposto allo stesso modo anche in un altro topic ma non mi è pervenuta alcuna risposta. Io proverei a mettere riscaldamento 0 nello slicer ed impostarlo nello star gcode della stampante. La mia, naturalmente, è un ipotesi, fammi sapere 

  • Like 1

Condividi questo messaggio


Link di questo messaggio
Condividi su altri siti

Sai cge ci pensavo anche io..... Solo cge sono alle prime armi....quale conando per scaldare l'ugello alla tem desiderata dopo il g29?

Condividi questo messaggio


Link di questo messaggio
Condividi su altri siti
23 minuti fa, Jiraya dice:

Sai cge ci pensavo anche io..... Solo cge sono alle prime armi....quale conando per scaldare l'ugello alla tem desiderata dopo il g29?

Dovrebbero essere queste

M104 S205
M109 S205

Se la temperatura che vuoi impostare è 205° sennò basta che cambi quel valore

Condividi questo messaggio


Link di questo messaggio
Condividi su altri siti
13 ore fa, Jiraya dice:

Provo!

 

Hai provato? 

Condividi questo messaggio


Link di questo messaggio
Condividi su altri siti

tornato dalle ferie questa notte...questa sera mi ci metto 🙂

Condividi questo messaggio


Link di questo messaggio
Condividi su altri siti

provato adesso in pausa pranzo.....yes funziona....scalda dopo che ha calibrato....

 

M104 S205
M105
M109 S205

dopo il g29

  • Like 2

Condividi questo messaggio


Link di questo messaggio
Condividi su altri siti

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Ospite
Rispondi a questa discussione...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


I servizi di Stampa 3D forum

Seleziona il servizio che stai cercando:



×
×
  • Crea Nuovo...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.